summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/zynaddsubfx/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/zynaddsubfx/files')
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-docs.patch12
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk.patch38
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk13.patch58
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-2.4.3-nofltk.patch24
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch14
5 files changed, 146 insertions, 0 deletions
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-docs.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-docs.patch
new file mode 100644
index 000000000000..587e4a4219a9
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-docs.patch
@@ -0,0 +1,12 @@
+Index: ZynAddSubFX-2.4.1/CMakeLists.txt
+===================================================================
+--- ZynAddSubFX-2.4.1.orig/CMakeLists.txt
++++ ZynAddSubFX-2.4.1/CMakeLists.txt
+@@ -5,7 +5,3 @@ project(zynaddsubfx)
+ enable_testing()
+ #Currently the only directory that uses cmake
+ add_subdirectory(src)
+-
+-install(FILES AUTHORS.txt COPYING FAQ.txt HISTORY.txt README.txt
+- DESTINATION share/doc/zynaddsubfx
+- )
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk.patch
new file mode 100644
index 000000000000..38446d7e11ca
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk.patch
@@ -0,0 +1,38 @@
+Index: ZynAddSubFX-2.4.1/src/CMakeLists.txt
+===================================================================
+--- ZynAddSubFX-2.4.1.orig/src/CMakeLists.txt
++++ ZynAddSubFX-2.4.1/src/CMakeLists.txt
+@@ -96,24 +96,7 @@ if(FltkGui)
+ #message(STATUS "FLTK_LIBRARIES: ${FLTK_LIBRARIES}")
+ #message(STATUS "FLTK_MATH_LIBRARY: ${FLTK_MATH_LIBRARY}")
+
+- #UGLY WORKAROUND
+- find_program (MYFLTK_CONFIG fltk-config)
+- if (MYFLTK_CONFIG)
+- execute_process (COMMAND ${MYFLTK_CONFIG} --ldflags OUTPUT_VARIABLE MYFLTK_LDFLAGS)
+- string(STRIP ${MYFLTK_LDFLAGS} MYFLTK_LIBRARIES)
+- endif()
+- mark_as_advanced(FORCE FLTK_BASE_LIBRARY)
+- mark_as_advanced(FORCE FLTK_CONFIG_SCRIPT)
+- mark_as_advanced(FORCE FLTK_DIR)
+- mark_as_advanced(FORCE FLTK_FLUID_EXECUTABLE)
+- mark_as_advanced(FORCE FLTK_FORMS_LIBRARY)
+- mark_as_advanced(FORCE FLTK_GL_LIBRARY)
+- mark_as_advanced(FORCE FLTK_IMAGES_LIBRARY)
+- mark_as_advanced(FORCE FLTK_INCLUDE_DIR)
+- mark_as_advanced(FORCE FLTK_MATH_LIBRARY)
+-
+-
+- set(GUI_LIBRARIES ${FLTK_LIBRARIES} ${MYFLTK_LIBRARIES} ${OPENGL_LIBRARIES} zynaddsubfx_gui)
++ set(GUI_LIBRARIES ${FLTK_LIBRARIES} ${OPENGL_LIBRARIES} zynaddsubfx_gui)
+ add_definitions(-DFLTK_GUI)
+
+ message(STATUS "Will build fltk gui")
+@@ -121,6 +104,7 @@ if(FltkGui)
+ include_directories(
+ "${CMAKE_CURRENT_SOURCE_DIR}/UI"
+ "${CMAKE_CURRENT_BINARY_DIR}/UI"
++ ${FLTK_INCLUDE_DIR}
+ )
+
+ add_subdirectory(UI)
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk13.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk13.patch
new file mode 100644
index 000000000000..72fa30a68145
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.1-fltk13.patch
@@ -0,0 +1,58 @@
+Sounds hackish but that's the only way I found to force it to generate the
+functions in the .cxx files with fluid 1.3...
+
+Index: ZynAddSubFX-2.4.1/src/UI/BankUI.fl
+===================================================================
+--- ZynAddSubFX-2.4.1.orig/src/UI/BankUI.fl
++++ ZynAddSubFX-2.4.1/src/UI/BankUI.fl
+@@ -32,7 +32,7 @@ decl {\#include "../Misc/Config.h"} {pub
+
+ class BankProcess_ {} {
+ Function {process()} {open return_type {virtual void}
+- } {}
++ } {code{;}}
+ decl {Bank *bank;} {public
+ }
+ }
+Index: ZynAddSubFX-2.4.1/src/UI/OscilGenUI.fl
+===================================================================
+--- ZynAddSubFX-2.4.1.orig/src/UI/OscilGenUI.fl
++++ ZynAddSubFX-2.4.1/src/UI/OscilGenUI.fl
+@@ -129,7 +129,7 @@ delete [] spc;} {selected
+
+ class PSlider {: {public Fl_Slider}
+ } {
+- Function {PSlider(int x,int y, int w, int h, const char *label=0):Fl_Slider(x,y,w,h,label)} {} {}
++ Function {PSlider(int x,int y, int w, int h, const char *label=0):Fl_Slider(x,y,w,h,label)} {} {code{;}}
+ Function {handle(int event)} {return_type int
+ } {
+ code {int X=x(),Y=y(),W=w(),H=h();
+Index: ZynAddSubFX-2.4.1/src/UI/PartUI.fl
+===================================================================
+--- ZynAddSubFX-2.4.1.orig/src/UI/PartUI.fl
++++ ZynAddSubFX-2.4.1/src/UI/PartUI.fl
+@@ -85,7 +85,7 @@ end();} {}
+
+ class PartUI_ {} {
+ Function {showparameters(int kititem,int engine)} {return_type virtual
+- } {}
++ } {code{;}}
+ }
+
+ class PartKitItem {: {public Fl_Group}
+Index: ZynAddSubFX-2.4.1/src/UI/PresetsUI.fl
+===================================================================
+--- ZynAddSubFX-2.4.1.orig/src/UI/PresetsUI.fl
++++ ZynAddSubFX-2.4.1/src/UI/PresetsUI.fl
+@@ -18,9 +18,9 @@ decl {\#include "../Params/Presets.h"} {
+
+ class PresetsUI_ {} {
+ Function {refresh()} {open return_type {virtual void}
+- } {}
++ } {code{;}}
+ Function {~PresetsUI_()} {open return_type virtual
+- } {}
++ } {code{;}}
+ }
+
+ class PresetsUI {} {
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.3-nofltk.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.3-nofltk.patch
new file mode 100644
index 000000000000..c20828328f26
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-2.4.3-nofltk.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/show_bug.cgi?id=437018
+
+Index: ZynAddSubFX-2.4.3/src/main.cpp
+===================================================================
+--- ZynAddSubFX-2.4.3.orig/src/main.cpp
++++ ZynAddSubFX-2.4.3/src/main.cpp
+@@ -37,8 +37,6 @@
+ #include "Misc/Dump.h"
+ extern Dump dump;
+
+-#include <FL/Fl.H>
+-
+ //Nio System
+ #include "Nio/Nio.h"
+
+@@ -51,6 +49,8 @@ QApplication *app;
+
+ #elif defined FLTK_GUI
+
++#include <FL/Fl.H>
++
+ #include "UI/MasterUI.h"
+ #endif // FLTK_GUI
+
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch
new file mode 100644
index 000000000000..a1b7d9332ea5
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-2.5.0-docs.patch
@@ -0,0 +1,14 @@
+Index: zynaddsubfx-2.5.0/CMakeLists.txt
+===================================================================
+--- zynaddsubfx-2.5.0.orig/CMakeLists.txt
++++ zynaddsubfx-2.5.0/CMakeLists.txt
+@@ -27,9 +27,6 @@ include(CTestConfig.cmake)
+ #Currently the only directory that uses cmake
+ add_subdirectory(src)
+
+-install(FILES AUTHORS.txt COPYING FAQ.txt HISTORY.txt README.adoc
+- DESTINATION share/doc/zynaddsubfx
+- )
+ install(FILES zynaddsubfx-jack.desktop zynaddsubfx-alsa.desktop
+ DESTINATION share/applications)
+ install(FILES zynaddsubfx.svg