summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/angst
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/angst')
-rw-r--r--net-analyzer/angst/Manifest1
-rw-r--r--net-analyzer/angst/angst-0.4b-r2.ebuild42
-rw-r--r--net-analyzer/angst/files/0.4b-libnet-1.0.patch12
-rw-r--r--net-analyzer/angst/metadata.xml6
4 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/angst/Manifest b/net-analyzer/angst/Manifest
new file mode 100644
index 000000000000..3cbb8d0646ae
--- /dev/null
+++ b/net-analyzer/angst/Manifest
@@ -0,0 +1 @@
+DIST angst-0.4b.tar.gz 13909 SHA256 609a7008030649171d6041bd1dd29ec1644db011ad7f8ba2074727a583366dc8 SHA512 5584b1dd01d781cd34b594fcc8970764874599a1f15b1185066ee21c11cde23af148270c178d6a0b3436d71955aaf1cd904703f9dfb0c75d0b70c04d394fb449 WHIRLPOOL 85ece3435a9adf81d20a4579beb86f96002fbe8b8f6d75e96080a88fdc4a0dc3fc133db09fab818874571709e07ec8c73ec26c5391bc2dda46a65b1ef478b0b4
diff --git a/net-analyzer/angst/angst-0.4b-r2.ebuild b/net-analyzer/angst/angst-0.4b-r2.ebuild
new file mode 100644
index 000000000000..84b29ec14f97
--- /dev/null
+++ b/net-analyzer/angst/angst-0.4b-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="an active sniffer that provides methods for aggressive sniffing on switched LANs"
+HOMEPAGE="http://angst.sourceforge.net/"
+SRC_URI="http://angst.sourceforge.net/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+DEPEND="net-libs/libpcap
+ net-libs/libnet:1.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp -av Makefile.linux{,.orig}
+ epatch "${FILESDIR}"/${PV}-libnet-1.0.patch
+ sed -i Makefile.linux \
+ -e 's|^CC =|CC ?=|g' \
+ -e '/ -o angst /s|$(OBJS)|$(LDFLAGS) &|g' \
+ || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ -f Makefile.linux
+}
+
+src_install() {
+ dosbin angst
+ doman angst.8
+ dodoc README TODO ChangeLog
+}
diff --git a/net-analyzer/angst/files/0.4b-libnet-1.0.patch b/net-analyzer/angst/files/0.4b-libnet-1.0.patch
new file mode 100644
index 000000000000..b78243a1a187
--- /dev/null
+++ b/net-analyzer/angst/files/0.4b-libnet-1.0.patch
@@ -0,0 +1,12 @@
+--- Makefile.linux.orig 2003-08-19 01:22:26.737300264 -0400
++++ Makefile.linux 2003-08-19 01:22:26.745299048 -0400
+@@ -14,2 +14,2 @@
+-LIBS = -L/usr/local/lib `libnet-config --libs` -lpcap
+-DEFINE = `libnet-config --defines` -DLINUX #-DDEBUG
++LIBS = -L/usr/local/lib `libnet-1.0-config --libs` -lpcap
++DEFINE = `libnet-1.0-config --defines` -DLINUX #-DDEBUG
+--- angst.h.orig 2003-08-19 01:22:26.741299656 -0400
++++ angst.h 2003-08-19 01:22:26.751298136 -0400
+@@ -12 +12 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
diff --git a/net-analyzer/angst/metadata.xml b/net-analyzer/angst/metadata.xml
new file mode 100644
index 000000000000..ed71c61c5906
--- /dev/null
+++ b/net-analyzer/angst/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>an active sniffer that provides methods for aggressive sniffing on switched LAN</longdescription>
+</pkgmetadata>