summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/cloudshark
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/cloudshark')
-rw-r--r--net-analyzer/cloudshark/Manifest2
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild49
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild49
-rw-r--r--net-analyzer/cloudshark/files/cs_log_dir.patch13
-rw-r--r--net-analyzer/cloudshark/metadata.xml11
5 files changed, 124 insertions, 0 deletions
diff --git a/net-analyzer/cloudshark/Manifest b/net-analyzer/cloudshark/Manifest
new file mode 100644
index 000000000000..fd3dd400511d
--- /dev/null
+++ b/net-analyzer/cloudshark/Manifest
@@ -0,0 +1,2 @@
+DIST cloudshark-plugin-1.0.2-174.tgz 143067 SHA256 d5918e9e3dc60059bdc40d436409c18197df428266863d90367a762f08c3623e SHA512 42445e67630b1bd2968f0836f625acb3792f22257de104ec0b90c59fa8d2096649eba2252cd6161ce57c8ff79095d52c5663d2fa018c650667896c9905e9dd7e WHIRLPOOL 01f3f6bc87b3f09645d2fef953d84b7ba3828f960d7e9bb952bf18cbeb8422beb63cee21355434f392727795b0462e59fd2b07549cce6048e689e5e02bcdd19d
+DIST cloudshark-plugin-1.0.3-180.tgz 143381 SHA256 0c0b204622107dcb29d302401688b62fa3b904eb0b5ccfa6bb42802084f5d102 SHA512 765144e6a2c7ce17eaa05f8170216e08ccac224ba6c11750893ae5caa8f40a2b6bee883fd9be91fa800ad3b45dc42d2ec81e564aa573015a91a8537be8384c73 WHIRLPOOL 818abb8dd904c72fe870336bb3702df04af7299c6e3bbed21510a0a4484997ec4eef68c14f0a556285f82a89ef57fd9768c6814cc3311c4abd28194d70159926
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
new file mode 100644
index 000000000000..67366efedb2f
--- /dev/null
+++ b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+SV="1.0.2-174"
+
+DESCRIPTION="Easily upload your wireshark captures to CloudShark"
+HOMEPAGE="http://appliance.cloudshark.org/plug-ins-wireshark.html"
+SRC_URI="http://appliance.cloudshark.org/downloads/${PN}-plugin-${SV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PDEPEND="net-analyzer/wireshark:=[lua]
+ net-misc/curl"
+
+S="${WORKDIR}/${PN}-${SV}"
+
+get_PV() {
+ local pv=$(best_version $1)
+ pv=${pv#$1-}; pv=${pv%-r*}
+ pv=${pv//_}; echo ${pv}
+}
+
+src_prepare() {
+ #cloudshark isn't meant to be installed systemwide, we fix that
+ epatch "${FILESDIR}"/cs_log_dir.patch
+
+ sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
+ #causes errors, looks like it expects windows paths only
+ #echo "CLOUDSHARK_CABUNDLE = /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt" >> cloudshark_init.default
+ sed -i "s#%s/curl-ca-bundle.crt#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt#" cloudshark.lua
+
+ #stuff to fix cloudshark_init.default to be more sane
+ #sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default (tshark support doesn't seem to work)
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
+ doins cloudshark.lua json.lua version.lua curl-ca-bundle.crt
+ newins cloudshark_init.default cloudshark_init.lua
+ dodoc CLOUDSHARK_README.txt
+}
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild
new file mode 100644
index 000000000000..79691a21d1b7
--- /dev/null
+++ b/net-analyzer/cloudshark/cloudshark-1.0.3.180.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+SV="1.0.3-180"
+
+DESCRIPTION="Easily upload your wireshark captures to CloudShark"
+HOMEPAGE="http://appliance.cloudshark.org/plug-ins-wireshark.html"
+SRC_URI="http://appliance.cloudshark.org/plugin/${PN}-plugin-${SV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PDEPEND="net-analyzer/wireshark:=[lua]
+ net-misc/curl"
+
+S="${WORKDIR}/${PN}-${SV}"
+
+get_PV() {
+ local pv=$(best_version $1)
+ pv=${pv#$1-}; pv=${pv%-r*}
+ pv=${pv//_}; echo ${pv}
+}
+
+src_prepare() {
+ #cloudshark isn't meant to be installed systemwide, we fix that
+ epatch "${FILESDIR}"/cs_log_dir.patch
+
+ sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
+ #causes errors, looks like it expects windows paths only
+ #echo "CLOUDSHARK_CABUNDLE = /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt" >> cloudshark_init.default
+ sed -i "s#%s/curl-ca-bundle.crt#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt#" cloudshark.lua
+
+ #stuff to fix cloudshark_init.default to be more sane
+ #sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default (tshark support doesn't seem to work)
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
+ doins cloudshark.lua json.lua version.lua curl-ca-bundle.crt
+ newins cloudshark_init.default cloudshark_init.lua
+ dodoc CLOUDSHARK_README.txt
+}
diff --git a/net-analyzer/cloudshark/files/cs_log_dir.patch b/net-analyzer/cloudshark/files/cs_log_dir.patch
new file mode 100644
index 000000000000..9b0424e3cd44
--- /dev/null
+++ b/net-analyzer/cloudshark/files/cs_log_dir.patch
@@ -0,0 +1,13 @@
+diff -Naur cloudshark-1.0.2-174-orig/cloudshark.lua cloudshark-1.0.2-174/cloudshark.lua
+--- cloudshark-1.0.2-174-orig/cloudshark.lua 2013-06-03 00:00:46.669223099 -0400
++++ cloudshark-1.0.2-174/cloudshark.lua 2013-06-03 00:01:31.493224300 -0400
+@@ -180,7 +180,8 @@
+ --
+
+ function cs_log_dir()
+- return persconffile_path('plugins/cloudshark')
++ local log_dir = "/tmp"
++ return log_dir
+ end
+
+ --
diff --git a/net-analyzer/cloudshark/metadata.xml b/net-analyzer/cloudshark/metadata.xml
new file mode 100644
index 000000000000..5fcbf8e1851a
--- /dev/null
+++ b/net-analyzer/cloudshark/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+