summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/multimon-ng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/multimon-ng')
-rw-r--r--net-analyzer/multimon-ng/Manifest1
-rw-r--r--net-analyzer/multimon-ng/metadata.xml14
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-1.0.0-r1.ebuild39
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-9999.ebuild39
4 files changed, 93 insertions, 0 deletions
diff --git a/net-analyzer/multimon-ng/Manifest b/net-analyzer/multimon-ng/Manifest
new file mode 100644
index 000000000000..b23677c16e91
--- /dev/null
+++ b/net-analyzer/multimon-ng/Manifest
@@ -0,0 +1 @@
+DIST multimon-ng-1.0.0.tar.gz 67095 SHA256 521bad293288c0c7c0c1934a36d54c6ea87f0557b197920ff32a2782627e132b SHA512 0fa475c7908bc24a9558c5a7e0aa4737fca117ff323a012b4316ad02840eb97f917a02d1daec50645729c2ca834068467ddc409cbc36af9cd5ffb9e8f6e5e3e9 WHIRLPOOL bb560c0329e61b171e8110f5fd13fde0273b64f2b44e40d5785ee163a604719845a3b38a190399187d31ebab08206c327b906aa073529aa8afc11176d46c1be7
diff --git a/net-analyzer/multimon-ng/metadata.xml b/net-analyzer/multimon-ng/metadata.xml
new file mode 100644
index 000000000000..1bd4de7592ac
--- /dev/null
+++ b/net-analyzer/multimon-ng/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <herd>radio</herd>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">EliasOenal/multimonNG</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/multimon-ng/multimon-ng-1.0.0-r1.ebuild b/net-analyzer/multimon-ng/multimon-ng-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..d8f994874509
--- /dev/null
+++ b/net-analyzer/multimon-ng/multimon-ng-1.0.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
+HOMEPAGE="https://github.com/EliasOenal/multimonNG"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/EliasOenal/multimonNG.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/multimonNG-${PV}
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pulseaudio"
+
+DEPEND="pulseaudio? ( media-sound/pulseaudio )
+ dev-qt/qtcore:4
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use !pulseaudio; then
+ sed -i -e 's/-lpulse-simple//' -e 's/-lpulse//' -e 's/PULSE/DUMMY/' ${PN}.pro || die
+ fi
+ qt4-r2_src_prepare
+}
+src_install() {
+ dobin ${PN}
+}
diff --git a/net-analyzer/multimon-ng/multimon-ng-9999.ebuild b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
new file mode 100644
index 000000000000..d8f994874509
--- /dev/null
+++ b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
+HOMEPAGE="https://github.com/EliasOenal/multimonNG"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/EliasOenal/multimonNG.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/multimonNG-${PV}
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pulseaudio"
+
+DEPEND="pulseaudio? ( media-sound/pulseaudio )
+ dev-qt/qtcore:4
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use !pulseaudio; then
+ sed -i -e 's/-lpulse-simple//' -e 's/-lpulse//' -e 's/PULSE/DUMMY/' ${PN}.pro || die
+ fi
+ qt4-r2_src_prepare
+}
+src_install() {
+ dobin ${PN}
+}