summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nagios-check_glsa2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nagios-check_glsa2')
-rw-r--r--net-analyzer/nagios-check_glsa2/Manifest1
-rw-r--r--net-analyzer/nagios-check_glsa2/metadata.xml19
-rw-r--r--net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild43
3 files changed, 63 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_glsa2/Manifest b/net-analyzer/nagios-check_glsa2/Manifest
new file mode 100644
index 000000000000..58d518bea67f
--- /dev/null
+++ b/net-analyzer/nagios-check_glsa2/Manifest
@@ -0,0 +1 @@
+DIST check_glsa2-20120930.tar.xz 1980 SHA256 cb5f73b0482c88ace0ba02499443a5f903773f57dc7967840711a58e5ff1aed5 SHA512 ecf7f6f119c8a73bf672eddc64374ed07c03720ec97b51f7e0bd779b3ba2c4ceab87c1c3cbbe38b1f0224234a9fb2af7bd156f9073a8a0aa8da1458988a2bc65 WHIRLPOOL 23c901c4bd2d0ad1b15af6f75c56500fa6f0c0b4204022c95aecfeb4d010f60c0aa87766c6e748f9bf34de5cc1856bbddf437875fa381568de30013378be53eb
diff --git a/net-analyzer/nagios-check_glsa2/metadata.xml b/net-analyzer/nagios-check_glsa2/metadata.xml
new file mode 100644
index 000000000000..0475fa3cf108
--- /dev/null
+++ b/net-analyzer/nagios-check_glsa2/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>andrew@ahamilto.net</email>
+ <name>Andrew Hamilton</name>
+ <description>Maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>creffett@gentoo.org</email>
+ <name>Chris Reffett</name>
+ <description>Proxy maintainer. CC him on bugs.</description>
+ </maintainer>
+ <herd>proxy-maintainers</herd>
+ <herd>sysadmin</herd>
+ <upstream>
+ <remote-id type="github">craig/check_glsa2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild b/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
new file mode 100644
index 000000000000..8c2ae355ee22
--- /dev/null
+++ b/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib user
+
+DESCRIPTION="Nagios check script for GLSAs (Gentoo Linux Security Advisories)"
+HOMEPAGE="https://github.com/craig/check_glsa2"
+
+MY_PN="${PN/nagios-/}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI="http://dev.gentoo.org/~flameeyes/${MY_PN}/${MY_P}.tar.xz"
+LICENSE="GPL-2 BSD-2"
+SLOT="0"
+
+KEYWORDS="amd64"
+
+RDEPEND="app-portage/gentoolkit"
+DEPEND=""
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /dev/null nagios
+}
+
+src_prepare() {
+ sed -i -e '/CACHEDIR=/s:=.*:=/var/cache/check_glsa2:' ${MY_PN}_cached.sh || die
+}
+
+src_install() {
+ local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
+ exeinto ${nagiosplugindir}
+ doexe *.sh
+
+ dodoc README
+
+ diropts -o nagios -g nagios
+ keepdir /var/cache/${MY_PN}
+}