summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2018-09-22 18:50:58 -0400
committerMichael Orlitzky <mjo@gentoo.org>2018-09-22 21:27:01 -0400
commit01aa5c86f215262b6ebac3b597553e6d2b487ea7 (patch)
tree5560e25053b4c08818e5cc3220bd9db5c125c80e /net-analyzer/ndoutils
parentnet-im/mcabber: add improved -r1 for 1.1.0 (diff)
downloadgentoo-01aa5c86f215262b6ebac3b597553e6d2b487ea7.tar.gz
gentoo-01aa5c86f215262b6ebac3b597553e6d2b487ea7.tar.bz2
gentoo-01aa5c86f215262b6ebac3b597553e6d2b487ea7.zip
net-analyzer/ndoutils: replace virtual/mysql build-time dependency.
The ndoutils build system (m4/np_mysqlclient.m4) requires the mysql_config program at build time but doesn't require any of the other server files to be present Per bug 665954, I've replaced the virtual/mysql DEPEND with dev-db/mysql-connector-c. The mysql virtual is still used in RDEPEND because, as far as I know, either server is still supported at runtime regardless of the client library in use. In an unrelated change, two symlinks were made relative to please repoman. Their targets were also made executable, since otherwise you can't run them via the symlinks. Closes: https://bugs.gentoo.org/665954 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/ndoutils')
-rw-r--r--net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild (renamed from net-analyzer/ndoutils/ndoutils-2.1.3.ebuild)22
1 files changed, 14 insertions, 8 deletions
diff --git a/net-analyzer/ndoutils/ndoutils-2.1.3.ebuild b/net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild
index 1872b7849d8d..57a0389779bc 100644
--- a/net-analyzer/ndoutils/ndoutils-2.1.3.ebuild
+++ b/net-analyzer/ndoutils/ndoutils-2.1.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,11 +14,12 @@ KEYWORDS="~amd64 ~ppc ~x86"
# We require the "nagios" user from net-analyzer/nagios-core at build
# time.
-DEPEND="dev-perl/DBD-mysql
+DEPEND="dev-db/mysql-connector-c
+ dev-perl/DBD-mysql
dev-perl/DBI
- >=net-analyzer/nagios-core-4
+ >=net-analyzer/nagios-core-4"
+RDEPEND="${DEPEND}
virtual/mysql"
-RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${P}"
@@ -74,12 +75,17 @@ src_install() {
# The documentation isn't installed by the build system
dodoc -r docs/html
- # Use symlinks because the installdb/upgradedb scripts use relative
- # paths to the SQL queries.
insinto "/usr/share/${PN}"
doins -r db
- dosym "/usr/share/${PN}/db/installdb" /usr/bin/ndoutils-installdb
- dosym "/usr/share/${PN}/db/upgradedb" /usr/bin/ndoutils-upgradedb
+
+ # These need to be executable...
+ exeinto "/usr/share/${PN}/db"
+ doexe db/{installdb,prepsql,upgradedb}
+
+ # Use symlinks because the installdb/upgradedb scripts use relative
+ # paths to the SQL queries.
+ dosym "../share/${PN}/db/installdb" /usr/bin/ndoutils-installdb
+ dosym "../share/${PN}/db/upgradedb" /usr/bin/ndoutils-upgradedb
}
pkg_postinst() {