summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/neti
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/neti')
-rw-r--r--net-analyzer/neti/Manifest1
-rw-r--r--net-analyzer/neti/files/neti-init220
-rw-r--r--net-analyzer/neti/metadata.xml8
-rw-r--r--net-analyzer/neti/neti-2.0-r1.ebuild55
-rw-r--r--net-analyzer/neti/neti-2.0.ebuild49
5 files changed, 133 insertions, 0 deletions
diff --git a/net-analyzer/neti/Manifest b/net-analyzer/neti/Manifest
new file mode 100644
index 000000000000..f33c7896ba46
--- /dev/null
+++ b/net-analyzer/neti/Manifest
@@ -0,0 +1 @@
+DIST neti-2.0.tar.gz 383442 SHA256 483f2955baa17a1143ea60ead4a6744f4802dbe8a8a55ad22bd9992322a6e867 SHA512 5a1156195106e8dcb738c5d2efdd88b77803fa16145db182f2d782a21316fac18af6812b264ece3bc49a5d6713b2aa86aca13129edd01753bf5cf0dd33b1aeb5 WHIRLPOOL 2a4cc1701e30b43f436adf9097c143c8f0cf5b0c49319f81626261a2ad6bfd9f42ad27bcd1fa8aa38d4d6cfbd9662996380c4fd8c791434a6ff766997cb84f20
diff --git a/net-analyzer/neti/files/neti-init2 b/net-analyzer/neti/files/neti-init2
new file mode 100644
index 000000000000..be967841b6f7
--- /dev/null
+++ b/net-analyzer/neti/files/neti-init2
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting netiathome"
+ start-stop-daemon --start --quiet --exec /usr/sbin/neti -- -D
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping netiathome"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/neti
+ eend $?
+}
diff --git a/net-analyzer/neti/metadata.xml b/net-analyzer/neti/metadata.xml
new file mode 100644
index 000000000000..fce9bd0bf3c6
--- /dev/null
+++ b/net-analyzer/neti/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">neti</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/neti/neti-2.0-r1.ebuild b/net-analyzer/neti/neti-2.0-r1.ebuild
new file mode 100644
index 000000000000..1ba478dd6780
--- /dev/null
+++ b/net-analyzer/neti/neti-2.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="NETI@Home research project from GATech"
+HOMEPAGE="http://www.neti.gatech.edu"
+SRC_URI="mirror://sourceforge/neti/${P}.tar.gz"
+
+KEYWORDS="~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib java"
+
+DEPEND="
+ java? ( || ( >=virtual/jdk-1.2 >=virtual/jre-1.2 ) )
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_with zlib)
+}
+
+src_compile() {
+ emake NETILogParse neti
+
+ use java && emake javadir=/usr/share/${PN} classjava.stamp
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ install-sbinPROGRAMS \
+ install-sysconfDATA \
+ install-man \
+ install-info
+
+ if use java; then
+ emake \
+ DESTDIR="${D}" \
+ javadir=/usr/share/${PN} \
+ install-javaJAVA \
+ install-javaDATA
+
+ echo cd /usr/share/${PN}\;java -cp /usr/share/${PN} NETIMap > "${WORKDIR}"/NETIMap
+ dobin "${WORKDIR}"/NETIMap
+ fi
+
+ dodoc README AUTHORS
+ newinitd "${FILESDIR}"/neti-init2 neti
+}
diff --git a/net-analyzer/neti/neti-2.0.ebuild b/net-analyzer/neti/neti-2.0.ebuild
new file mode 100644
index 000000000000..3e0cd53b4612
--- /dev/null
+++ b/net-analyzer/neti/neti-2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="NETI@Home research project from GATech"
+HOMEPAGE="http://www.neti.gatech.edu"
+SRC_URI="mirror://sourceforge/neti/${P}.tar.gz"
+
+KEYWORDS="~ppc x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib java"
+
+DEPEND="java? ( || ( >=virtual/jdk-1.2 >=virtual/jre-1.2 ) )
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_compile() {
+ econf \
+ $(use_with zlib) \
+ || die "econf failed"
+
+ emake NETILogParse neti \
+ || die "emake NETILogParse neti failed"
+
+ if use java;
+ then
+ emake javadir=/usr/share/${PN} classjava.stamp || die "emake classjava.stamp failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-sbinPROGRAMS \
+ install-sysconfDATA install-man install-info || die "emake install failed"
+
+ if use java;
+ then
+ emake javadir=/usr/share/${PN} \
+ DESTDIR="${D}" install-javaJAVA install-javaDATA || die "emake java install failed"
+ dobin /usr/bin
+ echo cd /usr/share/${PN}\;java -cp /usr/share/${PN} NETIMap > "${D}"/usr/bin/NETIMap
+ fperms ugo+x /usr/bin/NETIMap
+ fi
+
+ dodoc README AUTHORS
+ newinitd "${FILESDIR}"/neti-init2 neti
+}