summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nikto
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nikto')
-rw-r--r--net-analyzer/nikto/Manifest2
-rw-r--r--net-analyzer/nikto/metadata.xml7
-rw-r--r--net-analyzer/nikto/nikto-1.36.ebuild51
-rw-r--r--net-analyzer/nikto/nikto-2.1.5.ebuild56
4 files changed, 116 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
new file mode 100644
index 000000000000..58a51de9c222
--- /dev/null
+++ b/net-analyzer/nikto/Manifest
@@ -0,0 +1,2 @@
+DIST nikto-1.36.tar.gz 206921 SHA256 a5c7f10e73b3ab9d262732a1377902589a7cde268666db892cc59f4b00e1bedc
+DIST nikto-2.1.5.tar.bz2 311580 SHA256 65b99c1fdec14d1d5e7cbc964f70fce162cbec50aee878e1500e2d22df079b34 SHA512 623b0fa923c05ecc4b69087321b544941f09b4d84fb7a32f6970e2ea42b2018f2c4e2d1cd0fabfc1c99a2ca7b57fd8c0d9f5f13c86e7eb102f00bdfd3062a95f WHIRLPOOL c4b15484b3fcb9df9219743cc138073b9b24673cf1e20d066dd632da3dc8aa0ac21d5cd7bc5e012a8bfea8d75fc82d25d85fd37e0038bf9c217e8437eb2cea0d
diff --git a/net-analyzer/nikto/metadata.xml b/net-analyzer/nikto/metadata.xml
new file mode 100644
index 000000000000..1470e032181b
--- /dev/null
+++ b/net-analyzer/nikto/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/nikto/nikto-1.36.ebuild b/net-analyzer/nikto/nikto-1.36.ebuild
new file mode 100644
index 000000000000..be40238112e1
--- /dev/null
+++ b/net-analyzer/nikto/nikto-1.36.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Web Server vulnerability scanner"
+HOMEPAGE="http://www.cirt.net/Nikto2"
+SRC_URI="http://www.cirt.net/source/nikto/ARCHIVE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc sparc x86"
+RDEPEND="dev-lang/perl
+ >=net-analyzer/nmap-3.00
+ ssl? ( dev-libs/openssl )"
+IUSE="ssl"
+
+src_compile() {
+ sed -i -e 's:config.txt:nikto.conf:' \
+ -i -e 's:\$CFG{configfile}="nikto.conf":\$CFG{configfile}="/etc/nikto/nikto.conf":' \
+ nikto.pl
+
+ mv config.txt nikto.conf
+
+ sed -i -e 's:^#NMAP:NMAP:' \
+ -i -e 's:^PROXYHOST:#PROXYHOST:' \
+ -i -e 's:^PROXYPORT:#PROXYPORT:' \
+ -i -e 's:^PROXYUSER:#PROXYUSER:' \
+ -i -e 's:^PROXYPASS:#PROXYPASS:' \
+ -i -e 's:# PLUGINDIR=/usr/local/nikto/plugins:PLUGINDIR=/usr/share/nikto/plugins:' \
+ nikto.conf
+
+ cp "${S}/docs/nikto-${PV}.man" "${WORKDIR}/${PN}.1"
+}
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf
+
+ dodir /usr/bin
+ dobin nikto.pl
+ dosym /usr/bin/nikto.pl /usr/bin/nikto
+
+ dodir /usr/share/nikto/plugins
+ insinto /usr/share/nikto/plugins
+ doins plugins/*
+
+ cd docs
+ dodoc CHANGES.txt LICENSE.txt README_plugins.txt nikto_usage.txt
+ dohtml nikto_usage.html
+ doman "${WORKDIR}/${PN}.1"
+}
diff --git a/net-analyzer/nikto/nikto-2.1.5.ebuild b/net-analyzer/nikto/nikto-2.1.5.ebuild
new file mode 100644
index 000000000000..aa1e74e0c6b1
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Web Server vulnerability scanner"
+HOMEPAGE="http://www.cirt.net/Nikto2"
+SRC_URI="http://www.cirt.net/nikto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ssl"
+
+RDEPEND="
+ dev-lang/perl
+ >=net-libs/libwhisker-2.5
+ ssl? (
+ dev-libs/openssl:0=
+ dev-perl/Net-SSLeay
+ )"
+
+src_prepare() {
+ sed -i -e 's:config.txt:nikto.conf:g' plugins/* || die
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:;
+ s:# EXECDIR=/usr/local/nikto:EXECDIR=/usr/share/nikto:;
+ s:# use LW2:use LW2:;
+ s:require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":# require "$CONFIGFILE{'\''PLUGINDIR'\''}/LW2.pm":;' nikto.pl || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf
+
+ dobin nikto.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ NIKTO_PMS='JSON-PP.pm'
+ einfo "symlinking ${NIKTO_PMS} to ${VENDOR_LIB}"
+
+ for _PM in ${NIKTO_PMS}; do
+ _TARGET=${VENDOR_LIB}/${_PM}
+ dosym /usr/share/nikto/plugins/${_PM} ${_TARGET}
+ done
+
+ dodoc docs/*.txt
+ dohtml docs/nikto_manual.html
+}