summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/snmptt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/snmptt')
-rw-r--r--net-analyzer/snmptt/Manifest2
-rw-r--r--net-analyzer/snmptt/files/snmptt.initd20
-rw-r--r--net-analyzer/snmptt/files/snmptt.initd-r120
-rw-r--r--net-analyzer/snmptt/metadata.xml9
-rw-r--r--net-analyzer/snmptt/snmptt-1.2.ebuild60
-rw-r--r--net-analyzer/snmptt/snmptt-1.4.ebuild53
6 files changed, 164 insertions, 0 deletions
diff --git a/net-analyzer/snmptt/Manifest b/net-analyzer/snmptt/Manifest
new file mode 100644
index 000000000000..6312e9ee2e23
--- /dev/null
+++ b/net-analyzer/snmptt/Manifest
@@ -0,0 +1,2 @@
+DIST snmptt_1.2.tgz 135132 SHA256 0e2756e3d75c59020af7eba668fc834f688330dc14401a6ec43f63ade6baa3b8
+DIST snmptt_1.4.tgz 148504 SHA256 512c33ecdf06da8b3c75082c1506e4b4091ddb714d0d9564771aa12ddc98ef99 SHA512 200ebe565766c15f85b9b9cbc178baeef740663efc951af4c790c4b28d27398c14a95c4b38306ec3503cefe9b86634d5f24ec5f2482694f07789e9025ea39a80 WHIRLPOOL 106c1a6b143bd3d3f68b1c20951edc84877783f1c8b7dcaa17090705695000979c34931e2ee1bb1b184c12704c3ce76f3a8eee1652738af1f59af18ec3e2d29d
diff --git a/net-analyzer/snmptt/files/snmptt.initd b/net-analyzer/snmptt/files/snmptt.initd
new file mode 100644
index 000000000000..1997851253bd
--- /dev/null
+++ b/net-analyzer/snmptt/files/snmptt.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net snmptrapd
+}
+
+start() {
+ ebegin "Starting snmptt"
+ start-stop-daemon --start --pidfile /var/run/snmptt.pid --exec /usr/sbin/snmptt
+ eend
+}
+
+stop() {
+ ebegin "Stopping snmptt"
+ start-stop-daemon --stop --pidfile /var/run/snmptt.pid
+ eend
+}
diff --git a/net-analyzer/snmptt/files/snmptt.initd-r1 b/net-analyzer/snmptt/files/snmptt.initd-r1
new file mode 100644
index 000000000000..fcbde4d947ee
--- /dev/null
+++ b/net-analyzer/snmptt/files/snmptt.initd-r1
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need snmptrapd
+}
+
+start() {
+ ebegin "Starting snmptt"
+ start-stop-daemon --start --pidfile /run/snmptt.pid --exec /usr/sbin/snmptt
+ eend
+}
+
+stop() {
+ ebegin "Stopping snmptt"
+ start-stop-daemon --stop --pidfile /run/snmptt.pid
+ eend
+}
diff --git a/net-analyzer/snmptt/metadata.xml b/net-analyzer/snmptt/metadata.xml
new file mode 100644
index 000000000000..f01e891b3e80
--- /dev/null
+++ b/net-analyzer/snmptt/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>SNMP Trap Translator</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">snmptt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/snmptt/snmptt-1.2.ebuild b/net-analyzer/snmptt/snmptt-1.2.ebuild
new file mode 100644
index 000000000000..8cf5a8091b84
--- /dev/null
+++ b/net-analyzer/snmptt/snmptt-1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="SNMP Trap Translator"
+SRC_URI="mirror://sourceforge/snmptt/${MY_P}.tgz"
+HOMEPAGE="http://www.snmptt.org/"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc x86"
+SLOT="0"
+IUSE="mysql postgres"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ dev-perl/Config-IniFiles
+ >=net-analyzer/net-snmp-5.1
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 105354, daemonize this thing
+ sed -i -e "s:mode = standalone:mode = daemon:g" snmptt.ini || die
+
+ echo "traphandle default /usr/sbin/snmptt" >examples/snmptrapd.conf.sample
+}
+
+src_install() {
+ into /usr
+ dosbin snmptt
+ dosbin snmptthandler
+ dosbin snmptt-net-snmp-test
+ dosbin snmpttconvert
+ dosbin snmpttconvertmib
+
+ insinto /etc/snmp
+ doins snmptt.ini
+ doins examples/snmptt.conf.generic
+ cp -pPR ${D}/etc/snmp/snmptt.conf.generic ${D}/etc/snmp/snmptt.conf
+ doins examples/snmptrapd.conf.sample
+
+ dodoc BUGS ChangeLog README sample-trap
+ dohtml docs/faqs.html docs/index.html docs/layout1.css docs/snmptt.html docs/snmpttconvert.html docs/snmpttconvertmib.html
+
+ newinitd "${FILESDIR}"/snmptt.initd snmptt
+}
+
+pkg_postinst() {
+ if ( use mysql || use postgres ); then
+ elog "Read the html documentation to configure your database."
+ fi
+ elog "Please configure /etc/snmp/snmptt.conf before running."
+}
diff --git a/net-analyzer/snmptt/snmptt-1.4.ebuild b/net-analyzer/snmptt/snmptt-1.4.ebuild
new file mode 100644
index 000000000000..a91c3fcdebfd
--- /dev/null
+++ b/net-analyzer/snmptt/snmptt-1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="SNMP Trap Translator"
+SRC_URI="mirror://sourceforge/snmptt/${MY_P}.tgz"
+HOMEPAGE="http://www.snmptt.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="mysql postgres"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Config-IniFiles
+ net-analyzer/net-snmp
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+"
+
+src_prepare() {
+ # bug 105354, daemonize this thing
+ sed -i \
+ -e 's:mode = standalone:mode = daemon:g' \
+ -e '/pid_file/s:/var/run:/run:g' \
+ snmptt.ini || die
+
+ echo "traphandle default /usr/sbin/snmptt" >examples/snmptrapd.conf.sample
+}
+
+src_install() {
+ into /usr
+ dosbin snmptt snmptthandler snmptt-net-snmp-test snmpttconvert \
+ snmpttconvertmib
+
+ insinto /etc/snmp
+ doins snmptt.ini examples/snmptt.conf.generic \
+ examples/snmptrapd.conf.sample
+ newins examples/snmptt.conf.generic snmptt.conf
+
+ dodoc BUGS ChangeLog README sample-trap
+ dohtml docs/faqs.html docs/index.html docs/layout1.css docs/snmptt.html \
+ docs/snmpttconvert.html docs/snmpttconvertmib.html
+
+ newinitd "${FILESDIR}"/snmptt.initd-r1 snmptt
+}