summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/webfuzzer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/webfuzzer')
-rw-r--r--net-analyzer/webfuzzer/Manifest1
-rw-r--r--net-analyzer/webfuzzer/metadata.xml5
-rw-r--r--net-analyzer/webfuzzer/webfuzzer-0.2.0-r1.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/webfuzzer/Manifest b/net-analyzer/webfuzzer/Manifest
new file mode 100644
index 000000000000..aa99c9450f28
--- /dev/null
+++ b/net-analyzer/webfuzzer/Manifest
@@ -0,0 +1 @@
+DIST webfuzzer-0.2.0.tar.gz 29664 SHA256 7e9a9ed81a7edab950acb69b8243735a9ff116e7043a9c0b7e55fe96dfd99d3f SHA512 7cb858178dd11e7b6020f2b0db1092462401aab552af6bdb8b8c95c018bd35572a981338226def07dc45ed8f0b5a0b282ad681e9d86bec14d14ffd623518082e WHIRLPOOL ef437fd0fbc3f6f490d16e6f7a9d385ab59f772a7579f0a70f89a54658145d2daab4a89b031146a037a5ed23c71c025d8d048e94f5849b5f6db0c2078b630a3b
diff --git a/net-analyzer/webfuzzer/metadata.xml b/net-analyzer/webfuzzer/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/webfuzzer/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/webfuzzer/webfuzzer-0.2.0-r1.ebuild b/net-analyzer/webfuzzer/webfuzzer-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..ce05818d8cd3
--- /dev/null
+++ b/net-analyzer/webfuzzer/webfuzzer-0.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Poor man's web vulnerability scanner"
+HOMEPAGE="http://gunzip.altervista.org/g.php?f=projects"
+SRC_URI="http://gunzip.altervista.org/webfuzzer/webfuzzer-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/devel
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|CFLAGS=-g -O3|CFLAGS+=|' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dodoc CHANGES README TODO
+ dobin webfuzzer
+}