summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-19 13:57:04 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-12-11 15:30:27 +0200
commit5583406b1cc81b4d7e657a1deb704b59730e40e5 (patch)
tree668f01f9aeb96cd8637ab70a0f1b1c65769a2363 /net-dialup
parentmedia-libs/libtgvoip: Drop stable (diff)
downloadgentoo-5583406b1cc81b4d7e657a1deb704b59730e40e5.tar.gz
gentoo-5583406b1cc81b4d7e657a1deb704b59730e40e5.tar.bz2
gentoo-5583406b1cc81b4d7e657a1deb704b59730e40e5.zip
net-dialup/rp-l2tp: Fix call to undeclared library function memset
Closes: https://bugs.gentoo.org/897858 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32926 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/rp-l2tp/files/rp-l2tp-0.4-clang16-build-fix.patch11
-rw-r--r--net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild43
2 files changed, 54 insertions, 0 deletions
diff --git a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-clang16-build-fix.patch b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-clang16-build-fix.patch
new file mode 100644
index 000000000000..dc4269764a27
--- /dev/null
+++ b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-clang16-build-fix.patch
@@ -0,0 +1,11 @@
+Bug: https://bugs.gentoo.org/897858
+--- a/handlers/cmd-control.c
++++ b/handlers/cmd-control.c
+@@ -16,6 +16,7 @@
+ static char const RCSID[] =
+ "$Id: cmd-control.c,v 1.2 2002/09/30 19:45:00 dskoll Exp $";
+ #include <stdio.h>
++#include <string.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <sys/types.h>
diff --git a/net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild b/net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild
new file mode 100644
index 000000000000..550a22d585a9
--- /dev/null
+++ b/net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="User-space implementation of L2TP for Linux and other UNIX systems"
+HOMEPAGE="https://sourceforge.net/projects/rp-l2tp/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.patch"
+ "${FILESDIR}/${P}-flags.patch"
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-parallel-build.patch"
+ "${FILESDIR}/${P}-clang16-build-fix.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf #871210
+
+ tc-export AR CC
+}
+
+src_install() {
+ emake RPM_INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ newdoc l2tp.conf rp-l2tpd.conf
+
+ docinto libevent
+ dodoc -r libevent/Doc/.
+ docompress -x /usr/share/doc/${PF}/libevent
+
+ newinitd "${FILESDIR}"/rp-l2tpd-init rp-l2tpd
+}