summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-fs/smbtad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-fs/smbtad')
-rw-r--r--net-fs/smbtad/Manifest1
-rwxr-xr-xnet-fs/smbtad/files/smbtad.rc26
-rw-r--r--net-fs/smbtad/metadata.xml12
-rw-r--r--net-fs/smbtad/smbtad-1.2.6.ebuild51
4 files changed, 90 insertions, 0 deletions
diff --git a/net-fs/smbtad/Manifest b/net-fs/smbtad/Manifest
new file mode 100644
index 000000000000..4229f213c492
--- /dev/null
+++ b/net-fs/smbtad/Manifest
@@ -0,0 +1 @@
+DIST smbtad-1.2.6.tar.bz2 82062 SHA256 0f641a7cb9f98d6ea28f52bca5055eebec74fa6d3e5fe32236afa3770ea26d48 SHA512 fd3b370d973a42fb2dee48d2fec08e20af32386893ee67bc407decd001a76c944f3a17b3251e9d8d746feb1e87c69776986d600fd108450113835823f6313e2c WHIRLPOOL 697199a30217e5f1c4dd0ce1754b4542725d9e8aa96c8fd78f354a50324518a8bcb6e03bbfe8a789531b5ef02846cb553527d08a25f8297937a2fa511d80376b
diff --git a/net-fs/smbtad/files/smbtad.rc b/net-fs/smbtad/files/smbtad.rc
new file mode 100755
index 000000000000..cf134b4ad39c
--- /dev/null
+++ b/net-fs/smbtad/files/smbtad.rc
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+CONFFILE=/etc/conf.d/${SVCNAME}.conf
+PIDFILE=/var/run/${SVCNAME}.pid
+
+depend() {
+ before samba
+ use dns logger
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --quiet \
+ --exec /usr/bin/"${SVCNAME}" \
+ -- -c "${CONFFILE}"
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --name "${SVCNAME}"
+ eend ${?}
+}
diff --git a/net-fs/smbtad/metadata.xml b/net-fs/smbtad/metadata.xml
new file mode 100644
index 000000000000..f3b584e4d0b0
--- /dev/null
+++ b/net-fs/smbtad/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>samba</herd>
+ <maintainer>
+ <email>samba@gentoo.org</email>
+ <name>Samba Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hhetter/smbtad</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-fs/smbtad/smbtad-1.2.6.ebuild b/net-fs/smbtad/smbtad-1.2.6.ebuild
new file mode 100644
index 000000000000..23dc627c3940
--- /dev/null
+++ b/net-fs/smbtad/smbtad-1.2.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Data receiver of the SMB Traffic Analyzer project"
+HOMEPAGE="http://github.com/hhetter/smbtad"
+SRC_URI="http://morelias.org/smbta/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-db/libdbi
+ dev-libs/iniparser
+ sys-libs/talloc
+"
+RDEPEND="${DEPEND}
+ || (
+ <net-fs/samba-3.6[smbtav2]
+ >=net-fs/samba-3.6
+ )
+"
+
+DOCS="README AUTHORS"
+
+src_prepare() {
+ sed -i \
+ -e '/CMAKE_C_FLAGS/d' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use debug)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}"/smbtad.rc smbtad
+ newconfd dist/smbtad.conf_example smbtad.conf
+}