summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-03-31 12:13:50 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-03-31 12:13:50 -0400
commit2b6b60259c34edd5067ac298522a04e95ed2c5cc (patch)
tree88889257e653147669bd1822d229e6154c7f0786 /net-fs/smbtatools
parentdev-db/postgresql: x86 stable wrt bug #578680 (diff)
downloadgentoo-2b6b60259c34edd5067ac298522a04e95ed2c5cc.tar.gz
gentoo-2b6b60259c34edd5067ac298522a04e95ed2c5cc.tar.bz2
gentoo-2b6b60259c34edd5067ac298522a04e95ed2c5cc.zip
net-fs/smbtatools: ebuilds fixes for newer samba and newer cmake
- Bumped ebuild to EAPI6 - Patched CMakeLists.txt to fix issues with include paths when using newer cmake - Specify libsmbclient vars in src_configure using pkg-config, fixes bug 561800 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-fs/smbtatools')
-rw-r--r--net-fs/smbtatools/files/smbtatools-1.2.6-fix-cmake.patch38
-rw-r--r--net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild (renamed from net-fs/smbtatools/smbtatools-1.2.6.ebuild)19
2 files changed, 50 insertions, 7 deletions
diff --git a/net-fs/smbtatools/files/smbtatools-1.2.6-fix-cmake.patch b/net-fs/smbtatools/files/smbtatools-1.2.6-fix-cmake.patch
new file mode 100644
index 000000000000..2b8979b5a380
--- /dev/null
+++ b/net-fs/smbtatools/files/smbtatools-1.2.6-fix-cmake.patch
@@ -0,0 +1,38 @@
+--- a/CMakeLists.txt 2016-03-31 11:14:33.462962843 -0400
++++ b/CMakeLists.txt 2016-03-31 11:53:16.319234121 -0400
+@@ -30,7 +30,7 @@
+ MESSAGE( FATAL_ERROR "ERROR: you need the qt development files and library installed.")
+ ENDIF()
+ IF (QT_INCLUDE_DIR)
+- INCLUDE_DIRECTORIES($QT_INCLUDE_DIR)
++ INCLUDE_DIRECTORIES(${QT_INCLUDE_DIR})
+ ENDIF()
+
+
+@@ -42,7 +42,7 @@
+ MESSAGE( FATAL_ERROR "ERROR: you need the pango library and headers installed.")
+ ENDIF()
+ IF (LIBPANGO_INCLUDE_DIRS)
+- INCLUDE_DIRECTORIES($LIBPANGO_INCLUDE_DIRS)
++ INCLUDE_DIRECTORIES(${LIBPANGO_INCLUDE_DIRS})
+ ENDIF()
+
+ #
+@@ -53,7 +53,7 @@
+ MESSAGE( FATAL_ERROR "ERROR: you need the cairo library and headers installed.")
+ ENDIF()
+ IF (LIBCAIRO_INCLUDE_DIRS)
+- INCLUDE_DIRECTORIES($LIBCAIRO_INCLUDE_DIRS)
++ INCLUDE_DIRECTORIES(${LIBCAIRO_INCLUDE_DIRS})
+ ENDIF()
+
+
+@@ -65,7 +65,7 @@
+ MESSAGE( FATAL_ERROR "ERROR: you will need curl development files installed.")
+ ENDIF()
+ if (CURL_INCLUDE_DIRS)
+- INCLUDE_DIRECTORIES($CURL_INCLUDE_DIRS)
++ INCLUDE_DIRECTORIES(${CURL_INCLUDE_DIRS})
+ ENDIF()
+
+ # compile on SunOS
diff --git a/net-fs/smbtatools/smbtatools-1.2.6.ebuild b/net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild
index 4ef8cf4cd672..c2d65eba3364 100644
--- a/net-fs/smbtatools/smbtatools-1.2.6.ebuild
+++ b/net-fs/smbtatools/smbtatools-1.2.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils
@@ -15,27 +15,32 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="
+RDEPEND="
dev-db/libdbi
>=dev-db/sqlite-3.7.0:3
net-fs/samba
net-misc/curl
- sys-libs/ncurses
+ sys-libs/ncurses:0=
sys-libs/talloc
x11-libs/cairo
x11-libs/pango
dev-qt/qtgui:4
-
"
-RDEPEND="${DEPEND}
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND+="
net-fs/smbtad
"
DOCS="doc/smbta-guide.html doc/gfx/*.png"
+PATCHES=( "${FILESDIR}"/${P}-fix-cmake.patch )
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use debug)
+ -Ddebug=$(usex debug)
+ -DLIBSMBCLIENT_LIBRARIES="$(pkg-config --libs smbclient)"
+ -DLIBSMBCLIENT_INCLUDE_DIRS="$(pkg-config --variable includedir smbclient)"
)
cmake-utils_src_configure