summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-fs/smbtatools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-fs/smbtatools')
-rw-r--r--net-fs/smbtatools/Manifest1
-rw-r--r--net-fs/smbtatools/metadata.xml12
-rw-r--r--net-fs/smbtatools/smbtatools-1.2.6.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/net-fs/smbtatools/Manifest b/net-fs/smbtatools/Manifest
new file mode 100644
index 000000000000..f3f194ab938c
--- /dev/null
+++ b/net-fs/smbtatools/Manifest
@@ -0,0 +1 @@
+DIST smbtatools-1.2.6.tar.bz2 2235106 SHA256 be03ebb24bed338cd2cc1e38bc112eb52c0b7c9f2154b3c1c9d195fd7245e667 SHA512 0dc25d8eb65151cb7216b2c417054259a0f415af5857e59239ae90aee93a8a3a43a7a74f5f9d8b2200a47e0c6fc92ac6c58308452075020c35ee6ebcb71dbfcf WHIRLPOOL f3f840fcbd54406d5f1e170ff397b723c1ef308413a6b04d029ac63b2689eb4d996ba383cbef4a9e93870e48b66bedd89f4e64edf23b5d7bfd8b192e9c403dc4
diff --git a/net-fs/smbtatools/metadata.xml b/net-fs/smbtatools/metadata.xml
new file mode 100644
index 000000000000..d3af04c2780b
--- /dev/null
+++ b/net-fs/smbtatools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>samba</herd>
+ <maintainer>
+ <email>samba@gentoo.org</email>
+ <name>Samba Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hhetter/smbtatools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-fs/smbtatools/smbtatools-1.2.6.ebuild b/net-fs/smbtatools/smbtatools-1.2.6.ebuild
new file mode 100644
index 000000000000..18b96f08595a
--- /dev/null
+++ b/net-fs/smbtatools/smbtatools-1.2.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Tools for configuration and query of SMB Traffic Analyzer"
+HOMEPAGE="http://github.com/hhetter/smbtatools"
+SRC_URI="http://morelias.org/smbta/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-db/libdbi
+ >=dev-db/sqlite-3.7.0:3
+ net-fs/samba
+ net-misc/curl
+ sys-libs/ncurses
+ sys-libs/talloc
+ x11-libs/cairo
+ x11-libs/pango
+ dev-qt/qtgui:4
+
+"
+RDEPEND="${DEPEND}
+ net-fs/smbtad
+"
+
+DOCS="doc/smbta-guide.html doc/gfx/*.png"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use debug)
+ )
+
+ cmake-utils_src_configure
+}