summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/gproftpd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/gproftpd')
-rw-r--r--net-ftp/gproftpd/Manifest1
-rw-r--r--net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild64
-rw-r--r--net-ftp/gproftpd/metadata.xml7
3 files changed, 72 insertions, 0 deletions
diff --git a/net-ftp/gproftpd/Manifest b/net-ftp/gproftpd/Manifest
new file mode 100644
index 000000000000..0cb943513189
--- /dev/null
+++ b/net-ftp/gproftpd/Manifest
@@ -0,0 +1 @@
+DIST gproftpd-8.3.2.tar.gz 605797 SHA256 6afd290ea8b68c3258f5c355144a8c6adbeb9c2c88ff85a2563916c2f1e3b468 SHA512 71a3b80b2bf18ec17719b1484d45fb6110764d28492edafcd97538ad99ad7cc182ed25723b721226329b61f29e511b48e0153cf01f90c3c7f5ce939f7b233f59 WHIRLPOOL d6929a981b5a44815daae0e4d2d4cce7e5a54e998b663f65cbcc237f215c0cf2882169d4805acdefcc0877c43dba88b4dbb0cc4d746fe8267b68cab0de200814
diff --git a/net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild b/net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild
new file mode 100644
index 000000000000..aeeb27429c87
--- /dev/null
+++ b/net-ftp/gproftpd/gproftpd-8.3.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="GTK frontend to proftpd"
+HOMEPAGE="http://mange.dynup.net/linux.html"
+SRC_URI="http://mange.dynup.net/linux/gproftpd/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc sparc x86"
+SLOT="0"
+
+IUSE="gnome ssl"
+
+# Requiring ProFTPD 1.2.9 due to security fixes
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=x11-libs/pango-1.0
+ >=dev-libs/atk-1.0
+ >=media-libs/freetype-2.0
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ >=net-ftp/proftpd-1.2.9"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local modules includes myconf
+
+ #location of proftpd.conf
+ myconf="/etc/proftpd"
+
+ if use ssl; then
+ # enable mod_tls
+ modules="${modules}:mod_tls"
+ includes="${include}:/usr/kerberos/include"
+ fi
+
+ econf --sysconfdir=${myconf} \
+ --localstatedir=/var \
+ --with-modules=${modules} \
+ --with-includes=${includes}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+# Add the Gnome menu entry
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Internet/
+ doins "${S}"/desktop/net-gproftpd.desktop
+ fi
+
+ dodoc AUTHORS ChangeLog README
+
+ rm -r "${D}/usr/share/doc/gproftpd" || die
+}
+
+pkg_postinst() {
+ elog "gproftpd looks for your proftpd.conf file in /etc/proftpd"
+ elog "run gproftpd with the option -c to specify an alternate location"
+ elog "ex: gproftpd -c /etc/proftpd.conf"
+ elog "Do NOT edit /etc/conf.d/proftpd with this program"
+}
diff --git a/net-ftp/gproftpd/metadata.xml b/net-ftp/gproftpd/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/net-ftp/gproftpd/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>