summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-12 00:06:52 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-12 00:28:52 +0200
commit0363f00331c4ea0e2a664303569adc8ec66ddf7e (patch)
treec013041fc784827a045d3bd1a3133623f495c81f /net-im/jabber-base
parentacct-user/jabber: new package (diff)
downloadgentoo-0363f00331c4ea0e2a664303569adc8ec66ddf7e.tar.gz
gentoo-0363f00331c4ea0e2a664303569adc8ec66ddf7e.tar.bz2
gentoo-0363f00331c4ea0e2a664303569adc8ec66ddf7e.zip
net-im/jabber-base: bump to EAPI=7, migrate to GLEP 81
Also dropping '/var/run/jabber' from default install, since this directory should be created by each jabber service upon start. Closes: https://bugs.gentoo.org/432462 Closes: https://bugs.gentoo.org/520552 Closes: https://bugs.gentoo.org/670286 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im/jabber-base')
-rw-r--r--net-im/jabber-base/jabber-base-0.01-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-im/jabber-base/jabber-base-0.01-r2.ebuild b/net-im/jabber-base/jabber-base-0.01-r2.ebuild
new file mode 100644
index 000000000000..eba2cc85d74a
--- /dev/null
+++ b/net-im/jabber-base/jabber-base-0.01-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Base layout package for various jabber services"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ acct-group/jabber
+ acct-user/jabber
+"
+
+# This package provides the base layout for all jabber related services.
+# Each service should use the user 'jabber' and the group 'jabber.
+#
+# The base layout contains of the following directories:
+# '/etc/jabber/' : All main configuration, by jabber services used, is stored here.
+# '(/var)/run/jabber' : All pid files, used by jabber services, are stored here.
+# : Please note, that this directory should be
+# : created dynamically by each jabber service during startup.
+# '/var/log/jabber/' : All log files, used by jabber services, are stored here.
+# '/var/spool/jabber' : All (flat) database files, used by jabber services, are stored here.
+
+src_install() {
+ local paths=(
+ "/etc/jabber"
+ "/var/log/jabber"
+ "/var/spool/jabber"
+ )
+
+ for path in ${paths[@]}; do
+ keepdir "${path}"
+ fowners "jabber:jabber" "${path}"
+ fperms 770 "${path}"
+ done
+}