summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/mu-conference/mu-conference-0.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/mu-conference/mu-conference-0.7.ebuild')
-rw-r--r--net-im/mu-conference/mu-conference-0.7.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/net-im/mu-conference/mu-conference-0.7.ebuild b/net-im/mu-conference/mu-conference-0.7.ebuild
new file mode 100644
index 000000000000..5b3d3501be38
--- /dev/null
+++ b/net-im/mu-conference/mu-conference-0.7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Multi-User Chat for jabberd"
+HOMEPAGE="https://gna.org/projects/mu-conference/"
+SRC_URI="http://download.gna.org/mu-conference/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+SLOT="0"
+
+DEPEND="
+ dev-libs/expat
+ >=dev-libs/glib-2
+ net-dns/libidn
+ net-im/jabberd2
+ mysql? ( virtual/mysql )"
+RDEPEND="${DEPEND}"
+IUSE="mysql"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix missing header in src/conference_user.c in order to
+ # make emerge happy and avoid QA notice.
+ sed -i "/conference.h/ i #define _XOPEN_SOURCE" src/conference_user.c || die
+
+ if use mysql; then
+ sed -i '/^CFLAGS/ a CFLAGS:=$(CFLAGS) -DHAVE_MYSQL' src/Makefile || die
+ else
+ # Makefile is broken. Should not always link against mysql
+ sed -i 's/`mysql_config --libs`//' src/Makefile || die
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin src/mu-conference
+ fowners jabber:jabber /usr/bin/mu-conference
+ fperms 750 /usr/bin/mu-conference
+
+ newinitd "${FILESDIR}/${P}".init mu-conference
+
+ dodoc ChangeLog FAQ mu-conference.sql README
+ docinto scripts
+ dodoc scripts/*
+
+ for i in log spool; do
+ dodir /var/${i}/jabber/mu-conference
+ keepdir /var/${i}/jabber/mu-conference
+ fowners jabber:jabber /var/${i}/jabber/mu-conference
+ fperms 770 /var/${i}/jabber/mu-conference
+ done
+
+ insinto /etc/jabber
+ newins muc-default.xml mu-conference.xml
+ doins style.css
+
+ cd "${D}/etc/jabber/" || die
+ sed -i \
+ -e 's,./spool/chat.localhost,/var/spool/jabber/mu-conference,g' \
+ -e 's,./syslogs,/var/log/jabber,g' \
+ -e 's,./logs,/var/log/jabber/mu-conference,g' \
+ -e 's,./mu-conference.pid,/var/run/jabber/mu-conference.pid,g' \
+ -e "s,../style.css,/etc/jabber/style.css,g" \
+ -e "s,7009,5347,g" \
+ mu-conference.xml || die "sed failed"
+}
+
+pkg_postinst() {
+ echo
+ elog "For jabberd-2 connection:"
+ elog "1. Make sure that the ip and port in /etc/jabber/mu-conference.xml"
+ elog " match the address of your jabberd router."
+ elog "2. Set a common secret in mu-conference.xml and router.xml"
+ echo
+}