summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/pork
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/pork')
-rw-r--r--net-im/pork/Manifest1
-rw-r--r--net-im/pork/files/pork-0.99.8.1-tinfo.patch11
-rw-r--r--net-im/pork/metadata.xml13
-rw-r--r--net-im/pork/pork-0.99.8.1.ebuild40
4 files changed, 65 insertions, 0 deletions
diff --git a/net-im/pork/Manifest b/net-im/pork/Manifest
new file mode 100644
index 000000000000..b3d3d311223d
--- /dev/null
+++ b/net-im/pork/Manifest
@@ -0,0 +1 @@
+DIST pork-0.99.8.1.tar.gz 490425 SHA256 f0d4cad21017fd75b3c200342c54dd56d9ff7bc38d1e9b3c8ba686ba53d585ed SHA512 20efae37c847e4f4552280832c252341f3d541a08f94df21b780d130bb9dc61cf3464f99e119c01a540572a96340d84ed04e81458c0908357693b6af50d6e77f WHIRLPOOL d507920b28046172c607be05b1acbbbcef0889dd2ca1a39d2751e4753939eac868a43076f3281be8f9336eb226528f92fcdb1767c9909b68f0ce482718c108f6
diff --git a/net-im/pork/files/pork-0.99.8.1-tinfo.patch b/net-im/pork/files/pork-0.99.8.1-tinfo.patch
new file mode 100644
index 000000000000..c1f9e6bbb945
--- /dev/null
+++ b/net-im/pork/files/pork-0.99.8.1-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -114,6 +114,8 @@
+
+ AC_CHECK_LIB(ncurses, resizeterm, AC_DEFINE(HAVE_RESIZETERM, 1, [Define to 1 if you have the 'resizeterm' function in -lncurses.]))
+
++AC_SEARCH_LIBS(stdscr, tinfo)
++
+ AC_CHECK_TYPE(u_int32_t, uint32_t)
+ if test "$ac_cv_type_u_int32_t" = "no"; then
+ AC_CHECK_TYPE(uint32_t, unsigned int)
diff --git a/net-im/pork/metadata.xml b/net-im/pork/metadata.xml
new file mode 100644
index 000000000000..759bb26ebbf9
--- /dev/null
+++ b/net-im/pork/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Pork is an AIM client based on the GAIM libraries with an interface similar to IRCII.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ojnk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/pork/pork-0.99.8.1.ebuild b/net-im/pork/pork-0.99.8.1.ebuild
new file mode 100644
index 000000000000..dd222c347f6e
--- /dev/null
+++ b/net-im/pork/pork-0.99.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Console based AIM client that looks like ircII"
+HOMEPAGE="http://dev.ojnk.net/"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="perl"
+
+RDEPEND="
+ perl? ( dev-lang/perl )
+ sys-libs/ncurses
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable perl)
+}
+
+src_install() {
+ default
+
+ doman doc/pork.1
+ insinto /usr/share/pork/examples
+ doins examples/blist.txt
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README STYLE TODO QUICK_START
+}