summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/psi/psi-0.15.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/psi/psi-0.15.ebuild')
-rw-r--r--net-im/psi/psi-0.15.ebuild129
1 files changed, 129 insertions, 0 deletions
diff --git a/net-im/psi/psi-0.15.ebuild b/net-im/psi/psi-0.15.ebuild
new file mode 100644
index 000000000000..57c82bc86d5e
--- /dev/null
+++ b/net-im/psi/psi-0.15.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="be cs de fr it ja pl pt_BR ru sl sv ur_PK zh_TW"
+inherit eutils l10n multilib gnome2-utils qt4-r2 readme.gentoo
+
+DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
+HOMEPAGE="http://psi-im.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+for LNG in ${PLOCALES}; do
+ SRC_URI="${SRC_URI}
+ linguas_${LNG}? ( http://psi-im.org/download/lang/${PN}_${LNG}.qm -> ${P}_${LNG}.qm )"
+done
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86 ~x86-fbsd"
+IUSE="crypt dbus debug doc jingle spell ssl xscreensaver whiteboarding"
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/unzip
+ >=app-crypt/qca-2.0.2:2[qt4(+)]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ >=sys-libs/zlib-1.2.5.1-r2[minizip]
+ x11-libs/libX11
+ dbus? ( dev-qt/qtdbus:4 )
+ spell? ( >=app-text/enchant-1.3.0 )
+ whiteboarding? ( dev-qt/qtsvg:4 )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+"
+DEPEND="${RDEPEND}
+ sys-devel/qconf
+ doc? ( app-doc/doxygen )
+"
+PDEPEND="
+ crypt? ( app-crypt/qca:2[gpg] )
+ jingle? (
+ net-im/psimedia
+ app-crypt/qca:2[openssl]
+ )
+ ssl? ( app-crypt/qca:2[openssl] )
+"
+
+DOC_CONTENTS='Psi+ support(USE="extras") was removed from ebuild since 0.15'
+FORCE_PRINT_ELOG=1
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.14-drop-debug-cflags.patch"
+ epatch_user
+
+ qconf || die "Failed to create ./configure."
+}
+
+src_configure() {
+ # unable to use econf because of non-standard configure script
+ # disable growl as it is a MacOS X extension only
+ local confcmd="./configure
+ --prefix=/usr
+ --qtdir=/usr
+ --disable-growl
+ $(use dbus || echo '--disable-qdbus')
+ $(use debug && echo '--debug')
+ $(use spell || echo '--disable-aspell')
+ $(use spell || echo '--disable-enchant')
+ $(use xscreensaver || echo '--disable-xss')
+ $(use whiteboarding && echo '--enable-whiteboarding')"
+
+ echo ${confcmd}
+ ${confcmd} || die "configure failed"
+ # Makefile is not always created...
+ [[ ! -f Makefile ]] && die "configure failed"
+}
+
+src_compile() {
+ eqmake4
+
+ emake
+
+ if use doc; then
+ cd doc || die
+ mkdir -p api || die # 259632
+ emake api_public
+ fi
+}
+
+src_install() {
+ install_locale() {
+ newins "${DISTDIR}/${P}_${1}.qm" "${PN}_${1}.qm"
+ }
+
+ emake INSTALL_ROOT="${D}" install
+ rm "${D}"/usr/share/psi/{COPYING,README} || die
+
+ readme.gentoo_create_doc
+
+ # this way the docs will be installed in the standard gentoo dir
+ newdoc iconsets/roster/README README.roster
+ newdoc iconsets/system/README README.system
+ newdoc certs/README README.certs
+ dodoc README
+
+ if use doc; then
+ cd doc || die
+ dohtml -r api
+ fi
+
+ # install translations
+ insinto /usr/share/${PN}
+ l10n_for_each_locale_do install_locale
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}