summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/skypetab-ng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/skypetab-ng')
-rw-r--r--net-im/skypetab-ng/Manifest1
-rw-r--r--net-im/skypetab-ng/metadata.xml12
-rw-r--r--net-im/skypetab-ng/skypetab-ng-0.5.2.ebuild38
-rw-r--r--net-im/skypetab-ng/skypetab-ng-9999.ebuild38
4 files changed, 89 insertions, 0 deletions
diff --git a/net-im/skypetab-ng/Manifest b/net-im/skypetab-ng/Manifest
new file mode 100644
index 000000000000..3be0c28de8af
--- /dev/null
+++ b/net-im/skypetab-ng/Manifest
@@ -0,0 +1 @@
+DIST skypetab-ng-0.5.2.tar.gz 54244 SHA256 cb47961ddb9d5754141c10c862d991704ae065abf2cba1e4763a78a5dcbf0805 SHA512 28a19ea983a81c069bb6ad24c337561293f7ec53ca9a315fb872c9341dccecf4eb30e1652b1f012f7be34060fb955a8c085327ae03017264ccc4510976d3f6ea WHIRLPOOL 48b1a86a588dd60c3ee7b9185625027bbaef69b0a6dce237c1e38d3c7dc5b762675d7d21efb88bef7e3840ac1464cdfa3ca4a531756ab3f3f155c2a681aec0e7
diff --git a/net-im/skypetab-ng/metadata.xml b/net-im/skypetab-ng/metadata.xml
new file mode 100644
index 000000000000..fa7aec24b7bb
--- /dev/null
+++ b/net-im/skypetab-ng/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kekekeks/skypetab-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/skypetab-ng/skypetab-ng-0.5.2.ebuild b/net-im/skypetab-ng/skypetab-ng-0.5.2.ebuild
new file mode 100644
index 000000000000..e565ad2aea60
--- /dev/null
+++ b/net-im/skypetab-ng/skypetab-ng-0.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/kekekeks/skypetab-ng.git"
+ UNPACKER_ECLASS="git-2"
+ LIVE_EBUILD=yes
+else
+ UNPACKER_ECLASS="vcs-snapshot"
+fi
+
+inherit qt4-r2 multilib ${UNPACKER_ECLASS}
+
+if [[ -z ${LIVE_EBUILD} ]]; then
+ KEYWORDS="-* ~x86 ~amd64"
+ SRC_URI="http://github.com/kekekeks/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An LD_PRELOAD wrapper that adds tabs to Skype for Linux"
+HOMEPAGE="http://github.com/kekekeks/skypetab-ng"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4[abi_x86_32(-)]
+ dev-qt/qtgui:4[abi_x86_32(-)]
+"
+RDEPEND="${DEPEND}
+ || ( >=net-im/skype-4.1 <net-im/skype-4.1[-qt-static] )
+"
+
+pkg_setup() {
+ use amd64 && multilib_toolchain_setup x86
+}
diff --git a/net-im/skypetab-ng/skypetab-ng-9999.ebuild b/net-im/skypetab-ng/skypetab-ng-9999.ebuild
new file mode 100644
index 000000000000..e565ad2aea60
--- /dev/null
+++ b/net-im/skypetab-ng/skypetab-ng-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/kekekeks/skypetab-ng.git"
+ UNPACKER_ECLASS="git-2"
+ LIVE_EBUILD=yes
+else
+ UNPACKER_ECLASS="vcs-snapshot"
+fi
+
+inherit qt4-r2 multilib ${UNPACKER_ECLASS}
+
+if [[ -z ${LIVE_EBUILD} ]]; then
+ KEYWORDS="-* ~x86 ~amd64"
+ SRC_URI="http://github.com/kekekeks/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An LD_PRELOAD wrapper that adds tabs to Skype for Linux"
+HOMEPAGE="http://github.com/kekekeks/skypetab-ng"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4[abi_x86_32(-)]
+ dev-qt/qtgui:4[abi_x86_32(-)]
+"
+RDEPEND="${DEPEND}
+ || ( >=net-im/skype-4.1 <net-im/skype-4.1[-qt-static] )
+"
+
+pkg_setup() {
+ use amd64 && multilib_toolchain_setup x86
+}