summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-10-03 05:02:38 +0300
committerIonen Wolkens <ionen@gentoo.org>2021-10-25 00:27:29 -0400
commitc91c1d1724205137be4f5ace922cc5683d08613e (patch)
tree694732a3b0528cbc530b4ec3d58a2f646e7ae6db /net-im
parentnet-im/qtox: take over maintainership (diff)
downloadgentoo-c91c1d1724205137be4f5ace922cc5683d08613e.tar.gz
gentoo-c91c1d1724205137be4f5ace922cc5683d08613e.tar.bz2
gentoo-c91c1d1724205137be4f5ace922cc5683d08613e.zip
net-im/qtox: update live ebuild
Sync with 1.17.3 while including the following changes: - Adjust formatting so that staying in sync is less work. - Add new required dependencies. - Flip -DUSE_CCACHE from ON to OFF to avoid using ccache with FEATURES="-ccache". - Enable spellchecking feature by default to match upstream. - Add a local description for USE="X", which controls auto-away detection support. - Disable a couple of network related tests. - Miscellaneous formatting/wording adjustments. - Use EAPI-8. Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/22471 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtox/metadata.xml3
-rw-r--r--net-im/qtox/qtox-9999.ebuild65
2 files changed, 45 insertions, 23 deletions
diff --git a/net-im/qtox/metadata.xml b/net-im/qtox/metadata.xml
index 2e4f2fbd7565..51bdfe56b855 100644
--- a/net-im/qtox/metadata.xml
+++ b/net-im/qtox/metadata.xml
@@ -11,7 +11,8 @@
</maintainer>
<use>
<flag name="notification">Use snorenotify for desktop notifications</flag>
- <flag name="spellcheck">Enable spell cheching support</flag>
+ <flag name="spellcheck">Enable spell checking support</flag>
+ <flag name="X">Enable auto-away support</flag>
</use>
<upstream>
<remote-id type="github">qTox/qTox</remote-id>
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index 8e6526263d3a..f3d034bc3f34 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,18 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake git-r3 xdg
+inherit cmake xdg
-DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
-HOMEPAGE="https://github.com/qTox/qTox"
-EGIT_REPO_URI="https://github.com/qTox/qTox.git"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qTox/qTox.git"
+else
+ SRC_URI="https://github.com/qTox/qTox/releases/download/v${PV}/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Instant messaging client using the encrypted p2p Tox protocol"
+HOMEPAGE="https://qtox.github.io/"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS=""
-IUSE="notification test X"
+IUSE="notification +spellcheck test X"
RESTRICT="!test? ( test )"
@@ -25,29 +31,33 @@ RDEPEND="
dev-libs/libsodium:=
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
- || (
- dev-qt/qtgui:5[gif,jpeg,png,X(-)]
- dev-qt/qtgui:5[gif,jpeg,png,xcb(-)]
- )
+ dev-qt/qtgui:5[gif,jpeg,png,X(-)]
dev-qt/qtnetwork:5
dev-qt/qtopengl:5
- dev-qt/qtsql:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
media-gfx/qrencode:=
- media-libs/libexif:=
+ media-libs/libexif
media-libs/openal
- >=media-video/ffmpeg-2.6.3:=[webp,v4l]
- net-libs/tox:0/0.2[av]
- notification? ( x11-libs/gtk+:2 )
- X? ( x11-libs/libX11
- x11-libs/libXScrnSaver )
+ media-video/ffmpeg:=[webp,v4l]
+ net-libs/tox:=[av]
+ net-libs/toxext
+ net-libs/tox_extension_messages
+ notification? ( x11-libs/snorenotify )
+ spellcheck? ( kde-frameworks/sonnet:5 )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
"
DEPEND="${RDEPEND}
test? ( dev-qt/qttest:5 )
+ X? ( x11-base/xorg-proto )
"
+DOCS=( CHANGELOG.md README.md doc/user_manual_en.md )
+
src_prepare() {
cmake_src_prepare
@@ -60,11 +70,22 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DENABLE_STATUSNOTIFIER=$(usex notification)
- -DENABLE_GTK_SYSTRAY=$(usex notification)
-DPLATFORM_EXTENSIONS=$(usex X)
- -DUSE_FILTERAUDIO=OFF
+ -DUPDATE_CHECK=OFF
+ -DUSE_CCACHE=OFF
+ -DSPELL_CHECK=$(usex spellcheck)
+ -DSVGZ_ICON=ON
+ -DASAN=OFF
+ -DDESKTOP_NOTIFICATIONS=$(usex notification)
+ -DSTRICT_OPTIONS=OFF
)
+ [[ ${PV} != 9999 ]] && mycmakeargs+=( -DGIT_DESCRIBE=${PV} )
+
cmake_src_configure
}
+
+src_test() {
+ # The excluded tests require network access.
+ cmake_src_test -E "test_(bsu|core)"
+}