summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ. García <u0x004a@gmail.com>2016-05-23 14:32:13 -0600
committerPatrice Clement <monsieurp@gentoo.org>2016-05-25 07:51:04 +0000
commit26a5188aebd914be8a898aeb36fa70e562d47e15 (patch)
tree3f3637bf52670cbd951607729b56b67de2f79afc /net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild
parentdev-util/dput-ng: simplify the manpage installation logic (diff)
downloadgentoo-26a5188aebd914be8a898aeb36fa70e562d47e15.tar.gz
gentoo-26a5188aebd914be8a898aeb36fa70e562d47e15.tar.bz2
gentoo-26a5188aebd914be8a898aeb36fa70e562d47e15.zip
net-irc/irssi-xmpp: bump to 0.53 and other changes - Change HOMEPAGE to https - Change SRC_URI to github and use https
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1527 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild')
-rw-r--r--net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild b/net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild
new file mode 100644
index 000000000000..b856a030c3bf
--- /dev/null
+++ b/net-irc/irssi-xmpp/irssi-xmpp-0.53.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="An irssi plugin providing Jabber/XMPP support"
+HOMEPAGE="https://cybione.org/~irssi-xmpp/"
+SRC_URI="https://github.com/cdidier/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-irc/irssi-0.8.13
+ >=net-libs/loudmouth-1.4.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "s/{MAKE} doc-install/{MAKE}/" \
+ -i Makefile || die #322355
+}
+
+src_compile() {
+ emake PREFIX=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr IRSSI_LIB=/usr/$(get_libdir)/irssi install
+ dodoc README NEWS TODO docs/*
+}