summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/cvm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/cvm')
-rw-r--r--net-libs/cvm/Manifest3
-rw-r--r--net-libs/cvm/cvm-0.76.ebuild62
-rw-r--r--net-libs/cvm/cvm-0.82.ebuild104
-rw-r--r--net-libs/cvm/cvm-0.96.ebuild106
-rw-r--r--net-libs/cvm/metadata.xml10
5 files changed, 285 insertions, 0 deletions
diff --git a/net-libs/cvm/Manifest b/net-libs/cvm/Manifest
new file mode 100644
index 000000000000..dc6718bc3709
--- /dev/null
+++ b/net-libs/cvm/Manifest
@@ -0,0 +1,3 @@
+DIST cvm-0.76.tar.gz 91957 SHA256 0b0bbc21ad7bbe6acab66a85369502c2907e522fa2fd5c33c6f584ad1ccc000e
+DIST cvm-0.82.tar.gz 93615 SHA256 5c209c2ac911ba5473b1ef1b78407afa6821eca26de476291a7362fee616d0fe
+DIST cvm-0.96.tar.gz 127999 SHA256 b85121b2f4b160b27c95705bd83a871675ed4b65b8bcb259a0877f37606224e9
diff --git a/net-libs/cvm/cvm-0.76.ebuild b/net-libs/cvm/cvm-0.76.ebuild
new file mode 100644
index 000000000000..d5b1d71ba269
--- /dev/null
+++ b/net-libs/cvm/cvm-0.76.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Credential Validation Modules by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/cvm/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc sparc x86"
+IUSE="mysql postgres test"
+
+RDEPEND="dev-db/cdb"
+DEPEND="${RDEPEND}
+ >=dev-libs/bglibs-1.041
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+ test? ( app-editors/vim )"
+# some of the testcases use ex/vi/xxd
+
+src_unpack() {
+ unpack ${A}
+ # disable this test, as it breaks under Portage
+ # and there is no easy fix
+ sed -i.orig -e '/qmail-lookup-nodomain/,/^END_OF_TEST_RESULTS/d' "${S}"/tests.sh || die "sed failed"
+}
+
+src_compile() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/lib/bglibs" > conf-bglibs
+ echo "${D}/usr/include" > conf-include
+ echo "${D}/usr/lib" > conf-lib
+ echo "${D}/usr/bin" > conf-bin
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS} -lcrypt" > conf-ld
+ emake || die
+
+ if use mysql; then
+ make mysql || die "making mysql support failed"
+ fi
+
+ if use postgres; then
+ make pgsql || die "making postgres support failed"
+ fi
+}
+
+src_install() {
+ einstall || die
+
+ dodoc ANNOUNCEMENT NEWS NEWS.sql NEWS.vmailmgr README README.vchkpw
+ dodoc README.vmailmgr TODO VERSION
+ dohtml *.html
+}
+
+src_test() {
+ sh tests.sh || die "Testing Failed"
+}
diff --git a/net-libs/cvm/cvm-0.82.ebuild b/net-libs/cvm/cvm-0.82.ebuild
new file mode 100644
index 000000000000..b3b32e2747ef
--- /dev/null
+++ b/net-libs/cvm/cvm-0.82.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Credential Validation Modules by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/cvm/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE="mysql postgres test vpopmail"
+
+RDEPEND="dev-db/cdb"
+DEPEND="${RDEPEND}
+ >=dev-libs/bglibs-1.041
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+ vpopmail? ( net-mail/vpopmail )
+ test? ( app-editors/vim )"
+# some of the testcases use ex/vi/xxd
+
+src_unpack() {
+ unpack ${A}
+ # disable this test, as it breaks under Portage
+ # and there is no easy fix
+ sed -i.orig \
+ -e '/qmail-lookup-nodomain/,/^END_OF_TEST_RESULTS/d' \
+ "${S}"/tests.sh || die "sed failed"
+ # Fix the vpopmail build
+ sed -i.orig \
+ -e '/.\/ltload cvm-vchkpw/s,-lmysqlclient,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,-L/usr/local/vpopmail/lib,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,-L/var/vpopmail/lib,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,-L/usr/local/lib/mysql,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,\.la,.la `cat /var/vpopmail/etc/lib_deps`,g' \
+ "${S}"/Makefile \
+ || die "Failed to fix vpopmail linking parts of Makefile"
+ sed -i.orig \
+ -e '/.\/compile cvm-vchkpw/s,$, `cat /var/vpopmail/etc/inc_deps`,g' \
+ "${S}"/Makefile \
+ || die "Failed to fix vpopmail compiling parts of Makefile"
+}
+
+src_compile() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/lib/bglibs" > conf-bglibs
+ echo "/usr/include" > conf-include
+ echo "/usr/lib" > conf-lib
+ echo "/usr/bin" > conf-bin
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS} -lcrypt" > conf-ld
+ emake || die
+
+ if use mysql; then
+ einfo "Building MySQL support"
+ emake mysql || die "making mysql support failed"
+ fi
+
+ if use postgres; then
+ einfo "Building Postgresql support"
+ emake pgsql || die "making postgres support failed"
+ fi
+
+ if use vpopmail; then
+ einfo "Building vpopmail support"
+ emake cvm-vchkpw || die "making vpopmail support failed"
+ fi
+}
+
+src_install() {
+ # Upstreams installer is incredibly broken
+ dolib .libs/*.a .libs/*.so.*
+ for i in a so ; do
+ dosym libcvm-v2client.${i} /usr/$(get_libdir)/libcvm-client.${i}
+ done
+
+ for i in {bench,test}client chain checkpassword pwfile qmail unix \
+ vmailmgr{,-local,-udp} v1{benchclient,checkpassword,testclient} \
+ ; do
+ dobin .libs/cvm-${i}
+ done
+ use mysql && dobin .libs/cvm-mysql{,-local,-udp}
+ use postgres && dobin .libs/cvm-pgsql{,-local,-udp}
+ use vpopmail && dobin .libs/cvm-vchkpw
+
+ insinto /usr/include/cvm
+ doins {credentials,errors,facts,module,protocol,sasl,v1client,v2client}.h
+ dosym v1client.h /usr/include/cvm/client.h
+ dosym cvm/sasl.h /usr/include/cvm-sasl.h
+
+ dodoc ANNOUNCEMENT NEWS{,.sql,.vmailmgr}
+ dodoc README{,.vchkpw,.vmailmgr}
+ dodoc TODO VERSION ChangeLog*
+ dohtml *.html
+}
+
+src_test() {
+ sh tests.sh || die "Testing Failed"
+}
diff --git a/net-libs/cvm/cvm-0.96.ebuild b/net-libs/cvm/cvm-0.96.ebuild
new file mode 100644
index 000000000000..926b4d9e9e66
--- /dev/null
+++ b/net-libs/cvm/cvm-0.96.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Credential Validation Modules by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/cvm/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="mysql postgres test vpopmail"
+
+RDEPEND="dev-db/cdb"
+DEPEND="${RDEPEND}
+ >=dev-libs/bglibs-1.041
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+ vpopmail? ( net-mail/vpopmail )
+ test? ( app-editors/vim )"
+# some of the testcases use ex/vi/xxd
+
+MAKEOPTS="${MAKEOPTS} -j1" #310843
+
+src_unpack() {
+ unpack ${A}
+ # disable this test, as it breaks under Portage
+ # and there is no easy fix
+ sed -i.orig \
+ -e '/qmail-lookup-nodomain/,/^END_OF_TEST_RESULTS/d' \
+ "${S}"/tests.sh || die "sed failed"
+ # Fix the vpopmail build
+ sed -i.orig \
+ -e '/.\/ltload cvm-vchkpw/s,-lmysqlclient,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,-L/usr/local/vpopmail/lib,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,-L/var/vpopmail/lib,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,-L/usr/local/lib/mysql,,g' \
+ -e '/.\/ltload cvm-vchkpw/s,\.la,.la `cat /var/vpopmail/etc/lib_deps`,g' \
+ "${S}"/Makefile \
+ || die "Failed to fix vpopmail linking parts of Makefile"
+ sed -i.orig \
+ -e '/.\/compile cvm-vchkpw/s,$, `cat /var/vpopmail/etc/inc_deps`,g' \
+ "${S}"/Makefile \
+ || die "Failed to fix vpopmail compiling parts of Makefile"
+}
+
+src_compile() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/lib/bglibs" > conf-bglibs
+ echo "/usr/include" > conf-include
+ echo "/usr/lib" > conf-lib
+ echo "/usr/bin" > conf-bin
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS} -lcrypt" > conf-ld
+ emake || die
+
+ if use mysql; then
+ einfo "Building MySQL support"
+ emake mysql || die "making mysql support failed"
+ fi
+
+ if use postgres; then
+ einfo "Building Postgresql support"
+ emake pgsql || die "making postgres support failed"
+ fi
+
+ if use vpopmail; then
+ einfo "Building vpopmail support"
+ emake cvm-vchkpw || die "making vpopmail support failed"
+ fi
+}
+
+src_install() {
+ # Upstreams installer is incredibly broken
+ dolib .libs/*.a .libs/*.so.*
+ for i in a so ; do
+ dosym libcvm-v2client.${i} /usr/$(get_libdir)/libcvm-client.${i}
+ done
+
+ for i in {bench,test}client chain checkpassword pwfile qmail unix \
+ vmailmgr{,-local,-udp} v1{benchclient,checkpassword,testclient} \
+ ; do
+ dobin .libs/cvm-${i}
+ done
+ use mysql && dobin .libs/cvm-mysql{,-local,-udp}
+ use postgres && dobin .libs/cvm-pgsql{,-local,-udp}
+ use vpopmail && dobin .libs/cvm-vchkpw
+
+ insinto /usr/include/cvm
+ doins {credentials,errors,facts,module,protocol,sasl,v1client,v2client}.h
+ dosym v1client.h /usr/include/cvm/client.h
+ dosym cvm/sasl.h /usr/include/cvm-sasl.h
+
+ dodoc ANNOUNCEMENT NEWS{,.sql,.vmailmgr}
+ dodoc README{,.vchkpw,.vmailmgr}
+ dodoc TODO VERSION ChangeLog*
+ dohtml *.html
+}
+
+src_test() {
+ sh tests.sh || die "Testing Failed"
+}
diff --git a/net-libs/cvm/metadata.xml b/net-libs/cvm/metadata.xml
new file mode 100644
index 000000000000..c8ae1a99908d
--- /dev/null
+++ b/net-libs/cvm/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="vpopmail">Enable vpopmail support</flag>
+ </use>
+</pkgmetadata>