summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:33:55 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:45:02 +0100
commitf9682018fc6f442bdda0be892199576c186300a3 (patch)
treece4ff4f22da7f6eeda82435741001a1af869869c /net-libs/daq
parentnet-analyzer/snort: bump to v2.9.12 (diff)
downloadgentoo-f9682018fc6f442bdda0be892199576c186300a3.tar.gz
gentoo-f9682018fc6f442bdda0be892199576c186300a3.tar.bz2
gentoo-f9682018fc6f442bdda0be892199576c186300a3.zip
net-libs/daq: bump to v2.0.6
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs/daq')
-rw-r--r--net-libs/daq/Manifest1
-rw-r--r--net-libs/daq/daq-2.0.6.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/daq/Manifest b/net-libs/daq/Manifest
index 71be401e32ef..13a86802343e 100644
--- a/net-libs/daq/Manifest
+++ b/net-libs/daq/Manifest
@@ -1,3 +1,4 @@
DIST daq-0.6.2.tar.gz 451581 BLAKE2B 64eebeb669eefc6715b206de19e823708a8e4255d5898d5f6d4b80889360611950764432c941a2a930582ab9b8c2300cfdb41784f008f4ef1c248f3469819d4e SHA512 da19034f210d9c202f5e3ba7ddf60645498ed8bdaf28410811922ebb1338b56c55c8e992e46e1c7b9b89de6148b471129826a02ab2a45c7232bc4091a4e53125
DIST daq-2.0.0.tar.gz 480030 BLAKE2B ab25ce133833babbdaecd74c79d319739e5bfa34bfa100d35c19569c935fe58b425ea817a12f6d2fc1ff47a6e8097b822e2d5ac5dc295cdde516811f139accff SHA512 aa79e06473592c0ee57a3a2da60f01f35e6268a126fcb3a992ee7c6da48a079cf359db7439be3778997e774c340630d768712c9efea10c570feb4961f9a00b3c
DIST daq-2.0.2.tar.gz 474447 BLAKE2B fa80d435056d672eaa15f003649d90dba91986780f372cd4e953b676e414232516c5fc43065f5497d38299e0309c58b2734458f9e5aa1b93cdfa29dfe72b622d SHA512 b2a47e174155f21cb1c6f1e1c431ea7cca6aa9f7371228e77def3c526a67fd42d0e26e4c94263195e041b203cdf0c2aaef14f9035afb23dde0bd5df3bf422cbd
+DIST daq-2.0.6.tar.gz 518013 BLAKE2B 702ab20c776b9047230bb1ac36574068e461a850ed5d15959c314d62b0b828c792cf23d19cdb411ba8c067348ae74dd2f011376ccbe0376c44536ad58fa1bba9 SHA512 61dd5408c587e57999445b9549ac539ffc5bb16ddc179601de1065fc5e251c1893536d8aa2251096e34b54093529d3578e7b5d97e3514cb2bbf4de113639b08c
diff --git a/net-libs/daq/daq-2.0.6.ebuild b/net-libs/daq/daq-2.0.6.ebuild
new file mode 100644
index 000000000000..42db13440514
--- /dev/null
+++ b/net-libs/daq/daq-2.0.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit autotools multilib
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="https://www.snort.org/"
+SRC_URI="https://www.snort.org/downloads/snort/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 +afpacket +dump +pcap nfq ipq static-libs"
+
+PCAP_DEPEND=">=net-libs/libpcap-1.0.0"
+IPT_DEPEND="
+ >=net-firewall/iptables-1.4.10
+ dev-libs/libdnet
+ net-libs/libnetfilter_queue
+
+"
+DEPEND="
+ dump? ( ${PCAP_DEPEND} )
+ ipq? ( ${IPT_DEPEND} )
+ nfq? ( ${IPT_DEPEND} )
+ pcap? ( ${PCAP_DEPEND} )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # We forced libpcap to 1.x, so we can set this cache var so
+ # cross-compiling doesn't break on us.
+ daq_cv_libpcap_version_1x=yes \
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ $(use_enable nfq nfq-module) \
+ $(use_enable ipq ipq-module) \
+ $(use_enable static-libs static) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+}
+
+DOCS=( ChangeLog README )
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ # If not using static-libs don't install the static libraries
+ # This has been bugged upstream
+ if ! use static-libs; then
+ for z in libdaq_static libdaq_static_modules; do
+ rm "${D}"usr/$(get_libdir)/${z}.a
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ einfo "calls to PCAP functions with an abstraction layer that facilitates"
+ einfo "operation on a variety of hardware and software interfaces without"
+ einfo "requiring changes to application such as Snort."
+ einfo
+ einfo "Please see the README file for DAQ for information about specific"
+ einfo "DAQ modules."
+}