summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-01-24 19:13:35 -0500
committerAaron Bauman <bman@gentoo.org>2018-01-24 19:13:35 -0500
commit2f8d1f906ee104fed8ee8994d8a861e15022b46b (patch)
tree16e6edbed1bbaf427a8adf8d043b18c0c8b011b1 /net-libs/ldns
parentnet-dns/ldns-utils: cleanup vulnerable wrt bug #638338 (diff)
downloadgentoo-2f8d1f906ee104fed8ee8994d8a861e15022b46b.tar.gz
gentoo-2f8d1f906ee104fed8ee8994d8a861e15022b46b.tar.bz2
gentoo-2f8d1f906ee104fed8ee8994d8a861e15022b46b.zip
net-libs/ldns: cleanup vulnerable wrt bug #638338
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/Manifest1
-rw-r--r--net-libs/ldns/ldns-1.6.17-r1.ebuild106
-rw-r--r--net-libs/ldns/ldns-1.6.17.ebuild94
-rw-r--r--net-libs/ldns/ldns-1.7.0-r1.ebuild110
4 files changed, 0 insertions, 311 deletions
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
index 308877613938..51c3ade23c2a 100644
--- a/net-libs/ldns/Manifest
+++ b/net-libs/ldns/Manifest
@@ -1,2 +1 @@
-DIST ldns-1.6.17.tar.gz 1315403 BLAKE2B 67cf163c0fc529730f6de6a7ed3c581a2fdc3be7eb3f1d2cdc4ff51c98e6b78f93fab96d19d665f2dc8592f80d92ec5d3dd16da9760124f0604eb48c09ffd201 SHA512 5de42b4b8622591db51efb0956735deee9cd5e0bee12249a03b65c5b45d7c51bf9c2edb310ef9d7431af49aef77d968bfa2455a7dedfa80cde3d433436c83785
DIST ldns-1.7.0.tar.gz 1304424 BLAKE2B 2f37aa2d00c1d9cf18711bd4f873f4722df01c4f4d0f627e054f04b2473c0fbf19449e293a130d5c8b98dcebafeb3d7b3f5923ae0244bd80139cea77f2171e06 SHA512 8a4e48bcc2a244b92447a9830b60efbb656fb7955f3559ef2eb6f8e724c4c0208776350c44ccf7dcf1ffe0b7b9d9ccc4cbddc5bc16e8888db494ab4d0bce3bd8
diff --git a/net-libs/ldns/ldns-1.6.17-r1.ebuild b/net-libs/ldns/ldns-1.6.17-r1.ebuild
deleted file mode 100644
index c0b67b5178fd..000000000000
--- a/net-libs/ldns/ldns-1.6.17-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib-minimal python-single-r1
-
-DESCRIPTION="a library with the aim to simplify DNS programming in C"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="dane doc +ecdsa gost libressl python +ssl static-libs vim-syntax"
-
-# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="ecdsa? ( ssl )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
- dane? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
- ecdsa? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[-bindist,${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
- gost? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
-"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )
-"
-
-RESTRICT="test" # 1.6.9 has no test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}_perl522.patch"
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(use_enable ssl sha2) \
- $(use_enable gost) \
- $(use_enable ecdsa) \
- $(use_enable dane) \
- $(use_with ssl ssl "${EPREFIX}"/usr) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --without-drill \
- --without-examples \
- --disable-rpath
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dohtml -r doc/html/.
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- prune_libtool_files --modules
- use python && python_optimize
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
- fi
-
- einfo
- elog "Install net-dns/ldns-utils if you want drill and examples"
- einfo
-}
diff --git a/net-libs/ldns/ldns-1.6.17.ebuild b/net-libs/ldns/ldns-1.6.17.ebuild
deleted file mode 100644
index c83ddb745d94..000000000000
--- a/net-libs/ldns/ldns-1.6.17.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib-minimal python-single-r1
-
-DESCRIPTION="a library with the aim to simplify DNS programming in C"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="dane doc +ecdsa gost python +ssl static-libs vim-syntax"
-
-# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="ecdsa? ( ssl )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dane? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
- ecdsa? ( >=dev-libs/openssl-1.0.1h-r2:0[-bindist,${MULTILIB_USEDEP}] )
- gost? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
- python? ( ${PYTHON_DEPS} )
- ssl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )
-"
-
-RESTRICT="test" # 1.6.9 has no test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}_perl522.patch"
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(use_enable ssl sha2) \
- $(use_enable gost) \
- $(use_enable ecdsa) \
- $(use_enable dane) \
- $(use_with ssl ssl "${EPREFIX}"/usr) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --without-drill \
- --without-examples \
- --disable-rpath
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dohtml -r doc/html/.
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- prune_libtool_files --modules
- use python && python_optimize
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
- fi
-
- einfo
- elog "Install net-dns/ldns-utils if you want drill and examples"
- einfo
-}
diff --git a/net-libs/ldns/ldns-1.7.0-r1.ebuild b/net-libs/ldns/ldns-1.7.0-r1.ebuild
deleted file mode 100644
index 50cea5972721..000000000000
--- a/net-libs/ldns/ldns-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib-minimal python-single-r1
-
-DESCRIPTION="a library with the aim to simplify DNS programming in C"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+dane doc +ecdsa gost libressl python +ssl static-libs vim-syntax"
-
-# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="ecdsa? ( ssl )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
- dane? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
- ecdsa? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0[-bindist,${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
- gost? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- )
-"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )
-"
-
-RESTRICT="test" # 1.6.9 has no test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(use_enable ssl sha2) \
- $(use_enable gost) \
- $(use_enable ecdsa) \
- $(use_enable dane) \
- $(use_with ssl ssl "${EPREFIX}"/usr) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --without-drill \
- --without-examples \
- --disable-dane-ta-usage \
- --disable-rpath
-
- # >=openssl-1.1.0 required for dane-ta
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-CVE-2017-1000231.patch"
- epatch "${FILESDIR}/${P}-CVE-2017-1000232.patch"
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dohtml -r doc/html/.
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- prune_libtool_files --modules
- use python && python_optimize
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
- fi
-
- einfo
- elog "Install net-dns/ldns-utils if you want drill and examples"
- einfo
-}