summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-09-11 22:35:50 +0100
committerMarkos Chandras <hwoarang@gentoo.org>2015-09-11 22:36:20 +0100
commitf3b7a35abb258019987890573b730f3c1f18ad04 (patch)
treec566b52582da3f14c5a077929966a39910416131 /net-libs
parentapp-emulation/qemu: require mesa[egl] too (diff)
downloadgentoo-f3b7a35abb258019987890573b730f3c1f18ad04.tar.gz
gentoo-f3b7a35abb258019987890573b730f3c1f18ad04.tar.bz2
gentoo-f3b7a35abb258019987890573b730f3c1f18ad04.zip
net-libs/rb_libtorrent: Backport upstream patch to fix debug builds. Thanks to Eugene (#559728)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-1.0.6-fix-debug-build.patch26
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.6.ebuild5
2 files changed, 30 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.6-fix-debug-build.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.6-fix-debug-build.patch
new file mode 100644
index 000000000000..62429e75dd95
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.6-fix-debug-build.patch
@@ -0,0 +1,26 @@
+Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
+X-Gentoo-Bug: 559728
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=559728
+
+From 06ce6a2d8b048c5791e2cc5acd1dfe8845680a84 Mon Sep 17 00:00:00 2001
+From: Chocobo1 <Chocobo1@users.noreply.github.com>
+Date: Sat, 1 Aug 2015 20:29:43 +0800
+Subject: [PATCH] Fix typo
+
+---
+ src/torrent.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/torrent.cpp b/src/torrent.cpp
+index d2da131..2e276ec 100644
+--- a/src/torrent.cpp
++++ b/src/torrent.cpp
+@@ -675,7 +675,7 @@ namespace libtorrent
+ }
+
+ #if defined TORRENT_VERBOSE_LOGGING || defined TORRENT_LOGGING
+- debug_log("*** LEAVING SEED MODE (%s)", seed ? "as seed" : "as non-seed");
++ debug_log("*** LEAVING SEED MODE (%s)", m_seed_mode ? "as seed" : "as non-seed");
+ #endif
+ m_seed_mode = false;
+ // seed is false if we turned out not
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.6.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.6.ebuild
index 9bad38985765..45085823a62a 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-1.0.6.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.6.ebuild
@@ -41,7 +41,10 @@ DEPEND="${RDEPEND}
RESTRICT="test"
-PATCHES=( "${FILESDIR}"/${PN}-1.0.2-python.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-python.patch
+ "${FILESDIR}"/${P}-fix-debug-build.patch
+)
AUTOTOOLS_IN_SOURCE_BUILD=1