summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/fetchmail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild100
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch14
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch11
-rw-r--r--net-mail/fetchmail/files/fetchmail.conf1
-rw-r--r--net-mail/fetchmail/files/fetchmail.confd10
-rw-r--r--net-mail/fetchmail/files/fetchmail.initd44
-rw-r--r--net-mail/fetchmail/files/fetchmail.service11
-rw-r--r--net-mail/fetchmail/metadata.xml13
9 files changed, 205 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
new file mode 100644
index 000000000000..3f091150e905
--- /dev/null
+++ b/net-mail/fetchmail/Manifest
@@ -0,0 +1 @@
+DIST fetchmail-6.3.26.tar.xz 1283816 SHA256 79b4c54cdbaf02c1a9a691d9948fcb1a77a1591a813e904283a8b614b757e850 SHA512 8e0a2484e60eaf6c0231e2599e10fec6d207fa1c0fa02ec99b3ef9aea00b6d87275434e79470a25f06e358cdd4a293f9c46a82dd128fe733a99c85144e6caa63 WHIRLPOOL 275d7b121a7fcec239e074d2dadc8d1645633d7f8335d760ceba98042b8b3bfe67cdacb9e247a072a8c587f821b23f89c1c7e654fd171ad4372dbb69bcf1021a
diff --git a/net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild b/net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild
new file mode 100644
index 000000000000..b3c143a2ca82
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.26-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1 user systemd toolchain-funcs autotools eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos hesiod tk socks"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 >=dev-libs/openssl-0.9.6 )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ tk? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+
+ epatch "${FILESDIR}"/${P}-python-optional.patch
+ epatch "${FILESDIR}"/${P}-tests.patch
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with hesiod) \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 700 /var/lib/${PN}
+
+ default
+
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch b/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch
new file mode 100644
index 000000000000..2eafe4dcbb24
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch
@@ -0,0 +1,14 @@
+--- fetchmail-6.3.26/Makefile.am
++++ fetchmail-6.3.26/Makefile.am
+@@ -16,9 +16,11 @@
+ pys= fetchmailconf.py
+ pym= fetchmailconf.man
+
++if HAVE_PYTHON
+ nodist_bin_SCRIPTS= fetchmailconf
+ python_PYTHON= $(pys)
+ dist_man1_MANS+= $(pym)
++endif
+
+ CLEANFILES= $(nodist_bin_SCRIPTS)
+
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch b/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch
new file mode 100644
index 000000000000..a0b3e8b5dfbb
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch
@@ -0,0 +1,11 @@
+--- fetchmail-6.3.26/Makefile.am
++++ fetchmail-6.3.26/Makefile.am
+@@ -45,7 +47,7 @@
+ check_PROGRAMS=
+
+ TESTS= t.smoke t.validate-xhtml10 t.validate-xhtml t.x509_name_match
+-TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)" $(SHELL)
++TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)"
+
+ if NEED_TRIO
+ noinst_LIBRARIES+= libtrio.a
diff --git a/net-mail/fetchmail/files/fetchmail.conf b/net-mail/fetchmail/files/fetchmail.conf
new file mode 100644
index 000000000000..07945f876468
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.conf
@@ -0,0 +1 @@
+d /run/fetchmail 700 fetchmail nobody
diff --git a/net-mail/fetchmail/files/fetchmail.confd b/net-mail/fetchmail/files/fetchmail.confd
new file mode 100644
index 000000000000..a5d0b74013b6
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.confd
@@ -0,0 +1,10 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Polling frequency in seconds
+# (fetchmail will daemonize and check for new mail at this interval)
+polling_period="60"
+
+# Directory where the pid file is kept
+pid_dir="/var/run/fetchmail"
diff --git a/net-mail/fetchmail/files/fetchmail.initd b/net-mail/fetchmail/files/fetchmail.initd
new file mode 100644
index 000000000000..889bcb61bb7d
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.initd
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+
+piddir=${pid_dir:-/var/run/fetchmail}
+pid_file=${piddir}/${RC_SVCNAME}.pid
+rcfile=/etc/${RC_SVCNAME}rc
+
+depend() {
+ need net
+ use mta
+}
+
+checkconfig() {
+ if [ ! -f ${rcfile} ]; then
+ eerror "Configuration file ${rcfile} not found"
+ return 1
+ fi
+ local fetchmail_instance
+ fetchmail_instance=${RC_SVCNAME##*.}
+ if [ -n "${fetchmail_instance}" -a "${RC_SVCNAME}" != "fetchmail" ]; then
+ fidfile=/var/lib/fetchmail/.fetchids.${RC_SVCNAME}
+ else
+ fidfile=/var/lib/fetchmail/.fetchids
+ fi
+ if [ ! -d ${piddir} ]; then
+ checkpath -q -d -o fetchmail:fetchmail -m 0755 ${piddir} || return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${RC_SVCNAME}"
+ start-stop-daemon --start --pidfile ${pid_file} \
+ --user fetchmail --exec /usr/bin/fetchmail \
+ -- -d ${polling_period} -f ${rcfile} \
+ --pidfile ${pid_file} -i ${fidfile}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${RC_SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile ${pid_file}
+ eend ${?}
+}
+
diff --git a/net-mail/fetchmail/files/fetchmail.service b/net-mail/fetchmail/files/fetchmail.service
new file mode 100644
index 000000000000..954f06e27be0
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A remote-mail retrieval utility
+After=network.target
+
+[Service]
+User=fetchmail
+ExecStart=/usr/bin/fetchmail -d 60 -f /etc/fetchmailrc
+RestartSec=1
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-mail/fetchmail/metadata.xml b/net-mail/fetchmail/metadata.xml
new file mode 100644
index 000000000000..236fc8487bdb
--- /dev/null
+++ b/net-mail/fetchmail/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="hesiod">Enable support for hesiod</flag>
+ <flag name="tk">Enable support for Tk GUI toolkit, in particular it installs fetchmailconf</flag>
+ <flag name="socks">Enable support for socks proxy</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">fetchmail</remote-id>
+ </upstream>
+</pkgmetadata>