summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/hotwayd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/hotwayd')
-rw-r--r--net-mail/hotwayd/Manifest1
-rw-r--r--net-mail/hotwayd/files/hotwayd-0.8-amd64.patch13
-rw-r--r--net-mail/hotwayd/files/hotwayd-0.8-headerfix.patch24
-rw-r--r--net-mail/hotwayd/files/hotwayd-0.8.xinetd28
-rw-r--r--net-mail/hotwayd/files/hotwayd.xinetd25
-rw-r--r--net-mail/hotwayd/hotwayd-0.8.4.ebuild74
-rw-r--r--net-mail/hotwayd/metadata.xml11
7 files changed, 176 insertions, 0 deletions
diff --git a/net-mail/hotwayd/Manifest b/net-mail/hotwayd/Manifest
new file mode 100644
index 000000000000..72498d3fb1be
--- /dev/null
+++ b/net-mail/hotwayd/Manifest
@@ -0,0 +1 @@
+DIST hotwayd-0.8.4.tar.bz2 161274 SHA256 5915fe038c3285bbfb732d55314b992a1734118c38528666ff69882e16d01d81
diff --git a/net-mail/hotwayd/files/hotwayd-0.8-amd64.patch b/net-mail/hotwayd/files/hotwayd-0.8-amd64.patch
new file mode 100644
index 000000000000..a74d9ab9131b
--- /dev/null
+++ b/net-mail/hotwayd/files/hotwayd-0.8-amd64.patch
@@ -0,0 +1,13 @@
+--- hotwayd-0.8/work/hotwayd-0.8/libghttp-1.0.9-mod/md5.h 2002-11-02 00:54:21.000000000 +0000
++++ hotwayd-0.8_patched/work/hotwayd-0.8/libghttp-1.0.9-mod/md5.h 2004-07-26 15:51:20.634345504 +0100
+@@ -38,7 +38,9 @@
+ typedef unsigned short int UINT2;
+
+ /* UINT4 defines a four byte word */
+-typedef unsigned long int UINT4;
++// not on x86_64 it ain't...
++//typedef unsigned long int UINT4;
++typedef unsigned int UINT4;
+
+ /* PROTO_LIST is defined depending on how PROTOTYPES is defined above.
+ If using PROTOTYPES, then PROTO_LIST returns the list, otherwise it
diff --git a/net-mail/hotwayd/files/hotwayd-0.8-headerfix.patch b/net-mail/hotwayd/files/hotwayd-0.8-headerfix.patch
new file mode 100644
index 000000000000..b9cb31decefe
--- /dev/null
+++ b/net-mail/hotwayd/files/hotwayd-0.8-headerfix.patch
@@ -0,0 +1,24 @@
+--- hotwayd-0.8.orig/commands.c 2004-02-07 06:44:05.000000000 -0500
++++ hotwayd-0.8/commands.c 2004-10-03 15:53:25.636497904 -0400
+@@ -1037,12 +1037,16 @@
+
+ char *grow_and_copy(char *dest, int curpos, char *src, int i)
+ {
+- if(!(dest = realloc(dest, curpos+i+1)))
++ char* temp = 0;
++ if(!(temp = malloc(curpos+i+1)))
+ return NULL;
+-
+- strlcat(dest, src, curpos+i+1);
+-
+- return dest;
++
++ memcpy(temp, dest, curpos);
++ memcpy(temp+curpos, src, i);
++ temp[curpos+i] = '\0';
++
++ free(dest);
++ return temp;
+ }
+
+ int proxy_sanity_check(void) {
diff --git a/net-mail/hotwayd/files/hotwayd-0.8.xinetd b/net-mail/hotwayd/files/hotwayd-0.8.xinetd
new file mode 100644
index 000000000000..c0e50fe7427f
--- /dev/null
+++ b/net-mail/hotwayd/files/hotwayd-0.8.xinetd
@@ -0,0 +1,28 @@
+# default: off
+# description: hotway daemon
+# - You need to add a line that says "hotwayd 110/tcp" to your
+# /etc/services file. Change the port number if necessary, see below.
+# - By default it listens to port 110 (default for pop3)
+# If you already have a pop3 server running, or you want it to listen
+# to another port change the value of "port = 110" below.
+# Change the value in your email client and in /etc/services accordingly.
+# - By default it only allows access from localhost.
+# - Also all xinetd entries do not start by default.
+# One should manually enable the entries that one wants by
+# changing the value of "disable = yes" to "disable = no".
+# - Restart xinetd after changing anything in this file:
+# # /etc/init.d/xinetd restart
+
+service hotwayd
+{
+ only_from = localhost
+ socket_type = stream
+ wait = no
+ user = nobody
+ port = 110
+ server = /usr/sbin/hotwayd
+ #server_args = - http://proxy:8080 -u proxy_user -q proxy_password
+ log_on_success += USERID
+ log_on_failure += USERID
+ disable = yes
+}
diff --git a/net-mail/hotwayd/files/hotwayd.xinetd b/net-mail/hotwayd/files/hotwayd.xinetd
new file mode 100644
index 000000000000..65947585fa77
--- /dev/null
+++ b/net-mail/hotwayd/files/hotwayd.xinetd
@@ -0,0 +1,25 @@
+# default: off
+# description: hotway daemon
+# - By default it listens to port 1100, so please adjust settings in your
+# clients
+# - By default it only allows access from localhost.
+# - Also all xinetd entries do not start by default.
+# One should manually enable the entries that one wants by
+# changing the value of "disable = yes" to "disable = no".
+# - Restart xinetd after changing anything in this file:
+# # /etc/init.d/xinetd restart
+
+service hotwayd
+{
+ only_from = localhost
+ socket_type = stream
+ wait = no
+ user = nobody
+ port = 1100
+ server = /usr/sbin/hotwayd
+ #server_args = -p http://proxy:8080 -u proxy_user -q proxy_password
+ log_on_success += USERID
+ log_on_failure += USERID
+ disable = yes
+ type = unlisted
+}
diff --git a/net-mail/hotwayd/hotwayd-0.8.4.ebuild b/net-mail/hotwayd/hotwayd-0.8.4.ebuild
new file mode 100644
index 000000000000..6eba3696751b
--- /dev/null
+++ b/net-mail/hotwayd/hotwayd-0.8.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Hotmail to pop3 daemon"
+HOMEPAGE="http://hotwayd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hotwayd/${P}.tar.bz2"
+RESTRICT="mirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+
+IUSE="smtp"
+
+DEPEND="virtual/inetd
+ dev-libs/libxml2
+ smtp? ( >=dev-libs/cyrus-sasl-2 )"
+
+hotmail_greed_warning() {
+ echo
+ ewarn "WARNING:"
+ ewarn "Since Hotmail started to charge for WebDAV access, you need a Hotmail Plus"
+ ewarn "(or equivalent MSN) account to keep using hotwayd. More info:"
+ ewarn "http://www.boolean.ca/hotpop/"
+ ewarn "http://sourceforge.net/forum/forum.php?thread_id=1277989&forum_id=80217"
+ echo
+ ebeep 3
+ epause 10
+}
+
+pkg_setup() {
+ hotmail_greed_warning
+}
+
+src_install () {
+ # The original make install is broken, since it also tries to install
+ # the libghttp files. This is not needed, since this library is statically
+ # linked into the executable.
+ # Lets just copy the (one) file manually...
+ dosbin hotwayd
+ if use smtp; then
+ dosbin hotsmtpd/hotsmtpd
+ insinto /etc/xinetd.d
+ sed -i -e 's:^disable = no:disable = yes:' hotsmtpd/hotsmtpd.xinetd
+ newins hotsmtpd/hotsmtpd.xinetd hotsmtpd
+ fi
+
+ dodoc AUTHORS NEWS README
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/${PN}.xinetd ${PN}
+}
+
+pkg_postinst () {
+ hotmail_greed_warning
+ echo
+ elog " By default daemons that use xinetd are not started automatically in gentoo"
+ elog " To activate do the following steps: "
+ elog " - Edit the file /etc/xinetd.d/hotwayd and change disable "
+ elog " from yes to no "
+ elog " - Restart xinetd with \`/etc/init.d/xinetd restart\` "
+ elog
+ if use smtp; then
+ elog "You chose to install hotsmtpd, a SMTP proxy for hotmail. Please"
+ elog "Configure /etc/xinetd.d/hotsmtpd and restart xinetd to start using it."
+ elog
+ fi
+ elog "Set your e-mail applications to use port 1100 for receiving email."
+ if use smtp; then
+ elog "Use port 2500 for sending email."
+ fi
+}
diff --git a/net-mail/hotwayd/metadata.xml b/net-mail/hotwayd/metadata.xml
new file mode 100644
index 000000000000..d690df6a5083
--- /dev/null
+++ b/net-mail/hotwayd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="smtp">Build SMTP proxy (hotsmtpd)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">hotwayd</remote-id>
+ </upstream>
+</pkgmetadata>