summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/qlogtools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/qlogtools')
-rw-r--r--net-mail/qlogtools/Manifest1
-rw-r--r--net-mail/qlogtools/files/qlogtools-3.1-errno.patch13
-rw-r--r--net-mail/qlogtools/metadata.xml9
-rw-r--r--net-mail/qlogtools/qlogtools-3.1.ebuild40
4 files changed, 63 insertions, 0 deletions
diff --git a/net-mail/qlogtools/Manifest b/net-mail/qlogtools/Manifest
new file mode 100644
index 000000000000..065c51c9ce43
--- /dev/null
+++ b/net-mail/qlogtools/Manifest
@@ -0,0 +1 @@
+DIST qlogtools-3.1.tar.gz 20868 RMD160 e420474b48d6efb04b382672e28d4276697e8098 SHA1 6e9e32a4a9ca7f3e29958384227eb2a033f8a1b9 SHA256 7a81eb8b8bf32abc75092b9779715b3d20eab902e6aba52a3b4ac04232af2de3
diff --git a/net-mail/qlogtools/files/qlogtools-3.1-errno.patch b/net-mail/qlogtools/files/qlogtools-3.1-errno.patch
new file mode 100644
index 000000000000..b080e1d285f8
--- /dev/null
+++ b/net-mail/qlogtools/files/qlogtools-3.1-errno.patch
@@ -0,0 +1,13 @@
+diff -ur qlogtools-3.1.orig/qfilelog.c qlogtools-3.1/qfilelog.c
+--- qlogtools-3.1.orig/qfilelog.c 2001-06-12 14:41:47.000000000 -0700
++++ qlogtools-3.1/qfilelog.c 2003-07-31 21:52:51.000000000 -0700
+@@ -3,8 +3,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+-
+-extern int errno;
++#include <errno.h>
+
+ #define PAUSE sleep(60)
+
diff --git a/net-mail/qlogtools/metadata.xml b/net-mail/qlogtools/metadata.xml
new file mode 100644
index 000000000000..d52303d1cbac
--- /dev/null
+++ b/net-mail/qlogtools/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qmail</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-mail/qlogtools/qlogtools-3.1.ebuild b/net-mail/qlogtools/qlogtools-3.1.ebuild
new file mode 100644
index 000000000000..89bfa4f29c20
--- /dev/null
+++ b/net-mail/qlogtools/qlogtools-3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Qmail Log processing tools"
+HOMEPAGE="http://untroubled.org/qlogtools/"
+SRC_URI="http://untroubled.org/qlogtools/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-text/multitail"
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d ${P}" epatch ${FILESDIR}/qlogtools-3.1-errno.patch
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man/" > conf-man
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/
+ ./installer || die "Installer failed"
+ dodoc ANNOUNCEMENT FILES NEWS README TARGETS VERSION
+}
+
+pkg_postinst() {
+ elog "Please see /usr/share/doc/${PF}/README for configuration information"
+}