summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-05-06 09:38:35 -0400
committerBrian Evans <grknight@gentoo.org>2016-05-06 09:39:37 -0400
commitec21645592ef5a5d96e35d56e5522580083f14e2 (patch)
tree0bc56523a64ea6203dbadfc3132f990504c79e0d /net-mail/queue-repair
parentdev-python/progressbar-2.3-r2: add ppc keyword (diff)
downloadgentoo-ec21645592ef5a5d96e35d56e5522580083f14e2.tar.gz
gentoo-ec21645592ef5a5d96e35d56e5522580083f14e2.tar.bz2
gentoo-ec21645592ef5a5d96e35d56e5522580083f14e2.zip
net-mail/queue-repair: Non-maintainer commit - Revbump to fix bug 405899
Bump EAPI from 0 to 6 Use the python-single-r1 eclass Package-Manager: portage-2.2.28
Diffstat (limited to 'net-mail/queue-repair')
-rw-r--r--net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild b/net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..33bcb55bbde1
--- /dev/null
+++ b/net-mail/queue-repair/queue-repair-0.9.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="A toolkit for dealing with the qmail queue directory structure"
+HOMEPAGE="http://pyropus.ca/software/queue-repair/"
+SRC_URI="http://pyropus.ca/software/queue-repair/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+REQURIED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( BLURB TODO CHANGELOG )
+
+src_install () {
+ python_newscript queue_repair.py queue-repair.py
+ dosym /usr/bin/queue-repair.py /usr/bin/queue-repair
+ einstalldocs
+}