summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/vqadmin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/vqadmin')
-rw-r--r--net-mail/vqadmin/Manifest2
-rw-r--r--net-mail/vqadmin/files/postinstall-en.txt12
-rw-r--r--net-mail/vqadmin/metadata.xml8
-rw-r--r--net-mail/vqadmin/vqadmin-2.3.6.ebuild114
-rw-r--r--net-mail/vqadmin/vqadmin-2.3.7.ebuild64
5 files changed, 200 insertions, 0 deletions
diff --git a/net-mail/vqadmin/Manifest b/net-mail/vqadmin/Manifest
new file mode 100644
index 000000000000..63dd122627a9
--- /dev/null
+++ b/net-mail/vqadmin/Manifest
@@ -0,0 +1,2 @@
+DIST vqadmin-2.3.6.tar.gz 155771 RMD160 31b89d0f6b605a96445d304e084ef6bc7b055376 SHA1 41e6ac1728f1a3b592377abcfa51e2e38d5d4f4c SHA256 e72fde3cf538d1e93a6aaaffbce100aeb417350d07cb73ee49b08c22256076d9
+DIST vqadmin-2.3.7.tar.gz 153678 RMD160 89657c2c6f1c9848c36e9684b605c4e450442c71 SHA1 c38bcecd301656a95dbf0244b569c67b71445816 SHA256 af68640f454896d6d267b6aee63a79ae0605c0104cff083aa6dc5df0d8c4ee0f
diff --git a/net-mail/vqadmin/files/postinstall-en.txt b/net-mail/vqadmin/files/postinstall-en.txt
new file mode 100644
index 000000000000..3a909a78d9fb
--- /dev/null
+++ b/net-mail/vqadmin/files/postinstall-en.txt
@@ -0,0 +1,12 @@
+You need to setup authentication. For apache do the following:
+
+<Files ${VHOST_CGIBINDIR}/${PN}>
+ AuthType Basic
+ AuthUserFile ${VHOST_CONFDIR}${PN}.passwd
+ AuthName ${PN}
+ Require valid-user
+</Files>
+
+The create the password file like this:
+
+htpasswd -c ${VHOST_CONFDIR}${PN}.passwd <user>
diff --git a/net-mail/vqadmin/metadata.xml b/net-mail/vqadmin/metadata.xml
new file mode 100644
index 000000000000..a732fd8b2f03
--- /dev/null
+++ b/net-mail/vqadmin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-mail/vqadmin/vqadmin-2.3.6.ebuild b/net-mail/vqadmin/vqadmin-2.3.6.ebuild
new file mode 100644
index 000000000000..10ee9006c4ba
--- /dev/null
+++ b/net-mail/vqadmin/vqadmin-2.3.6.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit depend.apache
+
+DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains. Works with qmailadmin"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.inter7.com/${PN}"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND=">=net-mail/vpopmail-5.3
+ virtual/qmail"
+RDEPEND="${DEPEND}
+ net-mail/qmailadmin"
+
+need_apache
+
+src_compile() {
+ local dir_vhost="/var/www/localhost/"
+ local dir_vpopmail="/var/vpopmail"
+ local dir_htdocs="${dir_vhost}/htdocs/${PN}"
+ local dir_htdocs_images="${dir_htdocs}/images"
+ local url_htdocs_images="/${PN}/images"
+ local dir_cgibin="${dir_vhost}/cgi-bin"
+ local url_cgibin="/cgi-bin/${PN}"
+ local dir_htdocs_htmlib="/usr/share/${PN}/htmllib"
+ local dir_qmail="/var/qmail"
+ local bin_true="/bin/true"
+ local dir_ezmlm="/usr/bin"
+ local dir_autorespond="/var/qmail/bin"
+ sed -e "3356iwwwroot='${dir_htdocs}'" -e '3356,3369d' -i configure || die "failed to fix configure"
+
+ find . -name 'Makefile*' -o -name '*.c' -o -name '*.html' | xargs -n1 -t sed 's|images/vqadmin|vqadmin/images|g' -i
+
+ econf ${myopts} \
+ --enable-vpopmaildir=${dir_vpopmail} \
+ --enable-htmldir=${dir_htdocs} \
+ --enable-imageurl=${url_htdocs_images} \
+ --enable-imagedir=${dir_htdocs_images} \
+ --enable-htmllibdir=${dir_htdocs_htmlib} \
+ --enable-qmaildir=${dir_qmail} \
+ --enable-true-path=${bin_true} \
+ --enable-ezmlmdir=${dir_ezmlm} \
+ --enable-cgibindir=${dir_cgibin} \
+ --enable-cgipath=${url_cgibin} \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ || die "econf failed"
+
+ sed 's|/vqadmin/vqadmin/|/vqadmin/|g' -i Makefile
+
+ emake || die
+ sed -e "/install-exec-local:/,/chmod go+r/s|${dir_vhost}|\$(DESTDIR)${dir_vhost}|" -i Makefile
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ dodoc ACL AUTHORS BUGS ChangeLog FAQ INSTALL NEWS TODO README
+}
+
+#pkg_config() {
+#
+# einfo "Performing post-installation routines for ${P}."
+#
+# cat > ${REAL_CGIBINDIR}/vqadmin/vqadmin.conf <<EOF
+#<Directory "${REAL_CGIBINDIR}/vqadmin">
+# deny from all
+# Options ExecCGI
+# AllowOverride AuthConfig
+# Order deny,allow
+#</Directory>
+#EOF
+#
+# # Including configuration to the apache config file
+# echo "Include ${REAL_CGIBINDIR}/vqadmin/vqadmin.conf" >> /etc/apache/conf/apache.conf
+#
+# # Creating .htaccess
+# einfo ""
+# einfo "We need to create an htaccess for the directory so Apache knows"
+# einfo "how to authenticate users trying to access the directory."
+# cat > ${REAL_CGIBINDIR}/vqadmin/.htaccess <<EOF
+#AuthType Basic
+#AuthUserFile /etc/apache/conf/vqadmin.passwd
+#AuthName vqadmin
+#require valid-user
+#satisfy any
+#EOF
+# # Tightening Permissions
+# chown apache.apache ${REAL_CGIBINDIR}/vqadmin/.htaccess
+# chmod 600 ${REAL_CGIBINDIR}/vqadmin/.htaccess
+#
+# # How set up users ?
+# einfo "Now, You can create a user. Example: "
+# einfo " htpasswd -c /etc/apache/conf/vqadmin.passwd username"
+# einfo "then: "
+# einfo " cd /etc/apache/conf/ && chown root.apache vqadmin.passwd"
+# einfo " chmod 640 vqadmin.passwd"
+# einfo ""
+# einfo "IMPORTANT ! Use the -c (-create) switch ONLY the first time"
+# einfo "IMPORTANT ! You will have to restart apache to get vqadmin working"
+#}
+
+#pkg_postrm() {
+# rm -rf ${REAL_CGIBINDIR}/vqadmin/vqadmin.conf
+# rm -rf ${REAL_CGIBINDIR}/vqadmin/.htaccess
+# rmdir ${REAL_CGIBINDIR}/vqadmin
+# sed "/^Include.*vqadmin.conf$/d" /etc/apache/conf/apache.conf > /etc/apache/conf/apache.conf.new
+# mv --force /etc/apache/conf/apache.conf.new /etc/apache/conf/apache.conf
+#}
diff --git a/net-mail/vqadmin/vqadmin-2.3.7.ebuild b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
new file mode 100644
index 000000000000..227287639b96
--- /dev/null
+++ b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit webapp eutils autotools qmail
+
+DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains. Works with qmailadmin"
+HOMEPAGE="http://www.inter7.com/index.php?page=vqadmin"
+SRC_URI="http://www.inter7.com/vqadmin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/qmail
+ >=net-mail/vpopmail-5.3"
+RDEPEND="${DEPEND}
+ net-mail/qmailadmin"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes for sane webapp integration
+ sed -i \
+ -e "s|html/|/usr/share/${PN}/|g" \
+ -e "s|/images/vqadmin/|/vqadmin/|g" \
+ -e "s|/cgi-bin/vqadmin/|/cgi-bin/|g" \
+ -e "s|vqadmin\.cgi|vqadmin|g" \
+ *.h *.c html/*.html
+}
+
+src_compile() {
+ econf ${myopts} \
+ --enable-qmaildir="${QMAIL_HOME}" \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ --enable-cgibindir="${MY_CGIBINDIR}" \
+ || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto /usr/share/${PN}
+ doins html/*
+
+ insinto "${MY_HTDOCSDIR}"
+ doins html/*.css
+
+ insinto "${MY_CGIBINDIR}"
+ doins vqadmin.acl
+ insopts -m 755
+ doins vqadmin
+
+ dodoc ACL AUTHORS BUGS ChangeLog FAQ INSTALL NEWS TODO README
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}