summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/elliptics
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/elliptics')
-rw-r--r--net-misc/elliptics/Manifest1
-rw-r--r--net-misc/elliptics/elliptics-2.19.2.6.ebuild71
-rw-r--r--net-misc/elliptics/files/elliptics.confd3
-rw-r--r--net-misc/elliptics/files/elliptics.initd35
-rw-r--r--net-misc/elliptics/metadata.xml11
5 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/elliptics/Manifest b/net-misc/elliptics/Manifest
new file mode 100644
index 000000000000..556592aa2754
--- /dev/null
+++ b/net-misc/elliptics/Manifest
@@ -0,0 +1 @@
+DIST elliptics-2.19.2.6.tar.gz 217118 SHA256 33803bea4f1bce448abf0c3203b9b2828ccde8dbb4b2b1a234d187b1a73a5436 SHA512 63670812fe422b2b02335e8ff248bdac19a0825a69118d3afa473c7775b177b469078c2dab47ace08643859e92576e1cdcdf44388489994b9560e96e7fbb400e WHIRLPOOL 44c334b238d0fa6a5767815cb9ccaa9bef68279b4314f405e8c78ea53e40a6210d4dc4e31fc62e665886f25272c079eef4b94a8b75fd0a0c2d5a9d0815227088
diff --git a/net-misc/elliptics/elliptics-2.19.2.6.ebuild b/net-misc/elliptics/elliptics-2.19.2.6.ebuild
new file mode 100644
index 000000000000..052d07f263db
--- /dev/null
+++ b/net-misc/elliptics/elliptics-2.19.2.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+DESCRIPTION="Elliptics network is a fault tolerant key/value storage without dedicated metadata servers"
+HOMEPAGE="http://www.ioremap.net/projects/elliptics"
+LICENSE="GPL-2"
+SLOT="0"
+
+inherit user eutils python flag-o-matic cmake-utils
+
+KEYWORDS="~x86 ~amd64"
+IUSE="fastcgi python"
+RDEPEND="app-arch/snappy
+ dev-libs/openssl
+ fastcgi? ( dev-libs/fcgi )
+ net-misc/elliptics-eblob
+ dev-libs/boost[python]
+ dev-libs/libevent
+ dev-libs/leveldb
+ dev-libs/smack
+ dev-db/kyotocabinet
+ net-misc/cocaine-core
+ net-libs/zeromq"
+DEPEND="${RDEPEND}"
+
+SRC_URI="https://github.com/reverbrain/elliptics/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+pkg_setup() {
+ enewgroup elliptics
+ enewuser elliptics -1 -1 /dev/null elliptics
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure(){
+ use python && filter-ldflags -Wl,--as-needed
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+
+ use fastcgi && example/fcgi/lighttpd-fastcgi-elliptics.conf
+ dodoc doc/design_notes.txt \
+ doc/io_storage_backend.txt \
+ example/EXAMPLE \
+ example/ioserv.conf
+
+ # init script stuff
+ # too many changes since the old version, needs to be re-added
+ #newinitd "${FILESDIR}"/elliptics.initd elliptics || die
+ #newconfd "${FILESDIR}"/elliptics.confd elliptics || die
+
+ # tune default config
+ sed -i 's#log = /dev/stderr#log = syslog#' "${S}/example/ioserv.conf"
+ sed -i 's#root = /tmp/root#root = /var/spool/elliptics#' "${S}/example/ioserv.conf"
+ sed -i 's#daemon = 0#daemon = 1#' "${S}/example/ioserv.conf"
+ sed -i 's#history = /tmp/history#history = /var/run/elliptics#' "${S}/example/ioserv.conf"
+
+ # configs
+ insinto /etc/elliptics
+ doins "${S}/example/ioserv.conf"
+
+ keepdir /var/{spool,run}/elliptics
+ fowners elliptics:elliptics /var/{spool,run}/elliptics
+ fperms 0750 /var/{spool,run}/elliptics
+}
diff --git a/net-misc/elliptics/files/elliptics.confd b/net-misc/elliptics/files/elliptics.confd
new file mode 100644
index 000000000000..70743c00411b
--- /dev/null
+++ b/net-misc/elliptics/files/elliptics.confd
@@ -0,0 +1,3 @@
+ELLIPTICS_BIN=/usr/bin/dnet_ioserv
+ELLIPTICS_CONF=/etc/elliptics/ioserv.conf
+ELLIPTICS_USER=elliptics \ No newline at end of file
diff --git a/net-misc/elliptics/files/elliptics.initd b/net-misc/elliptics/files/elliptics.initd
new file mode 100644
index 000000000000..b18d3d27a7e7
--- /dev/null
+++ b/net-misc/elliptics/files/elliptics.initd
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+
+opts="reload graceful"
+ELLIPTICS_PNAME=dnet-main
+
+depend() {
+ need net
+ use logger
+ after sshd
+}
+
+
+start() {
+ ebegin "Starting dnet_ioserv"
+ start-stop-daemon --start --user=${ELLIPTICS_USER} --exec ${ELLIPTICS_BIN} -- -c "${ELLIPTICS_CONF}"
+ eend $?
+}
+
+stop() {
+ local rv=0
+ ebegin "Stopping dnet_ioserv"
+ killall -0 ${ELLIPTICS_PNAME} && /usr/bin/killall -w ${ELLIPTICS_PNAME} || true
+ eend $?
+}
+
+reload() {
+ if ! service_started "${SVCNAME}" ; then
+ eerror "${SVCNAME} isn't running"
+ return 1
+ fi
+
+ ebegin "Re-opening dnet_ioserv log files"
+ /usr/bin/killall --signal HUP ${ELLIPTICS_PNAME}
+ eend $?
+} \ No newline at end of file
diff --git a/net-misc/elliptics/metadata.xml b/net-misc/elliptics/metadata.xml
new file mode 100644
index 000000000000..783c4d3a16c5
--- /dev/null
+++ b/net-misc/elliptics/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">reverbrain/elliptics</remote-id>
+ </upstream>
+</pkgmetadata>