summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/knock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/knock')
-rw-r--r--net-misc/knock/Manifest2
-rw-r--r--net-misc/knock/files/knockd.confd.29
-rw-r--r--net-misc/knock/files/knockd.initd.225
-rw-r--r--net-misc/knock/knock-0.6.ebuild48
-rw-r--r--net-misc/knock/knock-0.7.ebuild48
-rw-r--r--net-misc/knock/metadata.xml11
6 files changed, 143 insertions, 0 deletions
diff --git a/net-misc/knock/Manifest b/net-misc/knock/Manifest
new file mode 100644
index 000000000000..fb7ed0b1acc1
--- /dev/null
+++ b/net-misc/knock/Manifest
@@ -0,0 +1,2 @@
+DIST knock-0.6.tar.gz 125772 SHA256 75a4e8ef8c59efa2cc910375191162adf0deeca20b7ab80d9eb0072f696ca541 SHA512 79179fe0358abfeb001b787522154b5045f9dd679e8b6bea0f375a064e56ed5166c20dee094b42d56338afdf19041c94f4c86b8d5d385d1cc02ca525c1b73714 WHIRLPOOL 556c27ac8dfaf58fa866b3644bbb4557dbbaf3f42896024825eccaf25896fa436685a1f1afce2ffe617c7948e368e189c1b00ddf83e19761886fde0c9c33ac02
+DIST knock-0.7.tar.gz 110791 SHA256 9938479c321066424f74c61f6bee46dfd355a828263dc89561a1ece3f56578a4 SHA512 eab5d855f7111d9411e84a56a15e8ea74f41c5bd9dee27ab49f0d8d509eeeb96a60c508928c92916dc0ec9b737c447ca8ca5ed4db6479b389549d60e76a85aa7 WHIRLPOOL 6d25c5d68edf5f1da9eeb8814f965fd0cdbb5c9cadd08895566200d61373481e8f9100818809c6048909112e37c7c95dc0fa558dd9f01e95cb22207583d2d64f
diff --git a/net-misc/knock/files/knockd.confd.2 b/net-misc/knock/files/knockd.confd.2
new file mode 100644
index 000000000000..cd72be91ddde
--- /dev/null
+++ b/net-misc/knock/files/knockd.confd.2
@@ -0,0 +1,9 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# interface to listen to
+IFACE="eth0"
+
+# extra options for knockd daemon
+OPTS=""
diff --git a/net-misc/knock/files/knockd.initd.2 b/net-misc/knock/files/knockd.initd.2
new file mode 100644
index 000000000000..2a52490cee3b
--- /dev/null
+++ b/net-misc/knock/files/knockd.initd.2
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Id$
+
+: ${CONFIGFILE:=/etc/knockd.conf}
+: ${IFACE:=eth0}
+
+get_config() {
+ [ -f ${CONFIGFILE} ] && conf=$(awk 'tolower($1) == "'$1'" { print $3 }' ${CONFIGFILE})
+
+ echo ${conf:-$2}
+}
+
+depend() {
+ need net
+ use net.${IFACE}
+
+ [ "$(get_config usesyslog no)" != "no" ] && use logger
+}
+
+pidfile=$(get_config pidfile /var/run/knockd.pid)
+
+command=/usr/sbin/knockd
+command_args="-d -i ${IFACE} ${OPTS}"
diff --git a/net-misc/knock/knock-0.6.ebuild b/net-misc/knock/knock-0.6.ebuild
new file mode 100644
index 000000000000..8ddab2d763e7
--- /dev/null
+++ b/net-misc/knock/knock-0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A simple port-knocking daemon"
+HOMEPAGE="http://www.zeroflux.org/projects/knock"
+SRC_URI="http://www.zeroflux.org/proj/knock/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="+server"
+
+DEPEND="server? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}
+ server? ( sys-apps/openrc )"
+
+src_prepare() {
+ sed -e "/^AM_CFLAGS/s: -g : :" \
+ -e "/dist_doc_DATA/s:COPYING::" \
+ -i Makefile.in || die
+ sed -e "s:/usr/sbin/iptables:/sbin/iptables:g" \
+ -i knockd.conf || die
+}
+
+src_configure() {
+ econf $(use_enable server knockd)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EROOT}/usr/share/doc/${PF}" install
+
+ if use server ; then
+ newinitd "${FILESDIR}"/knockd.initd.2 knock
+ newconfd "${FILESDIR}"/knockd.confd.2 knock
+ fi
+}
+
+pkg_postinst() {
+ if use server && ! has_version net-firewall/iptables ; then
+ einfo
+ elog "You're really encouraged to install net-firewall/iptables to"
+ elog "actually modify your firewall and use the example configuration."
+ einfo
+ fi
+}
diff --git a/net-misc/knock/knock-0.7.ebuild b/net-misc/knock/knock-0.7.ebuild
new file mode 100644
index 000000000000..dee0bba231a7
--- /dev/null
+++ b/net-misc/knock/knock-0.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A simple port-knocking daemon"
+HOMEPAGE="http://www.zeroflux.org/projects/knock"
+SRC_URI="http://www.zeroflux.org/proj/knock/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="+server"
+
+DEPEND="server? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}
+ server? ( sys-apps/openrc )"
+
+src_prepare() {
+ sed -e "/^AM_CFLAGS/s: -g : :" \
+ -e "/dist_doc_DATA/s:COPYING::" \
+ -i Makefile.in || die
+ sed -e "s:/usr/sbin/iptables:/sbin/iptables:g" \
+ -i knockd.conf || die
+}
+
+src_configure() {
+ econf $(use_enable server knockd)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EROOT}/usr/share/doc/${PF}" install
+
+ if use server ; then
+ newinitd "${FILESDIR}"/knockd.initd.2 knock
+ newconfd "${FILESDIR}"/knockd.confd.2 knock
+ fi
+}
+
+pkg_postinst() {
+ if use server && ! has_version net-firewall/iptables ; then
+ einfo
+ elog "You're really encouraged to install net-firewall/iptables to"
+ elog "actually modify your firewall and use the example configuration."
+ einfo
+ fi
+}
diff --git a/net-misc/knock/metadata.xml b/net-misc/knock/metadata.xml
new file mode 100644
index 000000000000..584231482dd8
--- /dev/null
+++ b/net-misc/knock/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <use>
+ <flag name='server'>Installs the knockd server daemon.</flag>
+ </use>
+</pkgmetadata>