summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/netkit-bootparamd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/netkit-bootparamd')
-rw-r--r--net-misc/netkit-bootparamd/Manifest1
-rw-r--r--net-misc/netkit-bootparamd/files/0.17-jumpstart.patch25
-rw-r--r--net-misc/netkit-bootparamd/files/bootparamd.confd3
-rw-r--r--net-misc/netkit-bootparamd/files/bootparamd.initd26
-rw-r--r--net-misc/netkit-bootparamd/metadata.xml8
-rw-r--r--net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r2.ebuild39
-rw-r--r--net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild45
7 files changed, 147 insertions, 0 deletions
diff --git a/net-misc/netkit-bootparamd/Manifest b/net-misc/netkit-bootparamd/Manifest
new file mode 100644
index 000000000000..4066882e0c12
--- /dev/null
+++ b/net-misc/netkit-bootparamd/Manifest
@@ -0,0 +1 @@
+DIST netkit-bootparamd_0.17.orig.tar.gz 13934 SHA256 7fd44b14f7ee5bf930bdd03b0c3a15bdb6efb60a862af47269b05361c4ed395c
diff --git a/net-misc/netkit-bootparamd/files/0.17-jumpstart.patch b/net-misc/netkit-bootparamd/files/0.17-jumpstart.patch
new file mode 100644
index 000000000000..41b471b5075f
--- /dev/null
+++ b/net-misc/netkit-bootparamd/files/0.17-jumpstart.patch
@@ -0,0 +1,25 @@
+diff -urN netkit-bootparamd-0.17.old/rpc.bootparamd/rpc.bootparamd.c netkit-bootparamd-0.17/rpc.bootparamd/rpc.bootparamd.c
+--- netkit-bootparamd-0.17.old/rpc.bootparamd/rpc.bootparamd.c 2000-07-22 12:23:56.000000000 -0400
++++ netkit-bootparamd-0.17/rpc.bootparamd/rpc.bootparamd.c 2004-09-13 17:42:43.000000000 -0400
+@@ -136,11 +136,16 @@
+ strncpy(path, where, sizeof(path));
+ path[sizeof(path)-1] = 0;
+ he = gethostbyname(hostname);
+- if (!he) goto failed;
+- bcopy( he->h_addr, &res.server_address.bp_address_u.ip_addr, 4);
+- res.server_name = hostname;
+- res.server_path = path;
+- res.server_address.address_type = IP_ADDR_TYPE;
++ if (!he) { /* jumpstart parameters are not valid hosts */
++ res.server_name = hostname;
++ res.server_path = path;
++ bzero(&res.server_address.bp_address_u.ip_addr,4);
++ } else {
++ bcopy( he->h_addr, &res.server_address.bp_address_u.ip_addr, 4);
++ res.server_name = hostname;
++ res.server_path = path;
++ res.server_address.address_type = IP_ADDR_TYPE;
++ }
+ }
+ else { /* special for dump, answer with null strings */
+ if (!strcmp(getfile->file_id, "dump")) {
diff --git a/net-misc/netkit-bootparamd/files/bootparamd.confd b/net-misc/netkit-bootparamd/files/bootparamd.confd
new file mode 100644
index 000000000000..f7e233a46de3
--- /dev/null
+++ b/net-misc/netkit-bootparamd/files/bootparamd.confd
@@ -0,0 +1,3 @@
+#
+
+OPTS_RPC_BOOTPARAMD="-s"
diff --git a/net-misc/netkit-bootparamd/files/bootparamd.initd b/net-misc/netkit-bootparamd/files/bootparamd.initd
new file mode 100644
index 000000000000..167b52474d55
--- /dev/null
+++ b/net-misc/netkit-bootparamd/files/bootparamd.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+[ -e /etc/conf.d/bootparamd ] && . /etc/conf.d/bootparamd
+
+rpc_bin=/usr/sbin/rpc.bootparamd
+
+depend() {
+ use ypbind net
+ need portmap
+ after quota
+}
+
+start() {
+ ebegin "Starting bootparamd"
+ ${rpc_bin} ${OPTS_RPC_BOOTPARAMD}
+ eend $? "make sure DNOTIFY support is enabled ..."
+}
+
+stop() {
+ ebegin "Stopping bootparamd"
+ start-stop-daemon --stop --exec ${rpc_bin}
+ eend $?
+}
diff --git a/net-misc/netkit-bootparamd/metadata.xml b/net-misc/netkit-bootparamd/metadata.xml
new file mode 100644
index 000000000000..5b80fb94c393
--- /dev/null
+++ b/net-misc/netkit-bootparamd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r2.ebuild b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r2.ebuild
new file mode 100644
index 000000000000..134fd9613558
--- /dev/null
+++ b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Netkit - bootparamd"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="mirror://debian/pool/main/n/netkit-bootparamd/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~hppa ~mips ppc sparc x86"
+IUSE=""
+
+DEPEND="!<=net-misc/netkit-bootpd-0.17-r2"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/0.17-jumpstart.patch
+}
+
+src_compile() {
+ # Note this is not an autoconf configure
+ ./configure || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ into /usr
+ dosbin rpc.bootparamd/bootparamd || die "installing binary failed"
+ dosym bootparamd /usr/sbin/rpc.bootparamd
+ doman rpc.bootparamd/bootparamd.8
+ dosym bootparamd.8.gz /usr/share/man/man8/rpc.bootparamd.8.gz
+ doman rpc.bootparamd/bootparams.5
+ dodoc README ChangeLog
+ newdoc rpc.bootparamd/README README.bootparamd
+}
diff --git a/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild
new file mode 100644
index 000000000000..539a9db5454a
--- /dev/null
+++ b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Netkit - bootparamd"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="mirror://debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc sparc x86"
+IUSE=""
+
+DEPEND="!<=net-misc/netkit-bootpd-0.17-r2"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.17-jumpstart.patch
+
+ # don't reset LDFLAGS (bug #335457), manpages into /usr/share/man
+ sed -i -e '/^LDFLAGS=/d ; /MANDIR=/s:man:share/man:' configure || die
+
+ sed -i -e 's:install -s:install:' rpc.bootparamd/Makefile || die
+}
+
+src_configure() {
+ # Note this is not an autoconf configure
+ CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ dodir usr/bin usr/sbin usr/share/man/man8 || die
+ emake INSTALLROOT="${D}" install || die
+
+ newconfd "${FILESDIR}"/bootparamd.confd bootparamd || die
+ newinitd "${FILESDIR}"/bootparamd.initd bootparamd || die
+
+ doman rpc.bootparamd/bootparams.5 || die
+ dodoc README ChangeLog || die
+ newdoc rpc.bootparamd/README README.bootparamd || die
+}