summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/netkit-rusers
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/netkit-rusers')
-rw-r--r--net-misc/netkit-rusers/Manifest1
-rw-r--r--net-misc/netkit-rusers/files/netkit-rusers-0.17-include.patch30
-rw-r--r--net-misc/netkit-rusers/metadata.xml8
-rw-r--r--net-misc/netkit-rusers/netkit-rusers-0.17-r1.ebuild42
4 files changed, 81 insertions, 0 deletions
diff --git a/net-misc/netkit-rusers/Manifest b/net-misc/netkit-rusers/Manifest
new file mode 100644
index 000000000000..1cad7bcc0827
--- /dev/null
+++ b/net-misc/netkit-rusers/Manifest
@@ -0,0 +1 @@
+DIST netkit-rusers-0.17.tar.gz 22063 SHA256 f00138651865ad2dcfec5dedda0cda403cb80c4ab68efcc3bbccafe198c24b6d
diff --git a/net-misc/netkit-rusers/files/netkit-rusers-0.17-include.patch b/net-misc/netkit-rusers/files/netkit-rusers-0.17-include.patch
new file mode 100644
index 000000000000..9dccf5442c41
--- /dev/null
+++ b/net-misc/netkit-rusers/files/netkit-rusers-0.17-include.patch
@@ -0,0 +1,30 @@
+--- ./rup/err.c.orig 1997-04-06 00:13:31.000000000 +0200
++++ ./rup/err.c 2010-12-31 19:29:41.000000000 +0100
+@@ -8,6 +8,7 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <err.h>
++#include <stdlib.h> /* exit() */
+
+ void err(int eval, const char *fmt, ...) {
+ va_list ap;
+--- ./rpc.rusersd/rusers_proc.c.orig 2000-07-23 05:11:56.000000000 +0200
++++ ./rpc.rusersd/rusers_proc.c 2010-12-31 19:27:50.000000000 +0100
+@@ -40,6 +40,7 @@
+ #include <sys/socket.h>
+ #include <sys/param.h>
+ #include <sys/stat.h>
++#include <time.h> /* time() */
+ #ifdef XIDLE
+ #include <setjmp.h>
+ #include <X11/Xlib.h>
+--- ./rusers/rusers.c.orig 1999-12-12 20:32:05.000000000 +0100
++++ ./rusers/rusers.c 2010-12-31 19:30:33.000000000 +0100
+@@ -44,6 +44,7 @@
+ #include <utmp.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <time.h> /* ctime() */
+
+ #include "../version.h"
+
diff --git a/net-misc/netkit-rusers/metadata.xml b/net-misc/netkit-rusers/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/net-misc/netkit-rusers/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/netkit-rusers/netkit-rusers-0.17-r1.ebuild b/net-misc/netkit-rusers/netkit-rusers-0.17-r1.ebuild
new file mode 100644
index 000000000000..b0c474aa8408
--- /dev/null
+++ b/net-misc/netkit-rusers/netkit-rusers-0.17-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Netkit - rup rpc.rusersd rusers"
+HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+ sed -i configure -e '/^LDFLAGS=/d' || die "sed configure"
+}
+
+src_configure() {
+ ./configure --with-c-compiler=$(tc-getCC) || die
+ sed -i MCONFIG -e "s:-O2::" -e "s:-Wpointer-arith::" || die "sed MCONFIG"
+}
+
+src_compile() {
+ # see bug #244867 for parallel make issues
+ emake -j1 || die
+}
+
+src_install() {
+ into /usr
+ dobin rup/rup
+ doman rup/rup.1
+ dobin rpc.rusersd/rusersd
+ doman rpc.rusersd/rpc.rusersd.8
+ dobin rusers/rusers
+ doman rusers/rusers.1
+ dodoc README ChangeLog
+}