summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-21 19:40:22 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-21 20:23:00 +0200
commit8c5f4f10c137a2646f54d1d5b8d531ab0a0bf8a8 (patch)
tree001cc5f233b977d2ff5f1eacc5666072ee4f3144 /net-misc/zsync
parentnet-misc/ser2net: Port to EAPI 8 (diff)
downloadgentoo-8c5f4f10c137a2646f54d1d5b8d531ab0a0bf8a8.tar.gz
gentoo-8c5f4f10c137a2646f54d1d5b8d531ab0a0bf8a8.tar.bz2
gentoo-8c5f4f10c137a2646f54d1d5b8d531ab0a0bf8a8.zip
net-misc/zsync: Port to EAPI 8
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-misc/zsync')
-rw-r--r--net-misc/zsync/zsync-0.6.2-r2.ebuild (renamed from net-misc/zsync/zsync-0.6.2-r1.ebuild)13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-misc/zsync/zsync-0.6.2-r1.ebuild b/net-misc/zsync/zsync-0.6.2-r2.ebuild
index 70575e7f4895..c99fa2fdbb5d 100644
--- a/net-misc/zsync/zsync-0.6.2-r1.ebuild
+++ b/net-misc/zsync/zsync-0.6.2-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools epatch
+inherit autotools
ZLIB_PV=1.2.3
ZLIB_P="zlib-${ZLIB_PV}"
@@ -14,23 +14,22 @@ SRC_URI="
http://zsync.moria.org.uk/download/${P}.tar.bz2
http://www.gzip.org/zlib/${ZLIB_P}.tar.bz2
http://www.zlib.net/${ZLIB_P}.tar.bz2"
+ZLIB_S="${WORKDIR}/${ZLIB_P}"
LICENSE="Artistic-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE=""
-
-ZLIB_S="${WORKDIR}/${ZLIB_P}"
src_prepare() {
+ default
# Move old zlib-1.2.11 out the way
mv "${S}"/zlib zlib-1.2.11-modified || die
cd "${ZLIB_S}" || die
# I am not sure how many other zlib patches we will need to port as well
# This covers the security vuln in 1.2.11
- epatch "${FILESDIR}"/${P}-${ZLIB_P}-support.patch
- rm -f Makefile || die
+ eapply "${FILESDIR}"/${P}-${ZLIB_P}-support.patch
+ rm Makefile || die
cd "${S}" || die
cp -a "${ZLIB_S}" "${ZLIB_P}-modified" || die