summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-25 10:48:28 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-25 10:50:03 +0100
commit70d0659c3dbcaf2600e6fe934e64d0d1a53dd5c4 (patch)
tree62183e587fdee3cb7b1738a49c83cec719f485da /net-misc
parentsci-libs/cdf: x86 stable wrt bug #773076 (diff)
downloadgentoo-70d0659c3dbcaf2600e6fe934e64d0d1a53dd5c4.tar.gz
gentoo-70d0659c3dbcaf2600e6fe934e64d0d1a53dd5c4.tar.bz2
gentoo-70d0659c3dbcaf2600e6fe934e64d0d1a53dd5c4.zip
net-misc/youtube-dl: only mention optional pkgs if they are absent
Doing it with has_version directly because optfeature.eclass is geared towards short descriptions and several of these are anything but. Closes: https://bugs.gentoo.org/769917 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.05.16.ebuild39
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild39
-rw-r--r--net-misc/youtube-dl/youtube-dl-9999.ebuild39
3 files changed, 66 insertions, 51 deletions
diff --git a/net-misc/youtube-dl/youtube-dl-2021.05.16.ebuild b/net-misc/youtube-dl/youtube-dl-2021.05.16.ebuild
index 3d701ad41fa9..f6c4602df69f 100644
--- a/net-misc/youtube-dl/youtube-dl-2021.05.16.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-2021.05.16.ebuild
@@ -51,21 +51,26 @@ python_install_all() {
}
pkg_postinst() {
- elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
- elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
- elog
- elog "youtube-dl works fine on its own on most sites. However, if you want"
- elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
- elog "On some sites - most notably YouTube - videos can be retrieved in"
- elog "a higher quality format without sound. youtube-dl will detect whether"
- elog "ffmpeg is present and automatically pick the best option."
- elog
- elog "Videos or video formats streamed via RTMP protocol can only be"
- elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
- elog
- elog "Downloading MMS and RTSP videos requires either mplayer"
- elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
- elog
- elog "If you want youtube-dl to embed thumbnails from the metadata into the"
- elog "resulting MP4 files, consider installing media-video/atomicparsley"
+ if ! has_version media-video/ffmpeg; then
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need media-video/ffmpeg."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. ${PN} will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ fi
+ if ! has_version media-video/rtmpdump; then
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when media-video/rtmpdump is installed."
+ fi
+ if ! has_version media-video/mplayer && ! has_version media-video/mpv; then
+ elog
+ elog "Downloading MMS and RTSP videos requires either media-video/mplayer"
+ elog "or media-video/mpv to be installed."
+ fi
+ if ! has_version media-video/atomicparsley; then
+ elog
+ elog "Install media-video/atomicparsley if you want ${PN} to embed thumbnails"
+ elog "from the metadata into the resulting MP4/M4A files."
+ fi
}
diff --git a/net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild b/net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild
index 8ec79bfd981f..5d46a59d125b 100644
--- a/net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-2021.06.06.ebuild
@@ -48,21 +48,26 @@ python_install_all() {
}
pkg_postinst() {
- elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
- elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
- elog
- elog "youtube-dl works fine on its own on most sites. However, if you want"
- elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
- elog "On some sites - most notably YouTube - videos can be retrieved in"
- elog "a higher quality format without sound. youtube-dl will detect whether"
- elog "ffmpeg is present and automatically pick the best option."
- elog
- elog "Videos or video formats streamed via RTMP protocol can only be"
- elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
- elog
- elog "Downloading MMS and RTSP videos requires either mplayer"
- elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
- elog
- elog "If you want youtube-dl to embed thumbnails from the metadata into the"
- elog "resulting MP4 files, consider installing media-video/atomicparsley"
+ if ! has_version media-video/ffmpeg; then
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need media-video/ffmpeg."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. ${PN} will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ fi
+ if ! has_version media-video/rtmpdump; then
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when media-video/rtmpdump is installed."
+ fi
+ if ! has_version media-video/mplayer && ! has_version media-video/mpv; then
+ elog
+ elog "Downloading MMS and RTSP videos requires either media-video/mplayer"
+ elog "or media-video/mpv to be installed."
+ fi
+ if ! has_version media-video/atomicparsley; then
+ elog
+ elog "Install media-video/atomicparsley if you want ${PN} to embed thumbnails"
+ elog "from the metadata into the resulting MP4/M4A files."
+ fi
}
diff --git a/net-misc/youtube-dl/youtube-dl-9999.ebuild b/net-misc/youtube-dl/youtube-dl-9999.ebuild
index 50bd1337b3fd..6ea8ff1593c3 100644
--- a/net-misc/youtube-dl/youtube-dl-9999.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-9999.ebuild
@@ -52,21 +52,26 @@ python_install_all() {
}
pkg_postinst() {
- elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
- elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
- elog
- elog "youtube-dl works fine on its own on most sites. However, if you want"
- elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
- elog "On some sites - most notably YouTube - videos can be retrieved in"
- elog "a higher quality format without sound. youtube-dl will detect whether"
- elog "ffmpeg is present and automatically pick the best option."
- elog
- elog "Videos or video formats streamed via RTMP protocol can only be"
- elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
- elog
- elog "Downloading MMS and RTSP videos requires either mplayer"
- elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
- elog
- elog "If you want youtube-dl to embed thumbnails from the metadata into the"
- elog "resulting MP4 files, consider installing media-video/atomicparsley"
+ if ! has_version media-video/ffmpeg; then
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need media-video/ffmpeg."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. ${PN} will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ fi
+ if ! has_version media-video/rtmpdump; then
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when media-video/rtmpdump is installed."
+ fi
+ if ! has_version media-video/mplayer && ! has_version media-video/mpv; then
+ elog
+ elog "Downloading MMS and RTSP videos requires either media-video/mplayer"
+ elog "or media-video/mpv to be installed."
+ fi
+ if ! has_version media-video/atomicparsley; then
+ elog
+ elog "Install media-video/atomicparsley if you want ${PN} to embed thumbnails"
+ elog "from the metadata into the resulting MP4/M4A files."
+ fi
}