summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-03 13:05:59 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-03 13:07:07 +0100
commit7aca71bb5a34d00da67fb7e9d08afa18ee992204 (patch)
tree2d7b2ab14d8b79207b8d588fe49c29d80de11739 /net-news
parentmedia-libs/libwebp: amd64/x86 stable, bug #597756 (diff)
downloadgentoo-7aca71bb5a34d00da67fb7e9d08afa18ee992204.tar.gz
gentoo-7aca71bb5a34d00da67fb7e9d08afa18ee992204.tar.bz2
gentoo-7aca71bb5a34d00da67fb7e9d08afa18ee992204.zip
net-news/blam: Prepare for new gtk-sharp
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-news')
-rw-r--r--net-news/blam/blam-1.8.12-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-news/blam/blam-1.8.12-r1.ebuild b/net-news/blam/blam-1.8.12-r1.ebuild
new file mode 100644
index 000000000000..be575dbdf223
--- /dev/null
+++ b/net-news/blam/blam-1.8.12-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit mono-env gnome2
+
+DESCRIPTION="A RSS aggregator written in C#"
+HOMEPAGE="https://git.gnome.org/browse/blam"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/mono-2.6.0
+ dev-dotnet/dbus-sharp-glib:1.0
+ || ( >=dev-dotnet/gtk-sharp-2.12.21 ( >=dev-dotnet/gtk-sharp-2.12.6 >=dev-dotnet/glade-sharp-2.12.6 ) )
+ >=dev-dotnet/gconf-sharp-2.8.2
+ dev-dotnet/notify-sharp
+ >=dev-dotnet/webkit-sharp-0.2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/gconf-2.4
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ >=dev-util/intltool-0.25
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=702798
+ sed -i -e 's/.png//' blam.desktop.in.in || die
+ sed -i -e 's/Application;//' blam.desktop.in.in || die
+
+ gnome2_src_prepare
+}