summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-06-16 05:29:32 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-06-29 15:56:00 +0300
commit909a43287489284ede0304fc3bd913c49d80c345 (patch)
tree3538c99749d6dbe617cc948bf8ad0a297e771afa /net-news
parentapp-arch/drpm: drop 0.5.1 (diff)
downloadgentoo-909a43287489284ede0304fc3bd913c49d80c345.tar.gz
gentoo-909a43287489284ede0304fc3bd913c49d80c345.tar.bz2
gentoo-909a43287489284ede0304fc3bd913c49d80c345.zip
net-news/yydecode: Fix error: call to undeclared library function strcmp
Closes: https://bugs.gentoo.org/898078 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31475 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/yydecode/files/yydecode-0.2.10-fix-strcmp-not-found.patch15
-rw-r--r--net-news/yydecode/yydecode-0.2.10-r2.ebuild21
2 files changed, 36 insertions, 0 deletions
diff --git a/net-news/yydecode/files/yydecode-0.2.10-fix-strcmp-not-found.patch b/net-news/yydecode/files/yydecode-0.2.10-fix-strcmp-not-found.patch
new file mode 100644
index 000000000000..9fad34a3573a
--- /dev/null
+++ b/net-news/yydecode/files/yydecode-0.2.10-fix-strcmp-not-found.patch
@@ -0,0 +1,15 @@
+Bug: https://bugs.gentoo.org/898078
+Include string.h for strcmp functions
+diff --git a/src/getopt.c b/src/getopt.c
+index 10a4c32..adf91e7 100644
+--- a/src/getopt.c
++++ b/src/getopt.c
+@@ -67,6 +67,8 @@
+ #include <stdlib.h>
+ #endif /* GNU C library. */
+
++#include <string.h>
++
+ /* This version of `getopt' appears to the caller like standard Unix `getopt'
+ but it behaves differently for the user, since it allows the user
+ to intersperse the options with the other arguments.
diff --git a/net-news/yydecode/yydecode-0.2.10-r2.ebuild b/net-news/yydecode/yydecode-0.2.10-r2.ebuild
new file mode 100644
index 000000000000..2d41a1da9015
--- /dev/null
+++ b/net-news/yydecode/yydecode-0.2.10-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A decoder for yENC format, popular on Usenet"
+HOMEPAGE="http://yydecode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yydecode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.10-fix-strcmp-not-found.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s/t3.sh//" -e "s/t7.sh//" -i checks/Makefile.in || die
+}