summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-24 18:02:14 +0200
committerUlrich Müller <ulm@gentoo.org>2023-11-19 11:25:14 +0100
commite18d26bfcea05a4bb969f67edcd444020f8cb89c (patch)
tree393547e90d4be4472d307f2aaf6a603230577e1d /net-news
parentmedia-video/ffcast: EAPI8 bump, fix LICENSE, update github Links (diff)
downloadgentoo-e18d26bfcea05a4bb969f67edcd444020f8cb89c.tar.gz
gentoo-e18d26bfcea05a4bb969f67edcd444020f8cb89c.tar.bz2
gentoo-e18d26bfcea05a4bb969f67edcd444020f8cb89c.zip
net-news/amphetadesk: EAPI8 bump, use https
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/amphetadesk/amphetadesk-0.93.1-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-news/amphetadesk/amphetadesk-0.93.1-r2.ebuild b/net-news/amphetadesk/amphetadesk-0.93.1-r2.ebuild
new file mode 100644
index 000000000000..b8c1b2dc5c80
--- /dev/null
+++ b/net-news/amphetadesk/amphetadesk-0.93.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Free syndicated news aggregator"
+HOMEPAGE="https://www.disobey.com/amphetadesk/"
+SRC_URI="mirror://sourceforge/sourceforge/amphetadesk/${PN}-src-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-src-v${PV}"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/perl
+ dev-perl/libwww-perl
+ dev-libs/expat
+ dev-perl/XML-Parser
+ virtual/perl-IO-Compress"
+
+src_install() {
+ dodir /usr/share/amphetadesk
+ cp "${S}"/AmphetaDesk.pl "${D}"/usr/share/amphetadesk/AmphetaDesk.pl || die
+ dodoc README.txt
+ cp -R "${S}"/data "${D}"/usr/share/amphetadesk || die
+ cp -R "${S}"/docs "${D}"/usr/share/amphetadesk || die
+ cp -R "${S}"/lib "${D}"/usr/share/amphetadesk || die
+ cp -R "${S}"/templates "${D}"/usr/share/amphetadesk || die
+ newinitd "${FILESDIR}"/amphetadesk.initd amphetadesk || die
+}
+
+pkg_postinst() {
+ # fixes bug #25066 thanks to kloeri
+ /etc/init.d/depscan.sh
+
+ einfo "AmphetaDesk should be started and stopped with the runscript located at "
+ einfo "'/etc/init.d/amphetadesk'. You can access AmphetaDesk after it has been"
+ einfo "started in your browser of choice on port 8888."
+ einfo ""
+ ewarn "If you start AmphetaDesk at boot with rc-update don't give it a browser"
+ ewarn "to start up when it loads (in the options page)"
+}