summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2022-11-08 16:40:38 -0500
committerJoonas Niilola <juippis@gentoo.org>2022-11-22 15:36:12 +0200
commita86964660985424aaaa15a6119e353800d57179b (patch)
tree4e67f0c64a5d7f10ac1a80e1192d55f7c0d0542d /net-nntp
parentdev-util/conan: drop 1.47.0, 1.48.0 (diff)
downloadgentoo-a86964660985424aaaa15a6119e353800d57179b.tar.gz
gentoo-a86964660985424aaaa15a6119e353800d57179b.tar.bz2
gentoo-a86964660985424aaaa15a6119e353800d57179b.zip
net-nntp/sabnzbd: add 3.7.0
Signed-off-by: Joe Kappus <joe@wt.gd> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/sabnzbd/Manifest1
-rw-r--r--net-nntp/sabnzbd/sabnzbd-3.7.0.ebuild156
2 files changed, 157 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index 3b69a8e0ef03..46b3fa1cda02 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -1,2 +1,3 @@
DIST SABnzbd-3.6.0-src.tar.gz 5052873 BLAKE2B 41b6fb818e9bcf40bedd16e9b2a0d5b2590cdbef8a29187f0e995d11d036c60364ed6f297eb6c2bb3f257040ef66b9bd26bc8464b9af2adfac3922f4817918a6 SHA512 277953a10211b72532ef4c490cc77516ad4691e15f55bbc08572edba8fc4154ddde5d6bd62ea79c2279dad571038cab25194d6764bf1377dda25d522a5838a92
DIST SABnzbd-3.6.1-src.tar.gz 5051796 BLAKE2B a123b148290dd135f2eb375ce712b19b241907fd78935d9ec8cbb1b80b695c0aa0f92aff6b533e1966c84b9024f4c154a9708496331f85111906e6b068c22410 SHA512 7864f9252bbe8d66cd307e78911b03973554f1a2ccbba0e5ede536e4b7c679fe48cc1e334209688a9f9cd289b8bafc9a317dd02c6563e4151eba4fe2d81b9ddc
+DIST SABnzbd-3.7.0-src.tar.gz 5107150 BLAKE2B e582aaf09016ae34df8c49a1164d3f7e9a8ee85f734ae1066cc6d2c52f6a50a3de5d4abec30e0465d05629af73f4277920211557692e12f41d4b725476059796 SHA512 dbb18f06a0f5eec9ed4b946560073701bbb80ef20de9403ce92f408e96545fda5f7663dfd603723ea6c396c1a13dbb40e5868175d02e3218843138382c2a1335
diff --git a/net-nntp/sabnzbd/sabnzbd-3.7.0.ebuild b/net-nntp/sabnzbd/sabnzbd-3.7.0.ebuild
new file mode 100644
index 000000000000..b9a838d892ce
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-3.7.0.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit optfeature python-single-r1 systemd
+
+MY_PV="${PV/_rc/RC}"
+MY_PV="${MY_PV//_pre*}"
+
+MY_P="${PN/sab/SAB}-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cheetah3[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.10[${PYTHON_USEDEP}]
+ >=dev-python/guessit-3.1.0[${PYTHON_USEDEP}]
+ dev-python/notify2[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/puremagic[${PYTHON_USEDEP}]
+ ~dev-python/sabyenc-5.4.4[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ >=app-arch/par2cmdline-0.4
+ net-misc/wget
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tavalidate[${PYTHON_USEDEP}]
+ dev-python/tavern[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ ')
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ www-apps/chromedriver-bin
+ )
+"
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ # network sandbox
+ tests/test_getipaddress.py
+ tests/test_rss.py
+ tests/test_urlgrabber.py
+ tests/test_utils/test_happyeyeballs.py
+ tests/test_utils/test_internetspeed.py
+ )
+ local EPYTEST_DESELECT=(
+ # network sandbox
+ 'tests/test_cfg.py::TestValidators::test_validate_host'
+ 'tests/test_consistency.py::TestWiki'
+ # Just plain fails
+ 'tests/test_newsunpack.py::TestPar2Repair::test_basic'
+ # Chromedriver tests don't want to behave in portage
+ 'tests/test_functional_config.py::TestBasicPages::test_base_pages'
+ 'tests/test_functional_config.py::TestBasicPages::test_base_submit_pages'
+ 'tests/test_functional_config.py::TestConfigLogin::test_login'
+ 'tests/test_functional_config.py::TestConfigCategories::test_page'
+ 'tests/test_functional_config.py::TestConfigRSS::test_rss_basic_flow'
+ 'tests/test_functional_config.py::TestConfigServers::test_add_and_remove_server'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_basic_rar5'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_7zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_passworded'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_fully_obfuscated'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_unicode_rar'
+ 'tests/test_functional_misc.py::TestShowLogging::test_showlog'
+ 'tests/test_functional_misc.py::TestQueueRepair::test_queue_repair'
+ 'tests/test_functional_misc.py::TestDaemonizing::test_daemonizing'
+ )
+
+ epytest -s
+}
+
+src_install() {
+ local d
+ for d in email icons interfaces locale po sabnzbd scripts tools; do
+ insinto /usr/share/${PN}/${d}
+ doins -r ${d}/*
+ done
+
+ exeinto /usr/share/${PN}
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+ python_optimize "${ED}"/usr/share/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-r1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ diropts -o ${PN} -g ${PN}
+ dodir /etc/${PN}
+ keepdir /var/log/${PN}
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc ISSUES.txt README.mkd
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: /var/lib/${PN}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ fi
+
+ optfeature "7z archive support" app-arch/p7zip
+ optfeature "rar archive support" app-arch/unrar app-arch/rar
+ optfeature "zip archive support" app-arch/unzip
+}