summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2022-07-12 15:58:09 +0200
committerSam James <sam@gentoo.org>2022-08-03 23:54:49 +0100
commita3196cc835c7532279355fe56d7564868e43ff15 (patch)
tree79fbd43da79ca180d00adc2caf7a67121c6911d6 /net-p2p/go-ipfs
parentnet-p2p/go-ipfs: drop 0.12.2 (diff)
downloadgentoo-a3196cc835c7532279355fe56d7564868e43ff15.tar.gz
gentoo-a3196cc835c7532279355fe56d7564868e43ff15.tar.bz2
gentoo-a3196cc835c7532279355fe56d7564868e43ff15.zip
net-p2p/*: move go-ipfs -> kubo
Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26371 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/go-ipfs')
-rw-r--r--net-p2p/go-ipfs/Manifest1
-rw-r--r--net-p2p/go-ipfs/files/ipfs-at.service18
-rw-r--r--net-p2p/go-ipfs/files/ipfs.confd1
-rw-r--r--net-p2p/go-ipfs/files/ipfs.init17
-rw-r--r--net-p2p/go-ipfs/files/ipfs.service19
-rw-r--r--net-p2p/go-ipfs/go-ipfs-0.13.1.ebuild69
-rw-r--r--net-p2p/go-ipfs/metadata.xml16
7 files changed, 0 insertions, 141 deletions
diff --git a/net-p2p/go-ipfs/Manifest b/net-p2p/go-ipfs/Manifest
deleted file mode 100644
index 773ebd4ef95f..000000000000
--- a/net-p2p/go-ipfs/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST go-ipfs-0.13.1.tar.gz 13474891 BLAKE2B 2e6e056e27a8783c9d04ea5d8c41d86e45250f5ba95c57737aaf52d36d453be31baab21767008596710d7eb84f471460c32de70faf1764740ea551a5aa4bd38e SHA512 3257d49df61bb31d4054934506ea543df2d9ed1f57b9b6aeef001bb77fe9fdce646fec96ded72b7f9f99e3bc687da77997b1295ebb5a40e20e4df0413e15bfd7
diff --git a/net-p2p/go-ipfs/files/ipfs-at.service b/net-p2p/go-ipfs/files/ipfs-at.service
deleted file mode 100644
index c9ce91294177..000000000000
--- a/net-p2p/go-ipfs/files/ipfs-at.service
+++ /dev/null
@@ -1,18 +0,0 @@
-[Unit]
-Description=InterPlanetary File System
-After=network.target
-
-[Service]
-CPUSchedulingPolicy=batch
-Environment=IPFS_PATH=
-ExecStart=/usr/bin/ipfs daemon --enable-gc --migrate
-ExecStop=/usr/bin/ipfs shutdown
-LimitNOFILE=8192
-PrivateTmp=yes
-ProtectSystem=full
-Restart=on-failure
-Type=simple
-User=%i
-
-[Install]
-WantedBy=multi-user.target
diff --git a/net-p2p/go-ipfs/files/ipfs.confd b/net-p2p/go-ipfs/files/ipfs.confd
deleted file mode 100644
index f1e8eb77adf5..000000000000
--- a/net-p2p/go-ipfs/files/ipfs.confd
+++ /dev/null
@@ -1 +0,0 @@
-IPFS_PATH=/var/lib/ipfs/.ipfs
diff --git a/net-p2p/go-ipfs/files/ipfs.init b/net-p2p/go-ipfs/files/ipfs.init
deleted file mode 100644
index b3798b2175a5..000000000000
--- a/net-p2p/go-ipfs/files/ipfs.init
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-export IPFS_PATH=${IPFS_PATH:-/var/lib/ipfs/.ipfs}
-
-pidfile="/run/ipfs.pid"
-command="/usr/bin/ipfs"
-command_args="daemon --enable-gc --migrate"
-command_user="ipfs:ipfs"
-start_stop_daemon_args="--wait 1000 -b -m \
- -1 /var/log/ipfs/ipfs.log \
- -2 /var/log/ipfs/ipfs.log"
-
-depend() {
- need net
-}
diff --git a/net-p2p/go-ipfs/files/ipfs.service b/net-p2p/go-ipfs/files/ipfs.service
deleted file mode 100644
index 12e9d19fd965..000000000000
--- a/net-p2p/go-ipfs/files/ipfs.service
+++ /dev/null
@@ -1,19 +0,0 @@
-[Unit]
-Description=InterPlanetary File System
-After=network.target
-
-[Service]
-CPUSchedulingPolicy=batch
-Environment=IPFS_PATH=/var/lib/ipfs/.ipfs
-ExecStart=/usr/bin/ipfs daemon --enable-gc --migrate
-ExecStop=/usr/bin/ipfs shutdown
-Group=ipfs
-LimitNOFILE=8192
-PrivateTmp=yes
-ProtectSystem=full
-Restart=on-failure
-Type=simple
-User=ipfs
-
-[Install]
-WantedBy=multi-user.target
diff --git a/net-p2p/go-ipfs/go-ipfs-0.13.1.ebuild b/net-p2p/go-ipfs/go-ipfs-0.13.1.ebuild
deleted file mode 100644
index 3418b0d7a9b5..000000000000
--- a/net-p2p/go-ipfs/go-ipfs-0.13.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 go-module systemd
-
-DESCRIPTION="Main implementation of IPFS"
-HOMEPAGE="https://ipfs.io/"
-SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/${PN}-source.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- acct-group/ipfs
- acct-user/ipfs
- sys-fs/fuse:0
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
-
-S="${WORKDIR}"
-
-src_compile() {
- default
-
- local mygoargs
- mygoargs=(
- -tags release
- )
-
- go build "${mygoargs[@]}" -o ipfs ./cmd/ipfs || die
- go build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch || die
-
- IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
-}
-
-src_test() {
- go test ./cmd/ipfs/... ./cmd/ipfswatch/... || die
-}
-
-src_install() {
- dobin ipfs
- dobin ipfswatch
- newbashcomp ipfs-completion.bash ipfs
- einstalldocs
-
- systemd_dounit "${FILESDIR}/ipfs.service"
- systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
-
- newinitd "${FILESDIR}/ipfs.init" ipfs
- newconfd "${FILESDIR}/ipfs.confd" ipfs
-
- keepdir /var/log/ipfs
- fowners -R ipfs:ipfs /var/log/ipfs
-}
-
-pkg_postinst() {
- elog 'To be able to use the ipfs service you will need to create the ipfs repository'
- elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
- elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
-
- # See https://bugs.gentoo.org/838238
- ewarn 'In case go-ipfs CPU usage is too high run the next workaround'
- ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower"'
- ewarn 'Be aware that this will make your node less visible to other peers'
-}
diff --git a/net-p2p/go-ipfs/metadata.xml b/net-p2p/go-ipfs/metadata.xml
deleted file mode 100644
index 9e33ed00d6e0..000000000000
--- a/net-p2p/go-ipfs/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>davidroman96@gmail.com</email>
- <name>David Roman</name>
- </maintainer>
- <maintainer type="person" proxied="yes">
- <email>hurikhan77+bgo@gmail.com</email>
- <name>Kai Krakow</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
-</pkgmetadata>