summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-08-04 21:16:01 -0400
committerMike Gilbert <floppym@gentoo.org>2019-08-05 12:38:15 -0400
commitb761cec14174af726ba7429ff06595cae3e77d79 (patch)
tree93636a908eaf97eaac63163343ece49f32b65c12 /net-p2p/transmission
parentacct-user/transmission: new user (169) (diff)
downloadgentoo-b761cec14174af726ba7429ff06595cae3e77d79.tar.gz
gentoo-b761cec14174af726ba7429ff06595cae3e77d79.tar.bz2
gentoo-b761cec14174af726ba7429ff06595cae3e77d79.zip
net-p2p/transmission: depend on acct-user/transmission
Package-Manager: Portage-2.3.70_p2, Repoman-2.3.16_p22 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-p2p/transmission')
-rw-r--r--net-p2p/transmission/transmission-2.94.ebuild18
-rw-r--r--net-p2p/transmission/transmission-9999.ebuild20
2 files changed, 13 insertions, 25 deletions
diff --git a/net-p2p/transmission/transmission-2.94.ebuild b/net-p2p/transmission/transmission-2.94.ebuild
index 246560fb9ad7..745abf9221fa 100644
--- a/net-p2p/transmission/transmission-2.94.ebuild
+++ b/net-p2p/transmission/transmission-2.94.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools flag-o-matic gnome2-utils qmake-utils systemd user xdg-utils
+inherit autotools flag-o-matic gnome2-utils qmake-utils systemd xdg-utils
DESCRIPTION="A Fast, Easy and Free BitTorrent client"
HOMEPAGE="http://www.transmissionbt.com/"
@@ -16,7 +16,7 @@ SLOT=0
IUSE="ayatana gtk libressl lightweight systemd qt5 xfs"
KEYWORDS="amd64 ~arm ~arm64 ~mips ppc ppc64 x86 ~x86-fbsd ~amd64-linux"
-RDEPEND=">=dev-libs/libevent-2.0.10:=
+COMMON_DEPEND=">=dev-libs/libevent-2.0.10:=
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-libs/libnatpmp
@@ -37,7 +37,7 @@ RDEPEND=">=dev-libs/libevent-2.0.10:=
dev-qt/qtwidgets:5
)
systemd? ( >=sys-apps/systemd-209:= )"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
>=dev-libs/glib-2.32
dev-util/intltool
sys-devel/gettext
@@ -45,6 +45,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
qt5? ( dev-qt/linguist-tools:5 )
xfs? ( sys-fs/xfsprogs )"
+RDEPEND="${COMMON_DEPEND}
+ acct-user/transmission"
REQUIRED_USE="ayatana? ( gtk )"
@@ -137,14 +139,6 @@ pkg_postinst() {
xdg_desktop_database_update
gnome2_icon_cache_update
- enewgroup transmission
- enewuser transmission -1 -1 /var/lib/transmission transmission
-
- if [[ ! -e "${EROOT%/}"/var/lib/transmission ]]; then
- mkdir -p "${EROOT%/}"/var/lib/transmission || die
- chown transmission:transmission "${EROOT%/}"/var/lib/transmission || die
- fi
-
elog "If you use transmission-daemon, please, set 'rpc-username' and"
elog "'rpc-password' (in plain text, transmission-daemon will hash it on"
elog "start) in settings.json file located at /var/lib/transmission/config or"
diff --git a/net-p2p/transmission/transmission-9999.ebuild b/net-p2p/transmission/transmission-9999.ebuild
index 392d8cb5bf3e..312540191f40 100644
--- a/net-p2p/transmission/transmission-9999.ebuild
+++ b/net-p2p/transmission/transmission-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils gnome2-utils readme.gentoo-r1 systemd user xdg-utils
+inherit cmake-utils gnome2-utils readme.gentoo-r1 systemd xdg-utils
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -24,7 +24,7 @@ SLOT="0"
IUSE="ayatana gtk libressl lightweight nls mbedtls qt5 systemd test"
RESTRICT="!test? ( test )"
-RDEPEND="
+COMMON_DEPEND="
dev-libs/libb64:0=
>=dev-libs/libevent-2.0.10:=
!mbedtls? (
@@ -51,7 +51,7 @@ RDEPEND="
)
systemd? ( >=sys-apps/systemd-209:= )
"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
nls? (
virtual/libintl
@@ -64,6 +64,9 @@ DEPEND="${RDEPEND}
)
)
"
+RDEPEND="${COMMON_DEPEND}
+ acct-user/transmission
+"
src_unpack() {
if [[ ${PV} == 9999 ]]; then
@@ -137,14 +140,5 @@ pkg_postrm() {
pkg_postinst() {
xdg_desktop_database_update
gnome2_icon_cache_update
-
- enewgroup transmission
- enewuser transmission -1 -1 /var/lib/transmission transmission
-
- if [[ ! -e "${EROOT%/}"/var/lib/transmission ]]; then
- mkdir -p "${EROOT%/}"/var/lib/transmission || die
- chown transmission:transmission "${EROOT%/}"/var/lib/transmission || die
- fi
-
readme.gentoo_print_elog
}