summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-12-24 13:20:16 -0800
committerZac Medico <zmedico@gentoo.org>2017-12-24 13:21:17 -0800
commit014388ce4792b759ac7763847cda533cea67ee8b (patch)
tree516eb1a127f33ac9fe7c21276543cdc0d2f6f5b7 /net-p2p
parentvirtual/python-funcsigs: keyword for amd64-fbsd. (diff)
downloadgentoo-014388ce4792b759ac7763847cda533cea67ee8b.tar.gz
gentoo-014388ce4792b759ac7763847cda533cea67ee8b.tar.bz2
gentoo-014388ce4792b759ac7763847cda533cea67ee8b.zip
net-p2p/go-ethereum: version bump to 1.7.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest1
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index 5da5f63e312a..a20740e7195b 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1 +1,2 @@
DIST go-ethereum-1.7.2.tar.gz 7037907 BLAKE2B eb1e358e42c743a931995e7ee46dc2441356159fc9095e8a886cc6a0495cb2d2e77ee7df4c6dd98bc790397819fc43cdedba6cf28de1e4f3dcdc4dd71106f8e5 SHA512 7bc5957f1523fa5ec67650c4305633aa4c6098a243ef415f9ef56a4e4763eb2ef9f69514ed15810fcdb75f11e87cbd27c4f2af802c32a03be91b37a7b08ea520
+DIST go-ethereum-1.7.3.tar.gz 8188445 BLAKE2B abfa7fff970ea740376e05a56c51a83ba62853b68fd1de1a7161192da294558ea2939427119d00aadcb9e00b8b487e1acfae058e0c5ab6dbe3531e4db0b446cb SHA512 c50391f84b64c924c56d8d052a5c910f94869d86b080cd9b3355a48e094e7f5d4a05a631a57a74619b677067be5da21d6018d18a81bd014bceed43d3626cb017
diff --git a/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild b/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
new file mode 100644
index 000000000000..a7fce9166ec3
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-base
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools opencl"
+
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ use opencl && export GO_OPENCL=true
+
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ if use devtools; then
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/evm
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ dobin build/bin/swarm
+ dobin build/bin/wnode
+ fi
+}