summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-18 21:23:49 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-20 21:03:00 +0200
commit2b3b816f48221612ef3ca0def29ce808d140e443 (patch)
tree3bc8a9aee50a6c287fd25c4c0da196ecccc601d9 /net-p2p
parentacct-user/bitflu: add user (148) bitflu (diff)
downloadgentoo-2b3b816f48221612ef3ca0def29ce808d140e443.tar.gz
gentoo-2b3b816f48221612ef3ca0def29ce808d140e443.tar.bz2
gentoo-2b3b816f48221612ef3ca0def29ce808d140e443.zip
net-p2p/bitflu: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781443 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitflu/bitflu-1.52-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-p2p/bitflu/bitflu-1.52-r1.ebuild b/net-p2p/bitflu/bitflu-1.52-r1.ebuild
new file mode 100644
index 000000000000..f6d0d7367da5
--- /dev/null
+++ b/net-p2p/bitflu/bitflu-1.52-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="BitTorrent client, written in Perl and is designed to run as a daemon"
+HOMEPAGE="http://bitflu.workaround.ch"
+SRC_URI="http://bitflu.workaround.ch/bitflu/${P}.tgz"
+
+LICENSE="Artistic-2 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ acct-group/bitflu
+ acct-user/bitflu
+ dev-perl/Danga-Socket
+ dev-perl/Sys-Syscall
+"
+RDEPEND="${DEPEND}"
+
+src_compile() { :; }
+
+src_install() {
+ local PLUGINS="/usr/lib/bitflu"
+ local CONFDIR="/etc/bitflu"
+ local LOGDIR="/var/log/bitflu"
+
+ # executable daemon
+ dosbin bitflu.pl
+
+ # plugins
+ insinto "${PLUGINS}"
+ doins -r plugins
+
+ # config file
+ insinto "${CONFDIR}"
+ fowners bitflu:bitflu "${CONFDIR}"
+ fperms 775 "${CONFDIR}"
+ doins "${FILESDIR}"/bitflu.config
+ fowners bitflu:bitflu "${CONFDIR}"/bitflu.config
+ fperms 664 "${CONFDIR}"/bitflu.config
+
+ # log file
+ keepdir "${LOGDIR}"
+ fowners bitflu:bitflu "${LOGDIR}"
+ fperms 775 "${LOGDIR}"
+
+ # docs
+ dodoc bitflu.config.example ChangeLog.txt CONTRIBUTING README_IPv6.txt \
+ README.txt Documentation/bitflu-internals.txt
+
+ newinitd "${FILESDIR}"/bitflu.initd bitflu
+}
+
+pkg_postinst() {
+ ewarn "Note: At startup, or at the user's request, ${PN} (re)reads its"
+ ewarn "configuration file and overwrites it with its own sanitized"
+ ewarn "version. A backup is created in the configuration directory,"
+ ewarn "/etc/${PN}, but that file will subseqently be overwritten if"
+ ewarn "a further backup is made. You may want to keep your own backup."
+ ewarn "A prestine example with comments may be found in /usr/share/doc/${P}."
+}