summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2018-09-13 09:58:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-18 11:26:00 +0200
commit2d1fec4428a682bd450e2ca0cd98335b0fa9696c (patch)
tree32ec1a88efa4a45a6d5d1e820105d28730e92b35 /net-p2p
parentnet-analyzer/linkchecker: add missing runtime dependency (diff)
downloadgentoo-2d1fec4428a682bd450e2ca0cd98335b0fa9696c.tar.gz
gentoo-2d1fec4428a682bd450e2ca0cd98335b0fa9696c.tar.bz2
gentoo-2d1fec4428a682bd450e2ca0cd98335b0fa9696c.zip
net-p2p/go-ethereum: version bump to 1.8.15, restrict test
test is restricted because it tries to connect to the docker daemon and other fun network activities Closes: https://bugs.gentoo.org/665436 Closes: https://bugs.gentoo.org/653542 Package-Manager: Portage[mgorny]-2.3.43.3
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest1
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.8.15.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index 1577deb49260..1fc16204ea42 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1 +1,2 @@
+DIST go-ethereum-1.8.15.tar.gz 11101556 BLAKE2B 19c92a473be363da3070cc6d264e2826b05430ed22fab2fa2567baaea3bd03f056d540639fc9f247cf3d45ded30ef28e5611f4eb0fda36324d46a0e1dad0e581 SHA512 d542881cbc2712eb35d327f26e14384fcfd273cfc9ee2b231c2a59bd1db18297a8444443551c186aa4942af2b5143e062845dcb2fa7c1daba50a6158a4ffe57f
DIST go-ethereum-1.8.2.tar.gz 9129180 BLAKE2B 8a1e841c8c9f0c0f0adcb08610996c0a06b0133aae89fc0b67543a4aa6d0209b9dbb5b5cff5fc83eb62f7b00ff650cedb7823d640fe4d222698063c8d818f1d5 SHA512 d09bb18098e866ecbabf8e5b796e1a93c125556525b55eaddc2ec870ea84ca861feab3f56b83f31adf9e5d4001df6f2045b82b9224a6017cc6791be04d202271
diff --git a/net-p2p/go-ethereum/go-ethereum-1.8.15.ebuild b/net-p2p/go-ethereum/go-ethereum-1.8.15.ebuild
new file mode 100644
index 000000000000..74e968bc7959
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.8.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-base
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools opencl"
+
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+
+# Does all kinds of wonky stuff like connecting to Docker daemon, network activity, ...
+RESTRICT="test"
+
+src_compile() {
+ use opencl && export GO_OPENCL=true
+
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ if use devtools; then
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/evm
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ dobin build/bin/swarm
+ dobin build/bin/wnode
+ fi
+}