summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-31 22:42:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-31 22:53:51 +0200
commit4f83b3f69496d974a028f7637fab8c078d4d948d (patch)
treece3f95e31b96f7bc3b1136ddfb2e1ffcfcb219c4 /net-p2p
parentnet-libs/libktorrent: 2.1 version bump (diff)
downloadgentoo-4f83b3f69496d974a028f7637fab8c078d4d948d.tar.gz
gentoo-4f83b3f69496d974a028f7637fab8c078d4d948d.tar.bz2
gentoo-4f83b3f69496d974a028f7637fab8c078d4d948d.zip
net-p2p/ktorrent: 5.1.0 version bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Manifest1
-rw-r--r--net-p2p/ktorrent/ktorrent-5.1.0.ebuild102
-rw-r--r--net-p2p/ktorrent/metadata.xml6
3 files changed, 109 insertions, 0 deletions
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
index e6d6c2e6b41f..238b67f7c138 100644
--- a/net-p2p/ktorrent/Manifest
+++ b/net-p2p/ktorrent/Manifest
@@ -1 +1,2 @@
DIST ktorrent-5.0.1.tar.xz 2152908 SHA256 d00feeca5dcc6a76a039d67dbe91a2d5a5e1da0f5e0bbd8da2c156d9c44879e5 SHA512 6ceced3d578e58f480ada5b71a66be244c75de726389d39b40c02c5a9445c6bb0b70573fac810abd1659c3172bff79c0c3e5cbfe1a84e0d50836b52291597bc1 WHIRLPOOL 11d59e1762b12e0c740337b05e9e678f71df1a5d43cffee6dcb1a3159afe1da00c118b62b84fdb80dbd6d98f3998250882406e8e61ad181b67b7043d350c8682
+DIST ktorrent-5.1.0.tar.xz 2046916 SHA256 3c57882f78006dcec3c5fb243479e995cc541e51e6acded5bf98a09900c486a3 SHA512 7bfe3a04a2b0f62d68b41c946af34e9f6ead6aa4ff7818a9c0ce2e83629d311e9e9be5fb1689065ce2601c43bd576b27d8c6946b845d4cdf5fa6362d53e8dd25 WHIRLPOOL 4be8e029e468d714a890652e77a6c6d1261a1ccc3b2114aae547bd5df38b2745a5d0836b86c4e0029ab13470cab66789b870da3536d183c106232f7bd960697f
diff --git a/net-p2p/ktorrent/ktorrent-5.1.0.ebuild b/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
new file mode 100644
index 000000000000..5f8e82acbce6
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+inherit kde5
+
+DESCRIPTION="Powerful BitTorrent client based on KDE Frameworks"
+HOMEPAGE="https://www.kde.org/applications/internet/ktorrent/"
+SRC_URI="mirror://kde/stable/${PN}/${PV/%.0}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bwscheduler +downloadorder +infowidget +ipfilter +kross +logviewer +magnetgenerator
++mediaplayer rss +scanfolder +search +shutdown +stats +upnp +zeroconf"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ =net-libs/libktorrent-2.1*:5
+ infowidget? ( dev-libs/geoip )
+ kross? (
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kross)
+ )
+ mediaplayer? (
+ media-libs/phonon[qt5(+)]
+ >=media-libs/taglib-1.5
+ )
+ rss? (
+ $(add_frameworks_dep kdewebkit)
+ $(add_kdeapps_dep syndication)
+ )
+ search? (
+ $(add_frameworks_dep kdewebkit)
+ $(add_qt_dep qtwebkit)
+ )
+ shutdown? ( $(add_plasma_dep plasma-workspace) )
+ stats? ( $(add_frameworks_dep kplotting) )
+ upnp? ( $(add_frameworks_dep kcompletion) )
+ zeroconf? ( $(add_frameworks_dep kdnssd) )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ $(add_frameworks_dep ktextwidgets)
+ $(add_kdeapps_dep kio-extras)
+ )
+ !net-p2p/ktorrent:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BWSCHEDULER_PLUGIN=$(usex bwscheduler)
+ -DENABLE_DOWNLOADORDER_PLUGIN=$(usex downloadorder)
+ -DENABLE_INFOWIDGET_PLUGIN=$(usex infowidget)
+ -DWITH_SYSTEM_GEOIP=$(usex infowidget)
+ -DENABLE_IPFILTER_PLUGIN=$(usex ipfilter)
+ -DENABLE_SCRIPTING_PLUGIN=$(usex kross)
+ -DENABLE_LOGVIEWER_PLUGIN=$(usex logviewer)
+ -DENABLE_MAGNETGENERATOR_PLUGIN=$(usex magnetgenerator)
+ -DENABLE_MEDIAPLAYER_PLUGIN=$(usex mediaplayer)
+ $(cmake-utils_use_find_package rss KF5Syndication)
+ -DENABLE_SCANFOLDER_PLUGIN=$(usex scanfolder)
+ -DENABLE_SEARCH_PLUGIN=$(usex search)
+ -DENABLE_SHUTDOWN_PLUGIN=$(usex shutdown)
+ -DENABLE_STATS_PLUGIN=$(usex stats)
+ -DENABLE_UPNP_PLUGIN=$(usex upnp)
+ -DENABLE_ZEROCONF_PLUGIN=$(usex zeroconf)
+ )
+# add back when ported
+# -DENABLE_WEBINTERFACE_PLUGIN=$(usex webinterface)
+ kde5_src_configure
+}
diff --git a/net-p2p/ktorrent/metadata.xml b/net-p2p/ktorrent/metadata.xml
index b9c2ba1ec081..4bd864220a5c 100644
--- a/net-p2p/ktorrent/metadata.xml
+++ b/net-p2p/ktorrent/metadata.xml
@@ -9,11 +9,17 @@
<flag name="bwscheduler">Schedule upload and download limits over a period of a week</flag>
<flag name="downloadorder">Specify the download order of a multi-file torrent</flag>
<flag name="infowidget">Displays general information about a torrent in several tabs</flag>
+ <flag name="ipfilter">Filter IP addresses through a blocklist</flag>
+ <flag name="kross">Enable kross scripting support</flag>
<flag name="logviewer">Displays the logging output</flag>
<flag name="magnetgenerator">Generates magnet URI's</flag>
<flag name="mediaplayer">Phonon-based media player</flag>
+ <flag name="rss">Syndication plugin for KTorrent, supporting RSS and Atom feeds</flag>
+ <flag name="scanfolder">Scan folders for torrent files and load them</flag>
+ <flag name="search">Search for torrents</flag>
<flag name="shutdown">Shutdown when done</flag>
<flag name="stats">Shows statistics about torrents in several graphs</flag>
+ <flag name="upnp">Forward ports using UPnP</flag>
<flag name="zeroconf">Discover peers on the local network using the Zeroconf protocol</flag>
</use>
</pkgmetadata>