summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2017-11-08 08:44:32 +0100
committerMarek Szuba <marecki@gentoo.org>2017-11-08 08:44:32 +0100
commitc6de0eb2a14315c154945bd49f05ec30caae076b (patch)
tree3b67c8ad9214f7096286fc743af7908ac6670175 /net-p2p
parentdev-python/weasyprint: Bump (diff)
downloadgentoo-c6de0eb2a14315c154945bd49f05ec30caae076b.tar.gz
gentoo-c6de0eb2a14315c154945bd49f05ec30caae076b.tar.bz2
gentoo-c6de0eb2a14315c154945bd49f05ec30caae076b.zip
net-p2p/syncthing: bump to 0.14.40
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-0.14.40.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index dbd2015b181a..7632c78a54cb 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,2 +1,3 @@
DIST syncthing-0.14.35.tar.gz 8235883 SHA256 58509294a150d137fbd005b5629d2859cce661d25e8063505813c4e7faa62fae SHA512 2a3de76e7118be6e91b8bc6bc69b10e250755836b378fa762e0feaed280bb2206d2e4552f09fd230d51e246633108fd8cff343ac355742ebb1bd06c2145fe086 WHIRLPOOL bdc971896378fe04576273cab23432f3dfdd96f77d464c0ea0bc8143771a40a15520d20ce2e76ccd790e78c04421f92e31ce1af04f66760a4f101b8b67b6c852
DIST syncthing-0.14.38.tar.gz 8246629 SHA256 76c1dab5873d6f3b9799ad3e5dcab4c17fb0f5a699fe845bd081f162d96f4477 SHA512 be5f7527d63e8db427705c34b26d783d9abd7cb5727d3dcf08ee62b1ace5454b7dfed4f030ec53e847a34f560cf349460f68c859a1008c5105aef65ef42c5cc5 WHIRLPOOL c71799207eaa6dfac7839ead25dd551c76f00823f70d9bfc1bc72409ef410dbdb28cf9df3742a97a56f12cf0c705262299eec164313a027118be177ce6b5458f
+DIST syncthing-0.14.40.tar.gz 8300965 SHA256 b9820dceb472531f20ebd18ab53a66876970c9d78d22c93ff53c3c879363d6be SHA512 3e79b034d71d1c862d21433f897dc774d3e421628804ed9c8304d4ed0dccb90fa8ec738aef476bf074ba70d4c9947114c5b6a8326faa5d6b6e5dcc03dacabecb WHIRLPOOL cad84ccdd6ed94cf2ea664f13c77b53a51cfa1928723e898134654a7cff9e05748438cc05620c9bae6f147a173f4ed4d564a1c48ccdb73b87c7d3f7a39089494
diff --git a/net-p2p/syncthing/syncthing-0.14.40.ebuild b/net-p2p/syncthing/syncthing-0.14.40.ebuild
new file mode 100644
index 000000000000..d86360de0e77
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-0.14.40.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-vcs-snapshot systemd user versionator
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="selinux tools"
+
+RDEPEND="selinux? ( sec-policy/selinux-syncthing )"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ if use tools ; then
+ # separate user for the relay server
+ enewgroup strelaysrv
+ enewuser strelaysrv -1 -1 /var/lib/strelaysrv strelaysrv
+ # and his home folder
+ keepdir /var/lib/strelaysrv
+ fowners strelaysrv:strelaysrv /var/lib/strelaysrv
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ export GOPATH="${S}:$(get_golibdir_gopath)"
+ cd src/${EGO_PN} || die
+ go run build.go -version "v${PV}" -no-upgrade install \
+ $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ cd src/${EGO_PN} || die
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ pushd src/${EGO_PN} >& /dev/null || die
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+ if use tools ; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+ popd >& /dev/null || die
+
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ if use tools ; then
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}/strelaysrv.confd" strelaysrv
+ newinitd "${FILESDIR}/strelaysrv.initd" strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/strelaysrv.logrotate" strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(get_version_component_range 2) -gt \
+ $(get_version_component_range 2 ${v}) ]]; then
+ ewarn "Version ${PV} is not protocol-compatible with version" \
+ "0.$(($(get_version_component_range 2) - 1)).x or lower."
+ ewarn "Make sure all your devices are running at least version" \
+ "0.$(get_version_component_range 2).0."
+ fi
+ ewarn "Syncthing OpenRC init script now uses the upstream default of"
+ ewarn ""
+ ewarn " /var/lib/${PN}/.config/${PN}"
+ ewarn ""
+ ewarn "as its configuration directory. Please set SYNCTHING_HOMEDIR"
+ ewarn "to /var/lib/${PN} in /etc/conf.d/${PN} if you wish to continue"
+ ewarn "using the old Gentoo default. Systemd users are not affected."
+ done
+
+ # check if user syncthing-relaysrv exists
+ # if yes, warn that it has been moved to strelaysrv
+ if [[ -n "$(egetent passwd syncthing-relaysrv 2>/dev/null)" ]]; then
+ ewarn
+ ewarn "The user and group for the relay server have been changed"
+ ewarn "from syncthing-relaysrv to strelaysrv"
+ ewarn "The old user and group are not deleted automatically. Delete them by running:"
+ ewarn " userdel -r syncthing-relaysrv"
+ ewarn " groupdel syncthing-relaysrv"
+ fi
+}