summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-12-22 22:55:46 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-12-22 22:56:01 +1100
commitd72e05e650250612ef0c4b28e5b05f03b8614cb1 (patch)
tree55c35e18a46c11c9f45dd4b92465dcb65a593e32 /net-p2p
parentqt5-build.eclass: use the system-configured linker (diff)
downloadgentoo-d72e05e650250612ef0c4b28e5b05f03b8614cb1.tar.gz
gentoo-d72e05e650250612ef0c4b28e5b05f03b8614cb1.tar.bz2
gentoo-d72e05e650250612ef0c4b28e5b05f03b8614cb1.zip
net-p2p/qbittorrent: improve Werror handling
Closes: https://bugs.gentoo.org/641010 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild4
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild2
3 files changed, 10 insertions, 3 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild b/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
index ddac9c49ab69..6511503962b7 100644
--- a/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
@@ -45,6 +45,13 @@ DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # bug 641010
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DSYSTEM_QTSINGLEAPPLICATION=ON
diff --git a/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
index 7316bdc01781..9ebc91b0bdb1 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.0.3.ebuild
@@ -44,10 +44,10 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
src_prepare() {
- default
+ cmake-utils_src_prepare
# bug 641382
- sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
}
src_configure() {
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 26971a131175..9ebc91b0bdb1 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -44,7 +44,7 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
src_prepare() {
- default
+ cmake-utils_src_prepare
# bug 641382
sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die