summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/shadowsocks-libev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/shadowsocks-libev')
-rw-r--r--net-proxy/shadowsocks-libev/Manifest2
-rw-r--r--net-proxy/shadowsocks-libev/files/shadowsocks.initd52
-rw-r--r--net-proxy/shadowsocks-libev/files/shadowsocks.json8
-rw-r--r--net-proxy/shadowsocks-libev/metadata.xml17
-rw-r--r--net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.1.ebuild49
-rw-r--r--net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.2.ebuild49
6 files changed, 177 insertions, 0 deletions
diff --git a/net-proxy/shadowsocks-libev/Manifest b/net-proxy/shadowsocks-libev/Manifest
new file mode 100644
index 000000000000..dcfea531a7d3
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/Manifest
@@ -0,0 +1,2 @@
+DIST shadowsocks-libev-2.2.1.tar.gz 2492392 SHA256 c8013bc56e507855913dd8972f3c629c1b0c58a7012c4c459186d7f6a0cfe953 SHA512 34209a0b86cf261bc544d2622015662918dc51f4e2bea115644653b20cede7b87360111b10d5dc194a3115099ae4256bf455472e0ed3da9af316a23d304c9bfc WHIRLPOOL b4bcc80edb33816ace40455670b5b243ec8d7d9018a11675a152767069b70aad2150260753e5e305e3921730c4d4b1c49f216f4f1179c682a8b18018bac11740
+DIST shadowsocks-libev-2.2.2.tar.gz 2492615 SHA256 9919d041a6ee4f7b7de2ea7209533b0b9d5fd5732eaa430a6f4055f6e7f1c23f SHA512 0d83a506e2ab95aa8ba1d1815d2e0a8213b96a901cf5e8939c00900167af96ae6045071f39fc07ac7daba328bc2eb1e89b0286e1e98744a8750916ec81b47f27 WHIRLPOOL 281ec6e2cc264c265c7a5b7de733e6cc71151a6d05c2fbf6f43b5cc8bea970229f74d04ec0633cd46d7fb49187d0fa834fcc0a0b039e078230168d89d0344432
diff --git a/net-proxy/shadowsocks-libev/files/shadowsocks.initd b/net-proxy/shadowsocks-libev/files/shadowsocks.initd
new file mode 100644
index 000000000000..d32e6df9a915
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/files/shadowsocks.initd
@@ -0,0 +1,52 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+SS_CONFIG="/etc/shadowsocks.json"
+
+SS_PIDFILE="/run/shadowsocks.pid"
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f ${SS_CONFIG} ]; then
+ ewarn "${SS_CONFIG} does not exist."
+ fi
+
+ SS_SVCNAME="${RC_SVCNAME#*.}"
+ case ${SS_SVCNAME} in
+ client)
+ SS_COMMAND="/usr/bin/ss-local"
+ return 0
+ ;;
+ server)
+ SS_COMMAND="/usr/bin/ss-server"
+ return 0
+ ;;
+ *)
+ eerror "please choose to run as server or client mode"
+ eerror " server: rc-update add shadowsocks.server default"
+ eerror " client: rc-update add shadowsocks.client default"
+ return 1
+ ;;
+ esac
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Shadowsocks: ${SS_SVCNAME} mode"
+ start-stop-daemon --start --exec ${SS_COMMAND} \
+ -- -c ${SS_CONFIG} -f ${SS_PIDFILE} >/dev/null 2>&1 &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Shadowsocks"
+ start-stop-daemon --stop --pidfile ${SS_PIDFILE}
+ eend $?
+}
+
diff --git a/net-proxy/shadowsocks-libev/files/shadowsocks.json b/net-proxy/shadowsocks-libev/files/shadowsocks.json
new file mode 100644
index 000000000000..a29c3a59b0ef
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/files/shadowsocks.json
@@ -0,0 +1,8 @@
+{
+ "server":"server ip",
+ "server_port":8388,
+ "local_port":1080,
+ "password":"password",
+ "timeout":600,
+ "method":"aes-256-cfb"
+}
diff --git a/net-proxy/shadowsocks-libev/metadata.xml b/net-proxy/shadowsocks-libev/metadata.xml
new file mode 100644
index 000000000000..e983078a92d8
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <use>
+ <flag name="openssl">Use <pkg>dev-libs/openssl</pkg> as crypto backend</flag>
+ <flag name="polarssl">Use <pkg>net-libs/polarssl</pkg> as crypto backend</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">shadowsocks/shadowsocks-libev</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.1.ebuild b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.1.ebuild
new file mode 100644
index 000000000000..d871ca0b138d
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A lightweight secured scoks5 proxy for embedded devices and low end boxes"
+HOMEPAGE="https://github.com/shadowsocks/shadowsocks-libev"
+
+MY_PV="v${PV}"
+SRC_URI="https://github.com/shadowsocks/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +openssl polarssl"
+
+DEPEND="openssl? ( dev-libs/openssl:= )
+ polarssl? ( net-libs/polarssl )
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE=" ^^ ( openssl polarssl )"
+
+src_configure() {
+ econf \
+ $(use_enable debug assert) \
+ --with-crypto-library=$(usex openssl openssl polarssl)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ insinto "/etc/"
+ newins "${FILESDIR}/shadowsocks.json" shadowsocks.json
+
+ newinitd "${FILESDIR}/shadowsocks.initd" shadowsocks
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.server
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.client
+}
+
+pkg_setup() {
+ elog "You need to choose to run as server or client mode"
+ elog " server: rc-update add shadowsocks.server default"
+ elog " client: rc-update add shadowsocks.client default"
+}
diff --git a/net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.2.ebuild b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.2.ebuild
new file mode 100644
index 000000000000..d871ca0b138d
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A lightweight secured scoks5 proxy for embedded devices and low end boxes"
+HOMEPAGE="https://github.com/shadowsocks/shadowsocks-libev"
+
+MY_PV="v${PV}"
+SRC_URI="https://github.com/shadowsocks/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +openssl polarssl"
+
+DEPEND="openssl? ( dev-libs/openssl:= )
+ polarssl? ( net-libs/polarssl )
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE=" ^^ ( openssl polarssl )"
+
+src_configure() {
+ econf \
+ $(use_enable debug assert) \
+ --with-crypto-library=$(usex openssl openssl polarssl)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ insinto "/etc/"
+ newins "${FILESDIR}/shadowsocks.json" shadowsocks.json
+
+ newinitd "${FILESDIR}/shadowsocks.initd" shadowsocks
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.server
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.client
+}
+
+pkg_setup() {
+ elog "You need to choose to run as server or client mode"
+ elog " server: rc-update add shadowsocks.server default"
+ elog " client: rc-update add shadowsocks.client default"
+}